aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb
deleted file mode 100644
index 9b2d1be1..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.4.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SECTION = "kernel"
-SUMMARY = "Linux kernel for TI devices"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-
-inherit kernel
-
-DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
-require recipes-kernel/linux/setup-defconfig.inc
-require recipes-kernel/linux/cmem.inc
-require recipes-kernel/linux/ti-uio.inc
-require recipes-kernel/linux/bundle-devicetree.inc
-require recipes-kernel/linux/kernel-rdepends.inc
-
-# Look in the generic major.minor directory for files
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.4:"
-
-KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
-
-S = "${WORKDIR}/git"
-
-BRANCH = "ti-linux-5.4.y"
-
-SRCREV = "023faefa70274929bff92dc41167b007f7523792"
-PV = "5.4.106+git${SRCPV}"
-
-# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
-MACHINE_KERNEL_PR:append = "a"
-PR = "${MACHINE_KERNEL_PR}"
-
-KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
-KERNEL_GIT_PROTOCOL = "git"
-SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
- file://defconfig"
-
-FILES:${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"
-
-# Special configuration for remoteproc/rpmsg IPC modules
-module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
-module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
-module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
-KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
-KERNEL_MODULE_AUTOLOAD:append:j7 = " rpmsg_kdrv_switch"