aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch')
-rw-r--r--recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
index bb27dea..90f1372 100644
--- a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
+++ b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
@@ -1,4 +1,4 @@
-From c7b1100f40c30a0cd5d1bc8869044e2881a8592b Mon Sep 17 00:00:00 2001
+From 19f38c23dc290f2a820c7d2c8b880568cdf90154 Mon Sep 17 00:00:00 2001
From: Fabio Berton <fabio.berton@ossystems.com.br>
Date: Wed, 12 Jun 2019 14:18:31 -0300
Subject: [PATCH] Allow enable DRI without DRI drivers
@@ -8,19 +8,18 @@ Upstream-Status: Pending
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
---
meson.build | 2 +-
meson_options.txt | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 70962fbb3f4..17c328ef90d 100644
+index af1f63041ce..224d930d4d5 100644
--- a/meson.build
+++ b/meson.build
-@@ -185,7 +185,7 @@ with_dri_r200 = dri_drivers.contains('r200')
+@@ -188,7 +188,7 @@ with_dri_r100 = dri_drivers.contains('r100')
+ with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
- with_dri_swrast = dri_drivers.contains('swrast')
-with_dri = dri_drivers.length() != 0
+with_dri = get_option('dri') or (dri_drivers.length() != 0 and dri_drivers != [''])
@@ -28,7 +27,7 @@ index 70962fbb3f4..17c328ef90d 100644
gallium_drivers = get_option('gallium-drivers')
if gallium_drivers.contains('auto')
diff --git a/meson_options.txt b/meson_options.txt
-index 057e3bebe32..faaf6388752 100644
+index fbb86f3f896..a8b021d718e 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -41,6 +41,12 @@ option(
@@ -44,3 +43,6 @@ index 057e3bebe32..faaf6388752 100644
option(
'dri-drivers',
type : 'array',
+--
+2.30.1
+