aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend8
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb6
-rw-r--r--recipes-kernel/linux/linux-qcom-bootimg.inc4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend4
4 files changed, 11 insertions, 11 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c22ada0..3d6a10d 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,10 +1,10 @@
# Enable freedreno driver
-GALLIUMDRIVERS_append_ifc6410 = ",freedreno"
-GALLIUMDRIVERS_append_dragonboard-410c = ",freedreno"
+GALLIUMDRIVERS_append_apq8064 = ",freedreno"
+GALLIUMDRIVERS_append_apq8016 = ",freedreno"
-PACKAGECONFIG_append_ifc6410 = " gallium \
+PACKAGECONFIG_append_apq8064 = " gallium \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
"
-PACKAGECONFIG_append_dragonboard-410c = " gallium \
+PACKAGECONFIG_append_apq8016 = " gallium \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
index 689c444..0cbe4bc 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bb
@@ -13,8 +13,8 @@ SRCREV ?= "f404da21e128bc015dfcbb88d3daf2bcf18ef872"
COMPATIBLE_MACHINE = "(ifc6410|dragonboard-410c)"
-KERNEL_DEFCONFIG_dragonboard-410c ?= "${S}/arch/arm64/configs/defconfig"
-KERNEL_DEFCONFIG_ifc6410 ?= "${S}/arch/arm/configs/qcom_defconfig"
+KERNEL_DEFCONFIG_apq8016 ?= "${S}/arch/arm64/configs/defconfig"
+KERNEL_DEFCONFIG_apq8064 ?= "${S}/arch/arm/configs/qcom_defconfig"
KERNEL_CONFIG_FRAGMENTS += "${S}/kernel/configs/distro.config"
# fixup.bin needs to be prepended to zImage to fixup the atag mem info because of broken bootloaders.
@@ -28,7 +28,7 @@ do_compile_append_ifc6410() {
}
# append DTB, since bootloader doesn't support DTB
-do_compile_append_ifc6410() {
+do_compile_append_apq8064() {
if ! [ -e ${B}/arch/${ARCH}/boot/dts/${KERNEL_DEVICETREE} ] ; then
oe_runmake ${KERNEL_DEVICETREE}
fi
diff --git a/recipes-kernel/linux/linux-qcom-bootimg.inc b/recipes-kernel/linux/linux-qcom-bootimg.inc
index 78c6bd7..96e1496 100644
--- a/recipes-kernel/linux/linux-qcom-bootimg.inc
+++ b/recipes-kernel/linux/linux-qcom-bootimg.inc
@@ -13,7 +13,7 @@ DT_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
BOOT_IMAGE_BASE_NAME = "boot-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
BOOT_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
-do_deploy_append_dragonboard-410c() {
+do_deploy_append_apq8016() {
dtbTool -o ${DEPLOYDIR}/${DT_IMAGE_BASE_NAME}.img -s 2048 ${B}/arch/${ARCH}/boot/dts/qcom/
@@ -40,7 +40,7 @@ do_deploy_append_dragonboard-410c() {
cd -
}
-do_deploy_append_ifc6410 () {
+do_deploy_append_apq8064 () {
tmp="${SERIAL_CONSOLES}"
baudrate=`echo $tmp | sed 's/\;.*//'`
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index fa6ba2b..13d759a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1,5 +1,5 @@
GST_BAD_OPENGL_FEATURES= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gles2', 'opengl', d)}"
# We want OpenGL with freedreno for our machines
-PACKAGECONFIG_GL_ifc6410 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
-PACKAGECONFIG_GL_dragonboard-410c = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
+PACKAGECONFIG_GL_apq8064 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"
+PACKAGECONFIG_GL_apq8016 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${GST_BAD_OPENGL_FEATURES}', '', d)}"