aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/qrtr/files/qrtr.service11
-rw-r--r--recipes-support/qrtr/qrtr_git.bb9
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-support/qrtr/files/qrtr.service b/recipes-support/qrtr/files/qrtr.service
new file mode 100644
index 0000000..e2f1952
--- /dev/null
+++ b/recipes-support/qrtr/files/qrtr.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=QRTR service
+After=systemd-remount-fs.service
+
+[Service]
+ExecStartPre=/usr/bin/qrtr-cfg 1
+ExecStart=/usr/bin/qrtr-ns
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index f76e437..74ccb79 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -5,8 +5,11 @@ SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
+inherit systemd
+
SRCREV = "56074bd5fe8f487b3a681b73e669cdbfe3b7b555"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
+SRC_URI += "file://qrtr.service"
PV = "0.0+${SRCPV}"
@@ -14,7 +17,13 @@ S = "${WORKDIR}/git"
do_install () {
oe_runmake install DESTDIR=${D}
+
+ sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/qrtr.service
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/qrtr.service ${D}${systemd_unitdir}/system
}
+SYSTEMD_SERVICE_${PN} = "qrtr.service"
+
PACKAGES =+ "qrtr-apps"
FILES_qrtr-apps = "${bindir}/*"