aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/premerge.yml10
-rw-r--r--.github/workflows/push.yml21
-rw-r--r--conf/machine/sdx55-mtp.conf2
-rw-r--r--conf/machine/sdx55-telit-fn980.conf2
-rw-r--r--recipes-devtools/skales/skales_git.bb4
-rw-r--r--recipes-kernel/linux/linux-linaro-qcom.inc2
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb4
7 files changed, 32 insertions, 13 deletions
diff --git a/.github/workflows/premerge.yml b/.github/workflows/premerge.yml
index 42dfa4b..6b9fd0f 100644
--- a/.github/workflows/premerge.yml
+++ b/.github/workflows/premerge.yml
@@ -1,14 +1,16 @@
-name: PR build test
+name: PR build
on:
pull_request_target:
jobs:
build:
- uses: ndechesne/meta-qcom/.github/workflows/premerge-template.yml@master
+ uses: ndechesne/meta-qcom/.github/workflows/build-template.yml@master
with:
host: ubuntu-20.04
images: core-image-base core-image-weston core-image-x11 initramfs-test-image initramfs-test-full-image cryptodev-module
- machines: >-
- ['dragonboard-410c', 'qcom-armv8a', 'sdx55-mtp']
+ machines: dragonboard-410c qcom-armv8a sdx55-mtp
+ ref: refs/pull/${{github.event.pull_request.number}}/merge
+ branch: ${{github.base_ref}}
+ url: ${{github.server_url}}/${{github.repository}}
secrets: inherit
diff --git a/.github/workflows/push.yml b/.github/workflows/push.yml
new file mode 100644
index 0000000..bd144a8
--- /dev/null
+++ b/.github/workflows/push.yml
@@ -0,0 +1,21 @@
+name: Push build
+
+on:
+ push:
+ branches:
+ - master
+ - honister
+ - dunfell
+
+jobs:
+ build:
+ uses: ndechesne/meta-qcom/.github/workflows/build-template.yml@master
+ with:
+ host: ubuntu-20.04
+ images: core-image-base core-image-weston core-image-x11 initramfs-test-image initramfs-test-full-image cryptodev-module
+ machines: dragonboard-410c qcom-armv8a sdx55-mtp
+ ref: ${{github.sha}}
+ ref_type: sha
+ branch: ${{github.ref_name}}
+ url: ${{github.server_url}}/${{github.repository}}
+ secrets: inherit
diff --git a/conf/machine/sdx55-mtp.conf b/conf/machine/sdx55-mtp.conf
index b37278b..dda313c 100644
--- a/conf/machine/sdx55-mtp.conf
+++ b/conf/machine/sdx55-mtp.conf
@@ -16,5 +16,3 @@ UBINIZE_ARGS ?= "-m 4096 -p 256KiB -s 4096"
# Use system partition for rootfs
UBI_VOLNAME ?= "system"
QCOM_BOOTIMG_ROOTFS ?= "ubi0:system"
-
-PREFERRED_PROVIDER_virtual/kernel = "linux-linaro-qcomlt-dev"
diff --git a/conf/machine/sdx55-telit-fn980.conf b/conf/machine/sdx55-telit-fn980.conf
index f9cbf2e..7514c7e 100644
--- a/conf/machine/sdx55-telit-fn980.conf
+++ b/conf/machine/sdx55-telit-fn980.conf
@@ -18,5 +18,3 @@ UBI_VOLNAME ?= "system"
QCOM_BOOTIMG_ROOTFS ?= "ubi0:system"
SERIAL_CONSOLES = "921600;ttyMSM0"
-
-PREFERRED_PROVIDER_virtual/kernel = "linux-linaro-qcomlt-dev"
diff --git a/recipes-devtools/skales/skales_git.bb b/recipes-devtools/skales/skales_git.bb
index 2b04657..134cc1e 100644
--- a/recipes-devtools/skales/skales_git.bb
+++ b/recipes-devtools/skales/skales_git.bb
@@ -1,6 +1,6 @@
SUMMARY = "Tools to create boot images for QCOM SoC"
-HOMEPAGE = "https://www.codeaurora.org/cgit/quic/kernel/skales/"
+HOMEPAGE = "https://git.codelinaro.org/clo/qsdk/oss/tools/skales"
SECTION = "devel"
LICENSE = "BSD-3-Clause"
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://mkbootimg;beginline=3;endline=29;md5=114b84083e657f38
SRCREV = "6eac9e943de53c4aaaede3697e9226a47686fe25"
PV = "1.5.0+git${SRCPV}"
-SRC_URI = "git://source.codeaurora.org/quic/kernel/skales;protocol=http;branch=master \
+SRC_URI = "git://git.codelinaro.org/clo/qsdk/oss/tools/skales.git;protocol=https;branch=caf_migration/skales/master \
file://0002-mkbootimg-use-python3.patch \
"
diff --git a/recipes-kernel/linux/linux-linaro-qcom.inc b/recipes-kernel/linux/linux-linaro-qcom.inc
index 40883f5..176321e 100644
--- a/recipes-kernel/linux/linux-linaro-qcom.inc
+++ b/recipes-kernel/linux/linux-linaro-qcom.inc
@@ -15,7 +15,7 @@ SRCBRANCH = "release/qcomlt-${PV}"
COMPATIBLE_MACHINE = "(qcom)"
-LINUX_LINARO_QCOM_GIT ?= "git://git.linaro.org/landing-teams/working/qualcomm/kernel.git;protocol=https"
+LINUX_LINARO_QCOM_GIT ?= "git://git.codelinaro.org/linaro/qcomlt/kernel.git;protocol=https"
SRC_URI = "${LINUX_LINARO_QCOM_GIT};branch=${SRCBRANCH}"
S = "${WORKDIR}/git"
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
index d883b26..ed5af39 100644
--- a/recipes-support/fastrpc/fastrpc_git.bb
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -1,4 +1,4 @@
-HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+HOMEPAGE = "https://git.codelinaro.org/linaro/qcomlt/fastrpc.git"
SUMMARY = "Qualcomm FastRPC applications and library"
SECTION = "devel"
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f9
SRCREV = "5a8320c46df8c0dbefe71d97a8273f417e8721f3"
SRC_URI = "\
- git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https \
+ git://git.codelinaro.org/linaro/qcomlt/fastrpc.git;branch=automake;protocol=https \
file://0001-apps_std_fopen_with_env-account-for-domain-kinds-whe.patch \
file://adsprpcd.service \
file://cdsprpcd.service \