aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf9
-rw-r--r--recipes-graphics/images/weston-chromium-image.bb18
-rw-r--r--recipes-graphics/images/weston-image.bb18
3 files changed, 9 insertions, 36 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 61a4870..ed3f7af 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -10,3 +10,12 @@ BBFILE_PATTERN_qcom := "^${LAYERDIR}/"
BBFILE_PRIORITY_qcom = "5"
QCOM_EULA_FILE = "${LAYERDIR}/conf/EULA"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+# includes customization and/or backports
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
diff --git a/recipes-graphics/images/weston-chromium-image.bb b/recipes-graphics/images/weston-chromium-image.bb
deleted file mode 100644
index d7bf4dd..0000000
--- a/recipes-graphics/images/weston-chromium-image.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Basic Wayland image with Chromium/Wayland"
-
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"
-
-LICENSE = "MIT"
-
-inherit core-image distro_features_check extrausers
-
-# let's make sure we have a good image..
-REQUIRED_DISTRO_FEATURES = "wayland pam systemd"
-
-CORE_IMAGE_BASE_INSTALL += "weston weston-examples clutter-1.0-examples \
- e2fsprogs-resize2fs chromium kernel-modules connman"
-
-EXTRA_USERS_PARAMS = "\
-useradd -p '' linaro; \
-usermod -a -G weston-launch linaro; \
-"
diff --git a/recipes-graphics/images/weston-image.bb b/recipes-graphics/images/weston-image.bb
deleted file mode 100644
index a1c033f..0000000
--- a/recipes-graphics/images/weston-image.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Basic Wayland image with Weston"
-
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"
-
-LICENSE = "MIT"
-
-inherit core-image distro_features_check extrausers
-
-# let's make sure we have a good image..
-REQUIRED_DISTRO_FEATURES = "wayland pam systemd"
-
-CORE_IMAGE_BASE_INSTALL += "weston weston-examples clutter-1.0-examples \
- e2fsprogs-resize2fs kernel-modules connman"
-
-EXTRA_USERS_PARAMS = "\
-useradd -p '' linaro; \
-usermod -a -G weston-launch linaro; \
-"