aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/classpath/classpath-0.98/SimpleName.diff66
-rw-r--r--recipes-core/classpath/classpath-0.98/javanet-local.patch37
-rw-r--r--recipes-core/classpath/classpath-0.99/autotools.patch118
-rw-r--r--recipes-core/classpath/classpath-0.99/ecj_java_dir.patch (renamed from recipes-core/classpath/classpath-0.98/ecj_java_dir.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/fix-gmp.patch (renamed from recipes-core/classpath/classpath-0.98/fix-gmp.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/miscompilation.patch (renamed from recipes-core/classpath/classpath-0.98/miscompilation.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch (renamed from recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch)72
-rw-r--r--recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch (renamed from recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch)0
-rw-r--r--recipes-core/classpath/classpath-initial-0.93/autotools.patch (renamed from recipes-core/classpath/files/autotools.patch)0
-rw-r--r--recipes-core/classpath/classpath-initial_0.93.bb3
-rw-r--r--recipes-core/classpath/classpath-native.inc12
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb (renamed from recipes-core/classpath/classpath-native_0.98.bb)21
-rw-r--r--recipes-core/classpath/classpath.inc6
-rw-r--r--recipes-core/classpath/classpath_0.98.bb15
-rw-r--r--recipes-core/classpath/classpath_0.99.bb14
15 files changed, 180 insertions, 184 deletions
diff --git a/recipes-core/classpath/classpath-0.98/SimpleName.diff b/recipes-core/classpath/classpath-0.98/SimpleName.diff
deleted file mode 100644
index ff2bec0..0000000
--- a/recipes-core/classpath/classpath-0.98/SimpleName.diff
+++ /dev/null
@@ -1,66 +0,0 @@
-Index: vm/reference/java/lang/VMClass.java
-===================================================================
-RCS file: /sources/classpath/classpath/vm/reference/java/lang/VMClass.java,v
-retrieving revision 1.20
-diff -u -r1.20 VMClass.java
---- vm/reference/java/lang/VMClass.java 18 Sep 2007 21:52:38 -0000 1.20
-+++ vm/reference/java/lang/VMClass.java 19 Apr 2008 15:19:00 -0000
-@@ -296,27 +296,43 @@
- */
- static String getSimpleName(Class klass)
- {
-+ int arrayCount = 0;
-+ while (klass.isArray())
-+ {
-+ klass = klass.getComponentType();
-+ ++arrayCount;
-+ }
-+ // now klass is the component type
-+
-+ String simpleComponentName = null;
- if (isAnonymousClass(klass))
-- return "";
-- if (isArray(klass))
- {
-- return getComponentType(klass).getSimpleName() + "[]";
-+ simpleComponentName = "";
- }
-- String fullName = getName(klass);
-- int pos = fullName.lastIndexOf("$");
-- if (pos == -1)
-- pos = 0;
- else
- {
-- ++pos;
-- while (Character.isDigit(fullName.charAt(pos)))
-- ++pos;
-+ String fullName = getName(klass);
-+ int pos = fullName.lastIndexOf("$");
-+ if (pos != -1)
-+ { //inner class or local class
-+ // skip digits of local classes
-+ while (Character.isDigit(fullName.charAt(pos+1)))
-+ pos++;
-+ }
-+ else
-+ {
-+ pos = fullName.lastIndexOf(".");
-+ }
-+ simpleComponentName = fullName.substring(pos+1);
- }
-- int packagePos = fullName.lastIndexOf(".", pos);
-- if (packagePos == -1)
-- return fullName.substring(pos);
-- else
-- return fullName.substring(packagePos + 1);
-+
-+ if (arrayCount == 0)
-+ return simpleComponentName;
-+
-+ StringBuffer sb = new StringBuffer(simpleComponentName);
-+ while (arrayCount-- > 0)
-+ sb.append("[]");
-+ return sb.toString();
- }
-
- /**
diff --git a/recipes-core/classpath/classpath-0.98/javanet-local.patch b/recipes-core/classpath/classpath-0.98/javanet-local.patch
deleted file mode 100644
index b8d1584..0000000
--- a/recipes-core/classpath/classpath-0.98/javanet-local.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: native/jni/java-net/local.c
-===================================================================
-RCS file: /sources/classpath/classpath/native/jni/java-net/local.c,v
-retrieving revision 1.4
-diff -u -r1.4 local.c
---- native/jni/java-net/local.c 17 Apr 2007 21:46:27 -0000 1.4
-+++ native/jni/java-net/local.c 27 Jun 2008 13:14:40 -0000
-@@ -73,27 +73,18 @@
- return socket (PF_UNIX, stream ? SOCK_STREAM : SOCK_DGRAM, 0);
- }
-
--static int gcc_sucks = 0;
--
- int
- local_bind (int fd, const char *addr)
- {
- struct sockaddr_un saddr;
-
-- /* For some reason, GCC 4.0.1 on Darwin/x86 MODIFIES the `addr'
-- pointer in the CALLER's STACK FRAME after calling this function,
-- but if we add this statement below, it doesn't! */
-- if (gcc_sucks)
-- fprintf (stderr, "bind %p\n", addr);
--
-- if (strlen (addr) > sizeof (saddr.sun_path))
-+ if (strlen (addr) >= sizeof (saddr.sun_path))
- {
- errno = ENAMETOOLONG;
- return -1;
- }
-
-- strncpy (saddr.sun_path, addr, sizeof (saddr.sun_path));
-- saddr.sun_path[sizeof (saddr.sun_path)] = '\0';
-+ strcpy (saddr.sun_path, addr);
- saddr.sun_family = AF_LOCAL;
-
- return bind (fd, (struct sockaddr *) &saddr, SUN_LEN (&saddr));
diff --git a/recipes-core/classpath/classpath-0.99/autotools.patch b/recipes-core/classpath/classpath-0.99/autotools.patch
new file mode 100644
index 0000000..6a077a0
--- /dev/null
+++ b/recipes-core/classpath/classpath-0.99/autotools.patch
@@ -0,0 +1,118 @@
+Index: classpath-0.99/configure.ac
+===================================================================
+--- classpath-0.99.orig/configure.ac 2012-03-08 19:03:15.000000000 +0100
++++ classpath-0.99/configure.ac 2012-07-18 23:16:41.047796558 +0200
+@@ -42,6 +42,9 @@
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local/classpath)
+
++AC_PROG_MKDIR_P
++AM_ICONV_LINK
++
+ dnl -----------------------------------------------------------
+ dnl Enable collections.jar (disabled by default)
+ dnl -----------------------------------------------------------
+@@ -382,6 +385,7 @@
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_PROG_CPP
++AM_PROG_CC_C_O
+
+ # Handle -Werror default case.
+ if test "$ENABLE_WERROR" = default; then
+Index: classpath-0.99/examples/Makefile.am
+===================================================================
+--- classpath-0.99.orig/examples/Makefile.am 2008-09-14 18:49:43.000000000 +0200
++++ classpath-0.99/examples/Makefile.am 2012-07-18 23:17:58.604498498 +0200
+@@ -96,9 +96,9 @@
+ endif
+
+ $(EXAMPLE_ZIP): $(EXAMPLE_JAVA_FILES)
+- @mkdir_p@ classes/gnu/classpath/examples/icons
++ $(MKDIR_P) classes/gnu/classpath/examples/icons
+ cp $(EXAMPLE_ICONS) classes/gnu/classpath/examples/icons
+- @mkdir_p@ classes/gnu/classpath/examples/swing
++ $(MKDIR_P) classes/gnu/classpath/examples/swing
+ cp $(EXAMPLE_HTML) classes/gnu/classpath/examples/swing
+ $(JCOMPILER) -d classes $(EXAMPLE_JAVA_FILES)
+ (cd classes; \
+Index: classpath-0.99/lib/Makefile.am
+===================================================================
+--- classpath-0.99.orig/lib/Makefile.am 2011-05-29 11:07:06.000000000 +0200
++++ classpath-0.99/lib/Makefile.am 2012-07-18 23:18:55.769018757 +0200
+@@ -83,18 +83,18 @@
+ resources: copy-vmresources.sh
+ @list=`cd $(top_srcdir)/resource && $(FIND) gnu java javax org -name \*\.properties -print -o -name \*\.css -print`; for p in $$list; do \
+ dirname=`dirname $$p`; \
+- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
++ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
+ cp $(top_srcdir)/resource/$$p $$p; \
+ done
+ @list=`cd $(top_srcdir)/resource && $(FIND) META-INF -name CVS -prune -o -name .svn -prune -o -name \*\.in -prune -o -type f -print`; for p in $$list; do \
+ dirname=`dirname $$p`; \
+- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
++ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
+ cp $(top_srcdir)/resource/$$p $$p; \
+ done
+ @$(SHELL) ./copy-vmresources.sh
+ @list=`cd $(top_srcdir) && $(FIND) gnu/javax/swing/plaf/gtk/icons -name *.png -type f -print`; for p in $$list; do \
+ dirname=`dirname $$p`; \
+- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
++ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
+ cp $(top_srcdir)/$$p $$p; \
+ done
+ touch resources
+@@ -102,7 +102,7 @@
+ classes: genclasses
+
+ $(top_builddir)/gnu/java/locale/LocaleData.java: $(top_srcdir)/scripts/generate-locale-list.sh
+- @mkdir_p@ $(top_builddir)/gnu/java/locale
++ $(MKDIR_P) $(top_builddir)/gnu/java/locale
+ $(top_srcdir)/scripts/generate-locale-list.sh > $(top_builddir)/gnu/java/locale/LocaleData.java
+
+ genclasses: gen-classlist.sh standard.omit $(top_builddir)/gnu/java/locale/LocaleData.java gen-xpath-parser
+@@ -160,7 +160,7 @@
+ -rm -rf lists
+
+ dist-hook:
+- @mkdir_p@ $(distdir)
++ $(MKDIR_P) $(distdir)
+ cp -pdfR $(top_srcdir)/gnu $(top_srcdir)/java $(top_srcdir)/javax $(top_srcdir)/org $(top_srcdir)/sun $(top_srcdir)/vm $(top_srcdir)/resource $(distdir)/..
+ # Delete not wanted files.
+ $(FIND) $(distdir)/../gnu $(distdir)/../java $(distdir)/../javax $(distdir)/../org $(distdir)/../sun $(distdir)/../vm $(distdir)/../resource -name CVS -print | xargs rm -fr
+Index: classpath-0.99/tools/Makefile.am
+===================================================================
+--- classpath-0.99.orig/tools/Makefile.am 2012-07-18 23:13:23.782018215 +0200
++++ classpath-0.99/tools/Makefile.am 2012-07-18 23:20:02.701629749 +0200
+@@ -314,11 +314,11 @@
+ # so they get also included.
+ $(TOOLS_ZIP): $(ALL_TOOLS_FILES)
+ @rm -rf classes asm
+- @mkdir_p@ classes asm
++ $(MKDIR_P) classes asm
+ if CREATE_GJDOC
+ if CREATE_GJDOC_PARSER
+ ## Generate antlr sources.
+- @mkdir_p@ $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr
++ $(MKDIR_P) $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr
+ $(ANTLR) -o $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr/ \
+ $(srcdir)/gnu/classpath/tools/gjdoc/expr/java-expression.g
+ endif
+@@ -348,7 +348,7 @@
+ sun/rmi/rmic $(GJDOC_EX) -name \*.properties -print -o -name \*.jav -print`; \
+ for p in $$list; do \
+ dirname=classes/`dirname $$p`; \
+- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
++ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
+ echo " cp $(srcdir)/resource/$$p classes/$$p"; \
+ cp $(srcdir)/resource/$$p classes/$$p; \
+ done
+@@ -356,7 +356,7 @@
+ ## Copy over gjdoc resource files.
+ for res in $(gjdoc_resources); do \
+ dir=classes/`dirname $$res`; \
+- if ! test -d "$$dir"; then @mkdir_p@ "$$dir"; fi; \
++ if ! test -d "$$dir"; then $(MKDIR_P) "$$dir"; fi; \
+ echo " cp $(srcdir)/resource/gnu/classpath/tools/gjdoc/$$res classes/$$res"; \
+ cp $(srcdir)/resource/gnu/classpath/tools/gjdoc/$$res classes/$$res; \
+ done
diff --git a/recipes-core/classpath/classpath-0.98/ecj_java_dir.patch b/recipes-core/classpath/classpath-0.99/ecj_java_dir.patch
index 1455a24..1455a24 100644
--- a/recipes-core/classpath/classpath-0.98/ecj_java_dir.patch
+++ b/recipes-core/classpath/classpath-0.99/ecj_java_dir.patch
diff --git a/recipes-core/classpath/classpath-0.98/fix-gmp.patch b/recipes-core/classpath/classpath-0.99/fix-gmp.patch
index 3f0dfbe..3f0dfbe 100644
--- a/recipes-core/classpath/classpath-0.98/fix-gmp.patch
+++ b/recipes-core/classpath/classpath-0.99/fix-gmp.patch
diff --git a/recipes-core/classpath/classpath-0.98/miscompilation.patch b/recipes-core/classpath/classpath-0.99/miscompilation.patch
index c61b214..c61b214 100644
--- a/recipes-core/classpath/classpath-0.98/miscompilation.patch
+++ b/recipes-core/classpath/classpath-0.99/miscompilation.patch
diff --git a/recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch b/recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch
index fb9cd9d..4ec8b1e 100644
--- a/recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch
+++ b/recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch
@@ -1,7 +1,7 @@
Index: gnu/classpath/debug/Simple1LineFormatter.java
===================================================================
--- gnu/classpath/debug/Simple1LineFormatter.java.orig 2006-07-11 18:03:59.000000000 +0200
-+++ gnu/classpath/debug/Simple1LineFormatter.java 2009-03-19 19:00:47.000000000 +0100
++++ gnu/classpath/debug/Simple1LineFormatter.java 2012-07-18 23:08:46.803554178 +0200
@@ -38,8 +38,6 @@
package gnu.classpath.debug;
@@ -22,8 +22,8 @@ Index: gnu/classpath/debug/Simple1LineFormatter.java
* by default in the JDK logging handlers.
Index: gnu/classpath/debug/SystemLogger.java
===================================================================
---- gnu/classpath/debug/SystemLogger.java.orig 2006-12-10 21:25:41.000000000 +0100
-+++ gnu/classpath/debug/SystemLogger.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/classpath/debug/SystemLogger.java.orig 2010-06-03 21:11:20.000000000 +0200
++++ gnu/classpath/debug/SystemLogger.java 2012-07-18 23:08:46.803554178 +0200
@@ -38,13 +38,13 @@
package gnu.classpath.debug;
@@ -42,8 +42,8 @@ Index: gnu/classpath/debug/SystemLogger.java
public static final SystemLogger SYSTEM = new SystemLogger();
Index: gnu/java/security/PolicyFile.java
===================================================================
---- gnu/java/security/PolicyFile.java.orig 2008-06-16 00:07:30.000000000 +0200
-+++ gnu/java/security/PolicyFile.java 2009-03-19 19:01:31.000000000 +0100
+--- gnu/java/security/PolicyFile.java.orig 2010-06-03 21:11:53.000000000 +0200
++++ gnu/java/security/PolicyFile.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.classpath.debug.SystemLogger;
@@ -63,7 +63,7 @@ Index: gnu/java/security/PolicyFile.java
* permissions are specified by a <em>policy file</em>.
Index: gnu/java/security/action/GetPropertyAction.java
===================================================================
---- gnu/java/security/action/GetPropertyAction.java 2006-12-10 21:25:42.000000000 +0100
+--- gnu/java/security/action/GetPropertyAction.java 2010-06-03 21:11:54.000000000 +0200
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
@@ -1,89 +0,0 @@
-/* GetPropertyAction.java
@@ -125,7 +125,7 @@ Index: gnu/java/security/action/GetPropertyAction.java
- public GetPropertyAction()
- {
- }
--
+-
- public GetPropertyAction(String propName)
- {
- setParameters(propName);
@@ -135,12 +135,12 @@ Index: gnu/java/security/action/GetPropertyAction.java
- {
- setParameters(propName, defaultValue);
- }
--
+-
- public String run()
- {
- return System.getProperty(name, value);
- }
--
+-
- public GetPropertyAction setParameters(String propName)
- {
- this.name = propName;
@@ -157,8 +157,8 @@ Index: gnu/java/security/action/GetPropertyAction.java
-}
Index: gnu/java/security/key/dss/DSSKey.java
===================================================================
---- gnu/java/security/key/dss/DSSKey.java.orig 2008-03-16 23:04:49.000000000 +0100
-+++ gnu/java/security/key/dss/DSSKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/dss/DSSKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/dss/DSSKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -178,8 +178,8 @@ Index: gnu/java/security/key/dss/DSSKey.java
* Standard) keys. It encapsulates the three DSS numbers: <code>p</code>,
Index: gnu/java/security/key/dss/DSSPrivateKey.java
===================================================================
---- gnu/java/security/key/dss/DSSPrivateKey.java.orig 2008-03-16 23:04:49.000000000 +0100
-+++ gnu/java/security/key/dss/DSSPrivateKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/dss/DSSPrivateKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/dss/DSSPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -42,7 +42,6 @@
import gnu.java.security.Configuration;
@@ -196,11 +196,11 @@ Index: gnu/java/security/key/dss/DSSPrivateKey.java
+
/**
* An object that embodies a DSS (Digital Signature Standard) private key.
- *
+ *
Index: gnu/java/security/key/dss/DSSPublicKey.java
===================================================================
---- gnu/java/security/key/dss/DSSPublicKey.java.orig 2008-03-16 23:04:49.000000000 +0100
-+++ gnu/java/security/key/dss/DSSPublicKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/dss/DSSPublicKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/dss/DSSPublicKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -217,11 +217,11 @@ Index: gnu/java/security/key/dss/DSSPublicKey.java
+
/**
* An object that embodies a DSS (Digital Signature Standard) public key.
- *
+ *
Index: gnu/java/security/key/rsa/GnuRSAKey.java
===================================================================
---- gnu/java/security/key/rsa/GnuRSAKey.java.orig 2008-03-16 23:04:49.000000000 +0100
-+++ gnu/java/security/key/rsa/GnuRSAKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/rsa/GnuRSAKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/rsa/GnuRSAKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -241,8 +241,8 @@ Index: gnu/java/security/key/rsa/GnuRSAKey.java
*/
Index: gnu/java/security/key/rsa/GnuRSAPrivateKey.java
===================================================================
---- gnu/java/security/key/rsa/GnuRSAPrivateKey.java.orig 2008-03-16 23:04:50.000000000 +0100
-+++ gnu/java/security/key/rsa/GnuRSAPrivateKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/rsa/GnuRSAPrivateKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/rsa/GnuRSAPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -262,8 +262,8 @@ Index: gnu/java/security/key/rsa/GnuRSAPrivateKey.java
* <p>
Index: gnu/java/security/key/rsa/GnuRSAPublicKey.java
===================================================================
---- gnu/java/security/key/rsa/GnuRSAPublicKey.java.orig 2008-03-16 23:04:50.000000000 +0100
-+++ gnu/java/security/key/rsa/GnuRSAPublicKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/java/security/key/rsa/GnuRSAPublicKey.java.orig 2010-06-03 21:11:56.000000000 +0200
++++ gnu/java/security/key/rsa/GnuRSAPublicKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -41,7 +41,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -283,8 +283,8 @@ Index: gnu/java/security/key/rsa/GnuRSAPublicKey.java
* <p>
Index: gnu/javax/crypto/key/dh/GnuDHKey.java
===================================================================
---- gnu/javax/crypto/key/dh/GnuDHKey.java.orig 2006-07-11 18:03:59.000000000 +0200
-+++ gnu/javax/crypto/key/dh/GnuDHKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/javax/crypto/key/dh/GnuDHKey.java.orig 2010-06-03 21:12:05.000000000 +0200
++++ gnu/javax/crypto/key/dh/GnuDHKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -39,7 +39,6 @@
package gnu.javax.crypto.key.dh;
@@ -304,8 +304,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHKey.java
* encapsulates the two DH numbers: <code>p</code>, and <code>g</code>.
Index: gnu/javax/crypto/key/dh/GnuDHPrivateKey.java
===================================================================
---- gnu/javax/crypto/key/dh/GnuDHPrivateKey.java.orig 2006-07-11 18:03:59.000000000 +0200
-+++ gnu/javax/crypto/key/dh/GnuDHPrivateKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/javax/crypto/key/dh/GnuDHPrivateKey.java.orig 2010-06-03 21:12:05.000000000 +0200
++++ gnu/javax/crypto/key/dh/GnuDHPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -40,7 +40,6 @@
import gnu.java.security.Configuration;
@@ -325,8 +325,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHPrivateKey.java
* <p>
Index: gnu/javax/crypto/key/dh/GnuDHPublicKey.java
===================================================================
---- gnu/javax/crypto/key/dh/GnuDHPublicKey.java.orig 2006-07-11 18:03:59.000000000 +0200
-+++ gnu/javax/crypto/key/dh/GnuDHPublicKey.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/javax/crypto/key/dh/GnuDHPublicKey.java.orig 2010-06-03 21:12:05.000000000 +0200
++++ gnu/javax/crypto/key/dh/GnuDHPublicKey.java 2012-07-18 23:08:46.803554178 +0200
@@ -39,7 +39,6 @@
package gnu.javax.crypto.key.dh;
@@ -346,8 +346,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHPublicKey.java
* <p>
Index: gnu/javax/crypto/sasl/plain/PasswordFile.java
===================================================================
---- gnu/javax/crypto/sasl/plain/PasswordFile.java.orig 2008-05-05 23:29:46.000000000 +0200
-+++ gnu/javax/crypto/sasl/plain/PasswordFile.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/javax/crypto/sasl/plain/PasswordFile.java.orig 2010-06-03 21:12:10.000000000 +0200
++++ gnu/javax/crypto/sasl/plain/PasswordFile.java 2012-07-18 23:08:46.803554178 +0200
@@ -40,7 +40,6 @@
import gnu.java.lang.CPStringBuilder;
@@ -367,8 +367,8 @@ Index: gnu/javax/crypto/sasl/plain/PasswordFile.java
*/
Index: gnu/javax/net/ssl/provider/X509TrustManagerFactory.java
===================================================================
---- gnu/javax/net/ssl/provider/X509TrustManagerFactory.java.orig 2006-12-10 21:25:43.000000000 +0100
-+++ gnu/javax/net/ssl/provider/X509TrustManagerFactory.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/javax/net/ssl/provider/X509TrustManagerFactory.java.orig 2010-06-03 21:12:17.000000000 +0200
++++ gnu/javax/net/ssl/provider/X509TrustManagerFactory.java 2012-07-18 23:08:46.803554178 +0200
@@ -66,11 +66,12 @@
import javax.net.ssl.TrustManagerFactorySpi;
import javax.net.ssl.X509TrustManager;
@@ -385,8 +385,8 @@ Index: gnu/javax/net/ssl/provider/X509TrustManagerFactory.java
* for the ``JessieX509'' algorithm.
Index: gnu/xml/aelfred2/XmlParser.java
===================================================================
---- gnu/xml/aelfred2/XmlParser.java.orig 2008-01-11 22:22:59.000000000 +0100
-+++ gnu/xml/aelfred2/XmlParser.java 2009-03-19 19:00:47.000000000 +0100
+--- gnu/xml/aelfred2/XmlParser.java.orig 2010-06-03 21:12:21.000000000 +0200
++++ gnu/xml/aelfred2/XmlParser.java 2012-07-18 23:08:46.807554239 +0200
@@ -53,8 +53,6 @@
package gnu.xml.aelfred2;
@@ -407,7 +407,7 @@ Index: gnu/xml/aelfred2/XmlParser.java
Index: sun/security/action/GetPropertyAction.java
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ sun/security/action/GetPropertyAction.java 2009-03-19 19:00:47.000000000 +0100
++++ sun/security/action/GetPropertyAction.java 2012-07-18 23:08:46.807554239 +0200
@@ -0,0 +1,92 @@
+/* GetPropertyAction.java
+ Copyright (C) 2004, 2008 Free Software Foundation, Inc.
diff --git a/recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch b/recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch
index 49b6631..49b6631 100644
--- a/recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch
+++ b/recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch
diff --git a/recipes-core/classpath/files/autotools.patch b/recipes-core/classpath/classpath-initial-0.93/autotools.patch
index 663c034..663c034 100644
--- a/recipes-core/classpath/files/autotools.patch
+++ b/recipes-core/classpath/classpath-initial-0.93/autotools.patch
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb
index 13ede10..7c2683c 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial_0.93.bb
@@ -5,8 +5,9 @@ require classpath-native.inc
DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
+DEPENDS += "jikes-native"
-DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
+PR = "${INC_PR}.0"
SRC_URI += " \
file://autotools.patch \
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index 16c1498..541c243 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -2,18 +2,13 @@ DESCRIPTION = "GNU Classpath standard Java libraries - For native Java-dependent
HOMEPAGE = "http://www.gnu.org/software/classpath/"
LICENSE = "Classpath"
-DEPENDS = "ecj-initial fastjar-native zip-native gettext-native"
+DEPENDS = "fastjar-native zip-native"
-PR = "r1"
-
-inherit autotools native
+inherit autotools native gettext
SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
-do_configure_prepend () {
-
- cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}
-}
+INC_PR = "r5"
export JAVA="${STAGING_BINDIR_NATIVE}/java-initial"
export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
@@ -33,4 +28,3 @@ EXTRA_OECONF = " \
--enable-tools \
--includedir=${STAGING_INCDIR}/classpath \
"
-
diff --git a/recipes-core/classpath/classpath-native_0.98.bb b/recipes-core/classpath/classpath-native_0.99.bb
index 32c3fb3..ece10c3 100644
--- a/recipes-core/classpath/classpath-native_0.98.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,11 +1,11 @@
require classpath-native.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
+DEPENDS += "ecj-initial"
-PR = "r1"
+PR = "${INC_PR}.0"
SRC_URI += " \
- file://SimpleName.diff;striplevel=0 \
file://sun-security-getproperty.patch;striplevel=0 \
file://ecj_java_dir.patch \
file://autotools.patch \
@@ -13,19 +13,6 @@ SRC_URI += " \
file://toolwrapper-exithook.patch \
"
-do_unpackpost() {
- # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
- mv external/w3c_dom/org/w3c/dom/html2 \
- external/w3c_dom/org/w3c/dom/html
-
- find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
- -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
-
- sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
-}
-
-addtask unpackpost after do_unpack before do_patch
-
# tools using java-initial rather than java sed it out
do_compile_append () {
@@ -40,6 +27,6 @@ do_compile_append () {
done
}
-SRC_URI[md5sum] = "90c6571b8b0309e372faa0f9f6255ea9"
-SRC_URI[sha256sum] = "501b5acd4dff79b6100da22cef15080f31071821ce3cea6f1b739bc1b56fac3f"
+SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
+SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 55a3f6c..4c3174b 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,9 +7,9 @@ LICENSE = "Classpath"
PBN = "classpath"
-inherit autotools java
+inherit autotools java gettext
-DEPENDS = "virtual/javac-native fastjar-native zip-native gettext-native gmp antlr-native gtk+ gconf libxtst"
+DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst"
RPROVIDES_${PN} = ""
@@ -21,7 +21,7 @@ RPROVIDES_${PN} = "${PBN}"
RPROVIDES_${PN}-common = "${PBN}-common"
RPROVIDES_${PN}-gtk = "${PBN}-awt"
-PR = "r1"
+PR = "r0"
SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
diff --git a/recipes-core/classpath/classpath_0.98.bb b/recipes-core/classpath/classpath_0.98.bb
deleted file mode 100644
index d822452..0000000
--- a/recipes-core/classpath/classpath_0.98.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-require classpath.inc
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=92acc79f1f429143f4624d07b253702a"
-
-SRC_URI += " \
- file://SimpleName.diff;striplevel=0 \
- file://ecj_java_dir.patch \
- file://autotools.patch \
- file://fix-gmp.patch \
- file://toolwrapper-exithook.patch \
- "
-
-SRC_URI[md5sum] = "90c6571b8b0309e372faa0f9f6255ea9"
-SRC_URI[sha256sum] = "501b5acd4dff79b6100da22cef15080f31071821ce3cea6f1b739bc1b56fac3f"
-
diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb
new file mode 100644
index 0000000..72c9c24
--- /dev/null
+++ b/recipes-core/classpath/classpath_0.99.bb
@@ -0,0 +1,14 @@
+require classpath.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=af0004801732bc4b20d90f351cf80510"
+
+SRC_URI += " \
+ file://sun-security-getproperty.patch;striplevel=0 \
+ file://ecj_java_dir.patch \
+ file://autotools.patch \
+ file://miscompilation.patch \
+ file://toolwrapper-exithook.patch \
+ "
+
+SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
+SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"