aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/intltool-nowarn-0.50.0.patch42
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/noperlcheck.patch40
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/remove-xml-check.patch29
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch40
-rw-r--r--recipes-devtools/intltool/intltool.inc40
-rw-r--r--recipes-devtools/intltool/intltool_0.50.0.bb38
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch39
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/glflags.patch30
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch44
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/no-strip.patch38
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/powerpc_rom.binbin0 -> 4096 bytes
-rw-r--r--recipes-devtools/qemu/qemu_2012.01.bb68
12 files changed, 299 insertions, 149 deletions
diff --git a/recipes-devtools/intltool/intltool-0.50.0/intltool-nowarn-0.50.0.patch b/recipes-devtools/intltool/intltool-0.50.0/intltool-nowarn-0.50.0.patch
new file mode 100644
index 0000000..06c938b
--- /dev/null
+++ b/recipes-devtools/intltool/intltool-0.50.0/intltool-nowarn-0.50.0.patch
@@ -0,0 +1,42 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Index: intltool-0.40.0/intltool-extract.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-extract.in 2011-10-08 22:24:57.000000000 +0300
++++ intltool-0.50.0/intltool-extract.in 2011-12-07 16:04:07.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
+Index: intltool-0.50.0/intltool-merge.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-merge.in 2011-10-08 17:52:01.000000000 +0300
++++ intltool-0.50.0/intltool-merge.in 2011-12-07 16:05:55.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
+Index: intltool-0.50.0/intltool-prepare.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-prepare.in 2011-10-08 09:16:58.000000000 +0300
++++ intltool-0.50.0/intltool-prepare.in 2011-12-07 16:06:13.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ # Intltool .desktop, .directory Prepare Tool
+Index: intltool-0.50.0/intltool-update.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-update.in 2011-10-08 22:24:57.000000000 +0300
++++ intltool-0.50.0/intltool-update.in 2011-12-07 16:06:39.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
diff --git a/recipes-devtools/intltool/intltool-0.50.0/noperlcheck.patch b/recipes-devtools/intltool/intltool-0.50.0/noperlcheck.patch
new file mode 100644
index 0000000..cc26749
--- /dev/null
+++ b/recipes-devtools/intltool/intltool-0.50.0/noperlcheck.patch
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+Index: intltool-0.40.6/configure.ac
+===================================================================
+--- intltool-0.40.6.orig/configure.ac 2011-08-31 11:21:13.061160535 +0100
++++ intltool-0.40.6/configure.ac 2011-08-31 11:22:44.991160885 +0100
+@@ -11,24 +11,10 @@
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+- AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+- PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+- AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+-else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++ AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+
+ AC_OUTPUT([
+ Makefile
diff --git a/recipes-devtools/intltool/intltool-0.50.0/remove-xml-check.patch b/recipes-devtools/intltool/intltool-0.50.0/remove-xml-check.patch
new file mode 100644
index 0000000..476d091
--- /dev/null
+++ b/recipes-devtools/intltool/intltool-0.50.0/remove-xml-check.patch
@@ -0,0 +1,29 @@
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-11-23 15:39:34.689561872 -0800
+@@ -122,14 +122,16 @@
+ IT_PERL_VERSION="`$INTLTOOL_PERL -e \"printf '%vd', $^V\"`"
+ AC_MSG_RESULT([$IT_PERL_VERSION])
+ fi
+-if test "x$2" != "xno-xml"; then
+- AC_MSG_CHECKING([for XML::Parser])
+- if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+- else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
+- fi
+-fi
++
++# Disable this check since we know XML::Parser is installed
++#if test "x$2" != "xno-xml"; then
++# AC_MSG_CHECKING([for XML::Parser])
++# if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
++# AC_MSG_RESULT([ok])
++# else
++# AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++# fi
++#fi
+
+ # Substitute ALL_LINGUAS so we can use it in po/Makefile
+ AC_SUBST(ALL_LINGUAS)
diff --git a/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
index 209861c..5f5fed3 100644
--- a/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
+++ b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
@@ -1,20 +1,20 @@
-OE has perl binary as 'nativeperl' in native sysroot so we look for it
-in order to avoid intltool searching and finding perl from /usr/bin
-on build system which may not have all the modules that it needs.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Inappropriate [OE specific]
-Index: intltool-0.40.6/intltool.m4
-===================================================================
---- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
-+++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
-@@ -110,7 +110,7 @@
- AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
- fi
-
--AC_PATH_PROG(INTLTOOL_PERL, perl)
-+AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
- if test -z "$INTLTOOL_PERL"; then
- AC_MSG_ERROR([perl not found])
- fi
+OE has perl binary as 'nativeperl' in native sysroot so we look for it
+in order to avoid intltool searching and finding perl from /usr/bin
+on build system which may not have all the modules that it needs.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [OE specific]
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
+@@ -110,7 +110,7 @@
+ AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
+ fi
+
+-AC_PATH_PROG(INTLTOOL_PERL, perl)
++AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
+ if test -z "$INTLTOOL_PERL"; then
+ AC_MSG_ERROR([perl not found])
+ fi
diff --git a/recipes-devtools/intltool/intltool.inc b/recipes-devtools/intltool/intltool.inc
index 5b7d69a..1c41f0f 100644
--- a/recipes-devtools/intltool/intltool.inc
+++ b/recipes-devtools/intltool/intltool.inc
@@ -1,20 +1,20 @@
-DESCRIPTION = "Utility scripts for internationalizing XML"
-SECTION = "devel"
-LICENSE = "GPLv2"
-
-URLV="${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
-SRC_URI = "http://launchpad.net/intltool/trunk/0.50.0/+download/intltool-0.50.0.tar.gz"
-S = "${WORKDIR}/intltool-${PV}"
-
-DEPENDS = "libxml-parser-perl-native"
-DEPENDS_virtclass-native = "libxml-parser-perl-native"
-#RDEPENDS_${PN} = "libxml-parser-perl"
-RRECOMMENDS_${PN} = "perl-modules"
-RRECOMMENDS_${PN}_virtclass-native = ""
-
-inherit autotools pkgconfig perlnative
-
-export PERL = "${bindir}/env perl"
-PERL_virtclass-native = "/usr/bin/env nativeperl"
-
-BBCLASSEXTEND = "native"
+DESCRIPTION = "Utility scripts for internationalizing XML"
+SECTION = "devel"
+LICENSE = "GPLv2"
+
+URLV="${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
+SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
+S = "${WORKDIR}/intltool-${PV}"
+
+DEPENDS = "libxml-parser-perl-native"
+DEPENDS_virtclass-native = "libxml-parser-perl-native"
+#RDEPENDS_${PN} = "libxml-parser-perl"
+RRECOMMENDS_${PN} = "perl-modules"
+RRECOMMENDS_${PN}_virtclass-native = ""
+
+inherit autotools pkgconfig perlnative
+
+export PERL = "${bindir}/env perl"
+PERL_virtclass-native = "/usr/bin/env nativeperl"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/intltool/intltool_0.50.0.bb b/recipes-devtools/intltool/intltool_0.50.0.bb
index e3cfe05..d1ee31d 100644
--- a/recipes-devtools/intltool/intltool_0.50.0.bb
+++ b/recipes-devtools/intltool/intltool_0.50.0.bb
@@ -1,19 +1,19 @@
-require intltool.inc
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r6"
-
-SRC_URI_append = " file://intltool-nowarn-0.50.0.patch \
- ${NATIVEPATCHES} \
- "
-
-#
-# All of the intltool scripts have the correct paths to perl already
-# embedded into them and can find perl fine, so we add the remove xml-check
-# in the intltool.m4 via the remove-xml-check.patch
-NATIVEPATCHES = "file://noperlcheck.patch \
- file://remove-xml-check.patch"
-NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
-
-SRC_URI[md5sum] = "0da9847a60391ca653df35123b1f7cc0"
-SRC_URI[sha256sum] = "dccfb0b7dd35a170130e8934bfd30c29da6ae73bcd3ca4ba71317c977b2893d6"
+require intltool.inc
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r0"
+
+SRC_URI += "file://intltool-nowarn-0.50.0.patch \
+ ${NATIVEPATCHES} \
+ "
+
+#
+# All of the intltool scripts have the correct paths to perl already
+# embedded into them and can find perl fine, so we add the remove xml-check
+# in the intltool.m4 via the remove-xml-check.patch
+NATIVEPATCHES = "file://noperlcheck.patch \
+ file://remove-xml-check.patch"
+NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
+
+SRC_URI[md5sum] = "0da9847a60391ca653df35123b1f7cc0"
+SRC_URI[sha256sum] = "dccfb0b7dd35a170130e8934bfd30c29da6ae73bcd3ca4ba71317c977b2893d6"
diff --git a/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch b/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch
new file mode 100644
index 0000000..2075386
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch
@@ -0,0 +1,39 @@
+From c313f89c33217ac0e471554dace2144718f86669 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 13 May 2010 12:23:40 +0200
+Subject: [PATCH] linux-user: use default mmap_min_addr 65536 when /proc/sys/vm/mmap_min_addr cannot be read
+
+* 65536 is default at least for ubuntu and fedora.
+---
+ linux-user/main.c | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/linux-user/main.c
+===================================================================
+--- qemu-0.14.0.orig/linux-user/main.c
++++ qemu-0.14.0/linux-user/main.c
+@@ -36,6 +36,7 @@
+ #include "envlist.h"
+
+ #define DEBUG_LOGFILE "/tmp/qemu.log"
++#define MMAP_MIN_ADDR_DEFAULT 65536
+
+ char *exec_path;
+
+@@ -3010,8 +3011,14 @@ int main(int argc, char **argv, char **e
+ if (fscanf(fp, "%lu", &tmp) == 1) {
+ mmap_min_addr = tmp;
+ qemu_log("host mmap_min_addr=0x%lx\n", mmap_min_addr);
++ } else {
++ qemu_log("cannot read value from /proc/sys/vm/mmap_min_addr, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
++ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
+ }
+ fclose(fp);
++ } else {
++ qemu_log("cannot open /proc/sys/vm/mmap_min_addr for reading, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
++ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
+ }
+ }
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/glflags.patch b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
index 0814675..0ad5551 100644
--- a/recipes-devtools/qemu/qemu-2012.01/glflags.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
@@ -1,15 +1,15 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: qemu-0.14.0/Makefile.target
-===================================================================
---- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
-+++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
-@@ -362,7 +362,7 @@
-
- monitor.o: hmp-commands.h qmp-commands.h
-
--LIBS += -lGL -lGLU
-+LIBS += -lGL
-
- $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
-
+Upstream-Status: Inappropriate [configuration]
+
+Index: qemu-0.14.0/Makefile.target
+===================================================================
+--- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
++++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
+@@ -362,7 +362,7 @@
+
+ monitor.o: hmp-commands.h qmp-commands.h
+
+-LIBS += -lGL -lGLU
++LIBS += -lGL
+
+ $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
index be8af8e..711c360 100644
--- a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
@@ -1,22 +1,22 @@
-This patch is taken from debian. 128M is too less sometimes if distro
-with lot of packages is booted so this patch raises the default to 384M
-
-It has not been applied to upstream qemu
-
-Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-Index: qemu-0.14.0/vl.c
-===================================================================
---- qemu-0.14.0.orig/vl.c
-+++ qemu-0.14.0/vl.c
-@@ -168,7 +168,7 @@ int main(int argc, char **argv)
- //#define DEBUG_NET
- //#define DEBUG_SLIRP
-
--#define DEFAULT_RAM_SIZE 128
-+#define DEFAULT_RAM_SIZE 384
-
- #define MAX_VIRTIO_CONSOLES 1
-
+This patch is taken from debian. 128M is too less sometimes if distro
+with lot of packages is booted so this patch raises the default to 384M
+
+It has not been applied to upstream qemu
+
+Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/vl.c
+===================================================================
+--- qemu-0.14.0.orig/vl.c
++++ qemu-0.14.0/vl.c
+@@ -168,7 +168,7 @@ int main(int argc, char **argv)
+ //#define DEBUG_NET
+ //#define DEBUG_SLIRP
+
+-#define DEFAULT_RAM_SIZE 128
++#define DEFAULT_RAM_SIZE 384
+
+ #define MAX_VIRTIO_CONSOLES 1
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
index 25e42da..f5ada7e 100644
--- a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
@@ -1,19 +1,19 @@
-Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
-
----
- Makefile | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ffd3364..38d8352 100644
---- a/Makefile
-+++ b/Makefile
-@@ -288,7 +288,7 @@ install-sysconfig:
- install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
- $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
- ifneq ($(TOOLS),)
-- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
-+ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
- endif
- ifneq ($(BLOBS),)
- $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
+Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ffd3364..38d8352 100644
+--- a/Makefile
++++ b/Makefile
+@@ -288,7 +288,7 @@ install-sysconfig:
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ ifneq ($(BLOBS),)
+ $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
diff --git a/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin b/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin
new file mode 100644
index 0000000..c404429
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin
Binary files differ
diff --git a/recipes-devtools/qemu/qemu_2012.01.bb b/recipes-devtools/qemu/qemu_2012.01.bb
index 45b5773..70df48b 100644
--- a/recipes-devtools/qemu/qemu_2012.01.bb
+++ b/recipes-devtools/qemu/qemu_2012.01.bb
@@ -1,35 +1,35 @@
-require recipes-devtools/qemu/qemu.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
- file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-
-PR = "r0"
-
-FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
-FILESDIR = "${WORKDIR}"
-
-# Tag 2012.01
-SRCREV = "4b6667af6cd1a58f4d43f3baae432723f47d28fb"
-
-SRC_URI = "\
- git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
- file://powerpc_rom.bin \
- file://no-strip.patch \
- file://fallback-to-safe-mmap_min_addr.patch \
- file://larger_default_ram_size.patch \
- "
-# Only use the GL passthrough patches for native/nativesdk versions
-QEMUGLPATCHES = "\
- "
-SRC_URI_append_virtclass-native = "\
- ${QEMUGLPATCHES} \
- "
-
-SRC_URI_append_virtclass-nativesdk = "\
- ${QEMUGLPATCHES} \
- file://glflags.patch \
- "
-#SRC_URI[md5sum] = "34f17737baaf1b3495c89cd6d4a607ed"
-#SRC_URI[sha256sum] = "7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba"
-
+require recipes-devtools/qemu/qemu.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
+ file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
+
+PR = "r0"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
+FILESDIR = "${WORKDIR}"
+
+# Tag 2012.01
+SRCREV = "4b6667af6cd1a58f4d43f3baae432723f47d28fb"
+
+SRC_URI = "\
+ git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
+ file://powerpc_rom.bin \
+ file://no-strip.patch \
+ file://fallback-to-safe-mmap_min_addr.patch \
+ file://larger_default_ram_size.patch \
+ "
+# Only use the GL passthrough patches for native/nativesdk versions
+QEMUGLPATCHES = "\
+ "
+SRC_URI_append_virtclass-native = "\
+ ${QEMUGLPATCHES} \
+ "
+
+SRC_URI_append_virtclass-nativesdk = "\
+ ${QEMUGLPATCHES} \
+ file://glflags.patch \
+ "
+#SRC_URI[md5sum] = "34f17737baaf1b3495c89cd6d4a607ed"
+#SRC_URI[sha256sum] = "7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba"
+
S = "${WORKDIR}/git" \ No newline at end of file