aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qemu')
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch39
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/glflags.patch30
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch44
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/no-strip.patch38
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/powerpc_rom.binbin0 -> 4096 bytes
-rw-r--r--recipes-devtools/qemu/qemu_2012.01.bb68
6 files changed, 129 insertions, 90 deletions
diff --git a/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch b/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch
new file mode 100644
index 0000000..2075386
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/fallback-to-safe-mmap_min_addr.patch
@@ -0,0 +1,39 @@
+From c313f89c33217ac0e471554dace2144718f86669 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 13 May 2010 12:23:40 +0200
+Subject: [PATCH] linux-user: use default mmap_min_addr 65536 when /proc/sys/vm/mmap_min_addr cannot be read
+
+* 65536 is default at least for ubuntu and fedora.
+---
+ linux-user/main.c | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/linux-user/main.c
+===================================================================
+--- qemu-0.14.0.orig/linux-user/main.c
++++ qemu-0.14.0/linux-user/main.c
+@@ -36,6 +36,7 @@
+ #include "envlist.h"
+
+ #define DEBUG_LOGFILE "/tmp/qemu.log"
++#define MMAP_MIN_ADDR_DEFAULT 65536
+
+ char *exec_path;
+
+@@ -3010,8 +3011,14 @@ int main(int argc, char **argv, char **e
+ if (fscanf(fp, "%lu", &tmp) == 1) {
+ mmap_min_addr = tmp;
+ qemu_log("host mmap_min_addr=0x%lx\n", mmap_min_addr);
++ } else {
++ qemu_log("cannot read value from /proc/sys/vm/mmap_min_addr, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
++ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
+ }
+ fclose(fp);
++ } else {
++ qemu_log("cannot open /proc/sys/vm/mmap_min_addr for reading, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
++ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
+ }
+ }
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/glflags.patch b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
index 0814675..0ad5551 100644
--- a/recipes-devtools/qemu/qemu-2012.01/glflags.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
@@ -1,15 +1,15 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: qemu-0.14.0/Makefile.target
-===================================================================
---- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
-+++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
-@@ -362,7 +362,7 @@
-
- monitor.o: hmp-commands.h qmp-commands.h
-
--LIBS += -lGL -lGLU
-+LIBS += -lGL
-
- $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
-
+Upstream-Status: Inappropriate [configuration]
+
+Index: qemu-0.14.0/Makefile.target
+===================================================================
+--- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
++++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
+@@ -362,7 +362,7 @@
+
+ monitor.o: hmp-commands.h qmp-commands.h
+
+-LIBS += -lGL -lGLU
++LIBS += -lGL
+
+ $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
index be8af8e..711c360 100644
--- a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
@@ -1,22 +1,22 @@
-This patch is taken from debian. 128M is too less sometimes if distro
-with lot of packages is booted so this patch raises the default to 384M
-
-It has not been applied to upstream qemu
-
-Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-Index: qemu-0.14.0/vl.c
-===================================================================
---- qemu-0.14.0.orig/vl.c
-+++ qemu-0.14.0/vl.c
-@@ -168,7 +168,7 @@ int main(int argc, char **argv)
- //#define DEBUG_NET
- //#define DEBUG_SLIRP
-
--#define DEFAULT_RAM_SIZE 128
-+#define DEFAULT_RAM_SIZE 384
-
- #define MAX_VIRTIO_CONSOLES 1
-
+This patch is taken from debian. 128M is too less sometimes if distro
+with lot of packages is booted so this patch raises the default to 384M
+
+It has not been applied to upstream qemu
+
+Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/vl.c
+===================================================================
+--- qemu-0.14.0.orig/vl.c
++++ qemu-0.14.0/vl.c
+@@ -168,7 +168,7 @@ int main(int argc, char **argv)
+ //#define DEBUG_NET
+ //#define DEBUG_SLIRP
+
+-#define DEFAULT_RAM_SIZE 128
++#define DEFAULT_RAM_SIZE 384
+
+ #define MAX_VIRTIO_CONSOLES 1
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
index 25e42da..f5ada7e 100644
--- a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
+++ b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
@@ -1,19 +1,19 @@
-Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
-
----
- Makefile | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ffd3364..38d8352 100644
---- a/Makefile
-+++ b/Makefile
-@@ -288,7 +288,7 @@ install-sysconfig:
- install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
- $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
- ifneq ($(TOOLS),)
-- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
-+ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
- endif
- ifneq ($(BLOBS),)
- $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
+Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ffd3364..38d8352 100644
+--- a/Makefile
++++ b/Makefile
+@@ -288,7 +288,7 @@ install-sysconfig:
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ ifneq ($(BLOBS),)
+ $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
diff --git a/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin b/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin
new file mode 100644
index 0000000..c404429
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/powerpc_rom.bin
Binary files differ
diff --git a/recipes-devtools/qemu/qemu_2012.01.bb b/recipes-devtools/qemu/qemu_2012.01.bb
index 45b5773..70df48b 100644
--- a/recipes-devtools/qemu/qemu_2012.01.bb
+++ b/recipes-devtools/qemu/qemu_2012.01.bb
@@ -1,35 +1,35 @@
-require recipes-devtools/qemu/qemu.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
- file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-
-PR = "r0"
-
-FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
-FILESDIR = "${WORKDIR}"
-
-# Tag 2012.01
-SRCREV = "4b6667af6cd1a58f4d43f3baae432723f47d28fb"
-
-SRC_URI = "\
- git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
- file://powerpc_rom.bin \
- file://no-strip.patch \
- file://fallback-to-safe-mmap_min_addr.patch \
- file://larger_default_ram_size.patch \
- "
-# Only use the GL passthrough patches for native/nativesdk versions
-QEMUGLPATCHES = "\
- "
-SRC_URI_append_virtclass-native = "\
- ${QEMUGLPATCHES} \
- "
-
-SRC_URI_append_virtclass-nativesdk = "\
- ${QEMUGLPATCHES} \
- file://glflags.patch \
- "
-#SRC_URI[md5sum] = "34f17737baaf1b3495c89cd6d4a607ed"
-#SRC_URI[sha256sum] = "7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba"
-
+require recipes-devtools/qemu/qemu.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
+ file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
+
+PR = "r0"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
+FILESDIR = "${WORKDIR}"
+
+# Tag 2012.01
+SRCREV = "4b6667af6cd1a58f4d43f3baae432723f47d28fb"
+
+SRC_URI = "\
+ git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
+ file://powerpc_rom.bin \
+ file://no-strip.patch \
+ file://fallback-to-safe-mmap_min_addr.patch \
+ file://larger_default_ram_size.patch \
+ "
+# Only use the GL passthrough patches for native/nativesdk versions
+QEMUGLPATCHES = "\
+ "
+SRC_URI_append_virtclass-native = "\
+ ${QEMUGLPATCHES} \
+ "
+
+SRC_URI_append_virtclass-nativesdk = "\
+ ${QEMUGLPATCHES} \
+ file://glflags.patch \
+ "
+#SRC_URI[md5sum] = "34f17737baaf1b3495c89cd6d4a607ed"
+#SRC_URI[sha256sum] = "7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba"
+
S = "${WORKDIR}/git" \ No newline at end of file