aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/connman/connman
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/connman/connman')
-rw-r--r--recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch46
-rw-r--r--recipes-connectivity/connman/connman/connman124
-rw-r--r--recipes-connectivity/connman/connman/disable_alg-test.patch46
-rw-r--r--recipes-connectivity/connman/connman/ethernet_default.patch44
4 files changed, 153 insertions, 107 deletions
diff --git a/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
index 36e7456..764c689 100644
--- a/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
+++ b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
@@ -1,23 +1,23 @@
-Some platform (like atom-pc) enables rootless X,
-thus we need to add the xuser in the list.
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-diff -ruN connman-0.65-orig/src/connman-dbus.conf connman-0.65/src/connman-dbus.conf
---- connman-0.65-orig/src/connman-dbus.conf 2011-03-04 09:34:49.000000000 +0800
-+++ connman-0.65/src/connman-dbus.conf 2011-03-04 09:35:21.000000000 +0800
-@@ -7,6 +7,12 @@
- <allow send_interface="net.connman.Agent"/>
- <allow send_interface="net.connman.Counter"/>
- </policy>
-+ <policy user="xuser">
-+ <allow own="net.connman"/>
-+ <allow send_destination="net.connman"/>
-+ <allow send_interface="net.connman.Agent"/>
-+ <allow send_interface="net.connman.Counter"/>
-+ </policy>
- <policy at_console="true">
- <allow send_destination="net.connman"/>
- </policy>
+Some platform (like atom-pc) enables rootless X,
+thus we need to add the xuser in the list.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN connman-0.65-orig/src/connman-dbus.conf connman-0.65/src/connman-dbus.conf
+--- connman-0.65-orig/src/connman-dbus.conf 2011-03-04 09:34:49.000000000 +0800
++++ connman-0.65/src/connman-dbus.conf 2011-03-04 09:35:21.000000000 +0800
+@@ -7,6 +7,12 @@
+ <allow send_interface="net.connman.Agent"/>
+ <allow send_interface="net.connman.Counter"/>
+ </policy>
++ <policy user="xuser">
++ <allow own="net.connman"/>
++ <allow send_destination="net.connman"/>
++ <allow send_interface="net.connman.Agent"/>
++ <allow send_interface="net.connman.Counter"/>
++ </policy>
+ <policy at_console="true">
+ <allow send_destination="net.connman"/>
+ </policy>
diff --git a/recipes-connectivity/connman/connman/connman b/recipes-connectivity/connman/connman/connman
index b8cf2c9..f01bf37 100644
--- a/recipes-connectivity/connman/connman/connman
+++ b/recipes-connectivity/connman/connman/connman
@@ -1,62 +1,62 @@
-#!/bin/sh
-
-DAEMON=/usr/sbin/connmand
-PIDFILE=/var/run/connmand.pid
-DESC="Connection Manager"
-
-if [ -f /etc/default/connman ] ; then
- . /etc/default/connman
-fi
-
-set -e
-
-nfsroot=0
-
-exec 9<&0 < /proc/mounts
-while read dev mtpt fstype rest; do
- if test $mtpt = "/" ; then
- case $fstype in
- nfs | nfs4)
- nfsroot=1
- break
- ;;
- *)
- ;;
- esac
- fi
-done
-
-do_start() {
- EXTRA_PARAM=""
- if test $nfsroot -eq 1 ; then
- EXTRA_PARAM="-P ethernet"
- fi
- $DAEMON $EXTRA_PARAM
-}
-
-do_stop() {
- start-stop-daemon --stop --name connmand --quiet
-}
-
-case "$1" in
- start)
- echo "Starting $DESC"
- do_start
- ;;
- stop)
- echo "Stopping $DESC"
- do_stop
- ;;
- restart|force-reload)
- echo "Restarting $DESC"
- do_stop
- sleep 1
- do_start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+nfsroot=0
+
+exec 9<&0 < /proc/mounts
+while read dev mtpt fstype rest; do
+ if test $mtpt = "/" ; then
+ case $fstype in
+ nfs | nfs4)
+ nfsroot=1
+ break
+ ;;
+ *)
+ ;;
+ esac
+ fi
+done
+
+do_start() {
+ EXTRA_PARAM=""
+ if test $nfsroot -eq 1 ; then
+ EXTRA_PARAM="-P ethernet"
+ fi
+ $DAEMON $EXTRA_PARAM
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-connectivity/connman/connman/disable_alg-test.patch b/recipes-connectivity/connman/connman/disable_alg-test.patch
new file mode 100644
index 0000000..44ad768
--- /dev/null
+++ b/recipes-connectivity/connman/connman/disable_alg-test.patch
@@ -0,0 +1,46 @@
+From b9a20c8eb61b600ced284646a1bea588fdd8a5ea Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Fri, 16 Dec 2011 19:31:59 -0200
+Subject: [PATCH] Disable building of alg-test
+
+alg-test utility depends on linux/if_alg.h header that is only
+available on kernels >= 2.6.39.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ Makefile.am | 2 +-
+ configure.ac | 3 ---
+ 2 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index d5a76f9..d42a766 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -144,7 +144,7 @@ noinst_PROGRAMS += tools/wispr tools/supplicant-test \
+ tools/dbus-test tools/polkit-test \
+ tools/iptables-test tools/tap-test tools/wpad-test \
+ tools/stats-tool tools/private-network-test \
+- tools/alg-test unit/test-session
++ unit/test-session
+
+ tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
+ tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
+diff --git a/configure.ac b/configure.ac
+index f63fea8..67bfe85 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -437,9 +437,6 @@ if (test "${enable_tools}" = "yes"); then
+ AC_MSG_ERROR(GnuTLS library is required))
+ AC_SUBST(GNUTLS_CFLAGS)
+ AC_SUBST(GNUTLS_LIBS)
+-
+- AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,
+- AC_MSG_ERROR(User-space algorithm header files are required))
+ fi
+ AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")
+
+--
+1.7.7.3
+
diff --git a/recipes-connectivity/connman/connman/ethernet_default.patch b/recipes-connectivity/connman/connman/ethernet_default.patch
index e948e56..6dae2aa 100644
--- a/recipes-connectivity/connman/connman/ethernet_default.patch
+++ b/recipes-connectivity/connman/connman/ethernet_default.patch
@@ -1,22 +1,22 @@
-Default to enabling the ethernet interface. If we don't do this, connman
-will shut down all the networking when it starts without any configuration
-which is usualy not what the users expects. This is particularly
-problematic with our qemu images and runtime testing using qemu.
-
-Upstream-Status: Inappropriate [Configuration]
-
-RP 2011/12/12
-
-Index: git/src/storage.c
-===================================================================
---- git.orig/src/storage.c 2011-12-12 16:14:10.892316565 +0000
-+++ git/src/storage.c 2011-12-12 16:14:13.788316431 +0000
-@@ -367,7 +367,7 @@
- "Enable", FALSE);
-
- g_key_file_set_boolean(keyfile, "Wired",
-- "Enable", FALSE);
-+ "Enable", TRUE);
-
- g_key_file_set_boolean(keyfile, "3G",
- "Enable", FALSE);
+Default to enabling the ethernet interface. If we don't do this, connman
+will shut down all the networking when it starts without any configuration
+which is usualy not what the users expects. This is particularly
+problematic with our qemu images and runtime testing using qemu.
+
+Upstream-Status: Inappropriate [Configuration]
+
+RP 2011/12/12
+
+Index: git/src/storage.c
+===================================================================
+--- git.orig/src/storage.c 2011-12-12 16:14:10.892316565 +0000
++++ git/src/storage.c 2011-12-12 16:14:13.788316431 +0000
+@@ -367,7 +367,7 @@
+ "Enable", FALSE);
+
+ g_key_file_set_boolean(keyfile, "Wired",
+- "Enable", FALSE);
++ "Enable", TRUE);
+
+ g_key_file_set_boolean(keyfile, "3G",
+ "Enable", FALSE);