aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/dlt-daemon/dlt-daemon')
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch30
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch78
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0003-systemd-unit-type-should-be-in-lowercase-so-use-Type.patch98
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch25
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0005-Fix-OE-cmake-installation-dir.patch26
5 files changed, 45 insertions, 212 deletions
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
deleted file mode 100644
index 5bf6bf8..0000000
--- a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8080b7395c1638baee60fb3c46667f21e00b87fb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Erik=20Bot=C3=B6?= <erik.boto@pelagicore.com>
-Date: Fri, 4 Apr 2014 10:59:18 +0200
-Subject: [PATCH 1/4] Fix build with systemd >= 209
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Inappropriate [Configuration Specific]
-Signed-off-by: Erik Botö <erik.boto@pelagicore.com>
----
- src/system/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
-index ce87914..1d0d224 100644
---- a/src/system/CMakeLists.txt
-+++ b/src/system/CMakeLists.txt
-@@ -23,7 +23,7 @@ set(dlt_system_SRCS dlt-system.c dlt-system-options.c dlt-system-process-handlin
- dlt-system-syslog.c dlt-system-watchdog.c dlt-system-journal.c)
- add_executable(dlt-system ${dlt_system_SRCS} ${systemd_SRCS})
- if(WITH_SYSTEMD_JOURNAL)
-- target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES} systemd-journal systemd-id128)
-+ target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES} systemd)
- else(WITH_SYSTEMD_JOURNAL)
- target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES})
- endif(WITH_SYSTEMD_JOURNAL)
---
-1.9.3
-
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
index 40c5afb..1688479 100644
--- a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
@@ -7,85 +7,75 @@ Upstream-Status: Inappropriate [Configuration Specific]
Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
---
systemd/dlt-adaptor-udp.service.cmake | 1 -
- systemd/dlt-dbus.service.cmake | 1 -
systemd/dlt-example-user.service.cmake | 1 -
systemd/dlt-receive.service.cmake | 1 -
systemd/dlt-system.service.cmake | 1 -
systemd/dlt.service.cmake | 1 -
- 6 files changed, 6 deletions(-)
+ 5 files changed, 5 deletions(-)
diff --git a/systemd/dlt-adaptor-udp.service.cmake b/systemd/dlt-adaptor-udp.service.cmake
-index 0c39637..f446757 100644
+index 8dac1f2..ecf9f9e 100644
--- a/systemd/dlt-adaptor-udp.service.cmake
+++ b/systemd/dlt-adaptor-udp.service.cmake
-@@ -20,7 +20,6 @@ Wants=dlt.service
+@@ -21,9 +21,8 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-adaptor-udp -a @DLT_ADAPTOR_UDP_APPID@ -c @DLT_ADAPTOR_UDP_CTID@ -p @DLT_ADAPTOR_UDP_PORT@
LimitCORE=infinity
-diff --git a/systemd/dlt-dbus.service.cmake b/systemd/dlt-dbus.service.cmake
-index 2727c2d..d1e3b12 100755
---- a/systemd/dlt-dbus.service.cmake
-+++ b/systemd/dlt-dbus.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=root
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-dbus
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+ [Install]
+-WantedBy=multi-user.target
+\ No newline at end of file
++WantedBy=multi-user.target
diff --git a/systemd/dlt-example-user.service.cmake b/systemd/dlt-example-user.service.cmake
-index 3652292..b67a83c 100644
+index b665742..35009b0 100644
--- a/systemd/dlt-example-user.service.cmake
+++ b/systemd/dlt-example-user.service.cmake
-@@ -20,6 +20,5 @@ Wants=dlt.service
+@@ -21,6 +21,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-example-user "Hallo from GENIVI DLT example user application"
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-receive.service.cmake b/systemd/dlt-receive.service.cmake
-index b92c8b2..4bbdfc2 100644
+index c07d447..8f88f00 100644
--- a/systemd/dlt-receive.service.cmake
+++ b/systemd/dlt-receive.service.cmake
-@@ -21,6 +21,5 @@ Wants=dlt.service
+@@ -22,6 +22,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-receive -o /tmp/dlt_receive_log.dlt localhost
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-system.service.cmake b/systemd/dlt-system.service.cmake
-index f5e844b..7ec995c 100755
+index 0e91f42..1a5b913 100755
--- a/systemd/dlt-system.service.cmake
+++ b/systemd/dlt-system.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=genivi
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+@@ -22,7 +22,6 @@ Wants=dlt.service
+
+ [Service]
+ Type=simple
+-User=@DLT_USER@
+ ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
+ WatchdogSec=@DLT_WatchdogSec@
+ NotifyAccess=main
diff --git a/systemd/dlt.service.cmake b/systemd/dlt.service.cmake
-index 22279c4..7bb05bc 100755
+index 0b3ee2c..e4753a2 100755
--- a/systemd/dlt.service.cmake
+++ b/systemd/dlt.service.cmake
-@@ -20,7 +20,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
+@@ -21,7 +21,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-daemon
WatchdogSec=@DLT_WatchdogSec@
NotifyAccess=main
---
-1.9.3
-
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0003-systemd-unit-type-should-be-in-lowercase-so-use-Type.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0003-systemd-unit-type-should-be-in-lowercase-so-use-Type.patch
deleted file mode 100644
index 691a500..0000000
--- a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0003-systemd-unit-type-should-be-in-lowercase-so-use-Type.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From 6804c68ed61f4436818c58cb0abe1c21b4d48aea Mon Sep 17 00:00:00 2001
-From: Andrei Gherzan <andrei.gherzan@windriver.com>
-Date: Tue, 18 Nov 2014 15:48:50 +0100
-Subject: [PATCH 3/4] systemd/*: unit type should be in lowercase, so use
- Type=simple
-
-Upstream-Status: Submitted [http://lists.genivi.org/pipermail/genivi-diagnostic-log-and-trace/2014-October/000546.html]
-Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
----
- systemd/dlt-adaptor-udp.service.cmake | 2 +-
- systemd/dlt-dbus.service.cmake | 2 +-
- systemd/dlt-example-user.service.cmake | 2 +-
- systemd/dlt-receive.service.cmake | 2 +-
- systemd/dlt-system.service.cmake | 2 +-
- systemd/dlt.service.cmake | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/systemd/dlt-adaptor-udp.service.cmake b/systemd/dlt-adaptor-udp.service.cmake
-index f446757..81a7158 100644
---- a/systemd/dlt-adaptor-udp.service.cmake
-+++ b/systemd/dlt-adaptor-udp.service.cmake
-@@ -19,7 +19,7 @@ Description=GENIVI DLT adaptor stdin. Adaptor for forwarding received UDP messag
- Wants=dlt.service
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-adaptor-udp -a @DLT_ADAPTOR_UDP_APPID@ -c @DLT_ADAPTOR_UDP_CTID@ -p @DLT_ADAPTOR_UDP_PORT@
- LimitCORE=infinity
-
-diff --git a/systemd/dlt-dbus.service.cmake b/systemd/dlt-dbus.service.cmake
-index d1e3b12..75dcdc3 100755
---- a/systemd/dlt-dbus.service.cmake
-+++ b/systemd/dlt-dbus.service.cmake
-@@ -20,7 +20,7 @@ Documentation=man:dlt-dbus(1) man:dlt-dbus.conf(5)
- Wants=dlt.service
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-dbus
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
-diff --git a/systemd/dlt-example-user.service.cmake b/systemd/dlt-example-user.service.cmake
-index b67a83c..fe9c567 100644
---- a/systemd/dlt-example-user.service.cmake
-+++ b/systemd/dlt-example-user.service.cmake
-@@ -19,6 +19,6 @@ Description=GENIVI DLT example user. Generate DLT messages and store them to fil
- Wants=dlt.service
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-example-user "Hallo from GENIVI DLT example user application"
- LimitCORE=infinity
-\ No newline at end of file
-diff --git a/systemd/dlt-receive.service.cmake b/systemd/dlt-receive.service.cmake
-index 4bbdfc2..3b47dd3 100644
---- a/systemd/dlt-receive.service.cmake
-+++ b/systemd/dlt-receive.service.cmake
-@@ -20,6 +20,6 @@ Documentation=man:dlt-receive(1)
- Wants=dlt.service
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-receive -o /tmp/dlt_receive_log.dlt localhost
- LimitCORE=infinity
-\ No newline at end of file
-diff --git a/systemd/dlt-system.service.cmake b/systemd/dlt-system.service.cmake
-index 7ec995c..d4a4c96 100755
---- a/systemd/dlt-system.service.cmake
-+++ b/systemd/dlt-system.service.cmake
-@@ -20,7 +20,7 @@ Documentation=man:dlt-system(1) man:dlt-system.conf(5)
- Wants=dlt.service
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
-diff --git a/systemd/dlt.service.cmake b/systemd/dlt.service.cmake
-index 7bb05bc..5386ffd 100755
---- a/systemd/dlt.service.cmake
-+++ b/systemd/dlt.service.cmake
-@@ -19,7 +19,7 @@ Description=GENIVI DLT logging daemon
- Documentation=man:dlt-daemon(1) man:dlt.conf(5)
-
- [Service]
--Type=Simple
-+Type=simple
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-daemon
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
---
-1.9.3
-
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
index df762f3..685dfcd 100644
--- a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
@@ -9,19 +9,16 @@ Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
systemd/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
-index a9838e4..c8feae5 100644
---- a/systemd/CMakeLists.txt
-+++ b/systemd/CMakeLists.txt
-@@ -16,7 +16,7 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e6b44a2..0e885bf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -175,7 +175,7 @@ if(WITH_SYSTEMD OR WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD_JOURNAL)
- if(WITH_SYSTEMD)
+ set( systemd_SRCS ${CMAKE_SOURCE_DIR}/systemd/3rdparty/sd-daemon.c)
-- set(SYSTEMD_CONFIGURATIONS_FILES_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/system )
-+ set(SYSTEMD_CONFIGURATIONS_FILES_DIR /lib/systemd/system )
-
- if(WITH_SYSTEMD_WATCHDOG)
- set( DLT_WatchdogSec 2 )
---
-1.9.3
-
+- set(SYSTEMD_UNITDIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system" CACHE PATH
++ set(SYSTEMD_UNITDIR "/lib/systemd/system" CACHE PATH
+ "Set directory to install systemd unit files")
+
+ add_subdirectory( systemd )
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0005-Fix-OE-cmake-installation-dir.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0005-Fix-OE-cmake-installation-dir.patch
deleted file mode 100644
index cbf049c..0000000
--- a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0005-Fix-OE-cmake-installation-dir.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 39a5c3136ee0f84e29fe3c8121b3b61142a8a76f Mon Sep 17 00:00:00 2001
-From: Clement Dransart <clement.dransart@awtce.be>
-Date: Tue, 7 Jun 2016 11:02:12 +0200
-Subject: [meta-ivi][PATCH] Fix OE cmake installation dir
-
-Signed-off-by: Clement Dransart <clement.dransart@awtce.be>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 46beec0..ad62848 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -112,7 +112,7 @@ ELSE (${WITH_DOC} STREQUAL "OFF")
- SET(PACKAGE_DOC "")
- ENDIF(${WITH_DOC} STREQUAL "OFF")
-
--set(LIB_INSTALL_DIR lib${LIB_SUFFIX})
-+set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR})
-
- configure_file(${CMAKE_SOURCE_DIR}/${PROJECT_NAME}.spec.in ${PROJECT_BINARY_DIR}/${PROJECT_NAME}.spec)
- configure_file(${CMAKE_SOURCE_DIR}/${PROJECT_NAME}.pc.in ${PROJECT_BINARY_DIR}/${PROJECT_NAME}.pc @ONLY)
---
-1.9.1
-