aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/common-api
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/common-api')
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb10
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb10
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-native.inc45
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc31
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb6
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-someip-native_3.1.5p2.bb10
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc36
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb6
8 files changed, 77 insertions, 77 deletions
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb
deleted file mode 100644
index 3e9c36c..0000000
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "Common API C++ core generator"
-
-LAUNCHER_BASE = "commonapi-generator"
-LAUNCHER_LINK = "capicxx-core-gen"
-
-require capicxx-native.inc
-
-SRC_URI = "${BASE_URL}/generator/${BASE_VER}/${PV}/commonapi-generator.zip"
-SRC_URI[md5sum] = "c12551e8f61da944b17a22c00d3e6559"
-SRC_URI[sha256sum] = "538a923a1e596106b9f2ce0838fcf85fd81c4e09b0951c59ad2e2e72eb6d0534"
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb
deleted file mode 100644
index 66b90a8..0000000
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "Common API C++ D-Bus generator"
-
-LAUNCHER_BASE = "commonapi-dbus-generator"
-LAUNCHER_LINK = "capicxx-dbus-gen"
-
-require capicxx-native.inc
-
-SRC_URI = "${BASE_URL}/generator/${BASE_VER}/${PV}/commonapi_dbus_generator.zip"
-SRC_URI[md5sum] = "70a6f1cf7e42a94260385281a569a486"
-SRC_URI[sha256sum] = "de165298b1062951dff07d99f491c8d8a3ca3c1a087de56bc01c083cf71fa742"
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc b/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc
deleted file mode 100644
index 19b22e3..0000000
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc
+++ /dev/null
@@ -1,45 +0,0 @@
-SECTION = "devel"
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = \
- "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
-
-BASE_URL = "http://docs.projects.genivi.org/yamaica-update-site/CommonAPI"
-BASE_VER = "${@'.'.join(d.getVar('PV', True).split('.')[0:2])}"
-
-def get_launcher_name(d):
- BS = d.getVar('BUILD_SYS', True)
- if BS == "x86_64-linux":
- launcherName = "${LAUNCHER_BASE}-linux-x86_64"
- elif BS == "i686-linux":
- launcherName = "${LAUNCHER_BASE}-linux-x86"
- else:
- bb.fatal("Build system '%s' is not supported by ${PN}_${PV} recipe" % BS)
- return launcherName
-
-LAUNCHER = "${@get_launcher_name(d)}"
-
-inherit native
-SANITY_REQUIRED_UTILITIES += "java"
-
-S = "${WORKDIR}"
-DD = "${D}${datadir}/${PN}-${PV}"
-
-do_install() {
- install -d ${DD}
- install -m 0644 ${S}/artifacts.xml ${DD}
- install -m 0755 ${S}/${LAUNCHER_BASE}-linux-x86 ${DD}
- install -m 0644 ${S}/${LAUNCHER_BASE}-linux-x86.ini ${DD}
- install -m 0755 ${S}/${LAUNCHER_BASE}-linux-x86_64 ${DD}
- install -m 0644 ${S}/${LAUNCHER_BASE}-linux-x86_64.ini ${DD}
- for dir in ./configuration ./features ./plugins; do
- for item in $(find ${dir} -name '*' -print); do
- if [ -d ${item} ]; then
- install -d ${DD}/${item}
- else
- install -m 0644 ${S}/${item} ${DD}/$(dirname ${item})
- fi
- done
- done
- install -d "${D}${bindir}"
- ln -sf -T "${DD}/${LAUNCHER}" ${D}${bindir}/${LAUNCHER_LINK}
-}
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc b/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc
new file mode 100644
index 0000000..09199db
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc
@@ -0,0 +1,31 @@
+#!/bin/sh
+get_list() {
+ return 1
+}
+
+get_title() {
+ echo "Common API C++ test code"
+}
+
+_run_dir=/opt/tests/capicxx-perf
+_run_1() {
+ ${_run_dir}/capicxx-server &
+ ${_run_dir}/capicxx-client
+ kill -9 `pidof capicxx-server`
+ sleep 1
+}
+
+run_1() {
+ if [ "x${1}" != "x" ]; then
+ _run_1 >& /tmp/t
+ _test_completed=`cat /tmp/t | grep "test completed"`
+ _10000_sent=`cat /tmp/t | grep "sync messages sent" | grep 10000`
+ if [ "x${_test_completed}" != "x" -a "y${_10000_sent}" != "y" ]; then
+ echo " PASSED"
+ else
+ echo " FAILED"
+ fi
+ else
+ _run_1
+ fi
+}
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
index 2263647..f468650 100644
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = \
PR = "r0"
SRCREV = "2eacc9d7fb76957e9a5450a559675fddf0a95ce2"
-SRC_URI = "git://github.com/GENIVI/capic-poc.git"
+SRC_URI = "git://github.com/GENIVI/capic-poc.git \
+ file://${BPN}_t.inc \
+ "
S = "${WORKDIR}/git/test/capicxx-perf"
DEPENDS = "common-api-c++ common-api-c++-dbus capicxx-core-native capicxx-dbus-native"
@@ -31,4 +33,6 @@ do_install_append() {
mv ${D}/usr/bin/* ${_DEST}
rmdir ${D}/usr/bin
rmdir ${D}/usr
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-someip-native_3.1.5p2.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-someip-native_3.1.5p2.bb
deleted file mode 100644
index d4eccb0..0000000
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-someip-native_3.1.5p2.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "Common API C++ SOME/IP generator"
-
-LAUNCHER_BASE = "commonapi-someip-generator"
-LAUNCHER_LINK = "capicxx-someip-gen"
-
-require capicxx-native.inc
-
-SRC_URI = "${BASE_URL}/generator/${BASE_VER}/${PV}/commonapi_someip_generator.zip"
-SRC_URI[md5sum] = "23196ec64737ea85b96aa754d17cf01c"
-SRC_URI[sha256sum] = "5135d9df40a27d29f60785db9812a65395e077b3e61f3beaa15d08c6094f8e0d"
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc
new file mode 100644
index 0000000..1c7cca9
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc
@@ -0,0 +1,36 @@
+#!/bin/sh
+get_list() {
+ return 1
+}
+
+get_title() {
+ echo "Common API C++ runtime"
+}
+
+_run_dir=/opt/tests/common-api-test
+_run_1() {
+ ${_run_dir}/E05ManagerService &
+ ${_run_dir}/E05ManagerClient &
+ sleep 5
+ kill -9 `pidof E05ManagerClient`
+ kill -9 `pidof E05ManagerService`
+ sleep 1
+}
+
+run_1() {
+ if [ "x${1}" != "x" ]; then
+ _run_1 >& /tmp/t
+ _c1=`cat /tmp/t | grep "Special device 0 detected"`
+ _c2=`cat /tmp/t | grep "Special device 0 removed"`
+ _c3=`cat /tmp/t | grep "Device 1 detected"`
+ _c4=`cat /tmp/t | grep "Device 1 removed"`
+ if [ "x${_c1}" != "x" -a "x${_c2}" != "x" -a \
+ "x${_c3}" != "x" -a "x${_c4}" != "x" ]; then
+ echo " PASSED"
+ else
+ echo " FAILED"
+ fi
+ else
+ _run_1
+ fi
+}
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
index a286502..04b8154 100644
--- a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
@@ -4,12 +4,13 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r0"
-inherit autotools cmake pkgconfig
+inherit cmake pkgconfig
DEPENDS += " common-api-c++ common-api-c++-dbus glib-2.0"
SRC_URI = " \
file://${PN}-${PV}.tar.gz \
+ file://${BPN}_t.inc \
"
S = "${WORKDIR}/${PN}"
@@ -22,6 +23,7 @@ FILES_${PN} = " \
/opt/tests/${PN}/*/commonapi4dbus.ini \
/opt/tests/${PN}/*/*Client \
/opt/tests/${PN}/*/*Service \
+ /opt/tests/${PN}/${BPN}_t.inc \
${libdir}/*.so \
"
@@ -60,4 +62,6 @@ do_install() {
fi
install -m 0755 ${_BIN}/${i}/lib${i}-dbus.so ${D}${libdir}
done
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}