aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/common-api
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/common-api')
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb10
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb10
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-native.inc45
3 files changed, 65 insertions, 0 deletions
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb
new file mode 100644
index 0000000..3e9c36c
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-core-native_3.1.5p2.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Common API C++ core generator"
+
+LAUNCHER_BASE = "commonapi-generator"
+LAUNCHER_LINK = "capicxx-core-gen"
+
+require capicxx-native.inc
+
+SRC_URI = "${BASE_URL}/generator/${BASE_VER}/${PV}/commonapi-generator.zip"
+SRC_URI[md5sum] = "c12551e8f61da944b17a22c00d3e6559"
+SRC_URI[sha256sum] = "538a923a1e596106b9f2ce0838fcf85fd81c4e09b0951c59ad2e2e72eb6d0534"
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb
new file mode 100644
index 0000000..66b90a8
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-dbus-native_3.1.5p2.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Common API C++ D-Bus generator"
+
+LAUNCHER_BASE = "commonapi-dbus-generator"
+LAUNCHER_LINK = "capicxx-dbus-gen"
+
+require capicxx-native.inc
+
+SRC_URI = "${BASE_URL}/generator/${BASE_VER}/${PV}/commonapi_dbus_generator.zip"
+SRC_URI[md5sum] = "70a6f1cf7e42a94260385281a569a486"
+SRC_URI[sha256sum] = "de165298b1062951dff07d99f491c8d8a3ca3c1a087de56bc01c083cf71fa742"
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc b/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc
new file mode 100644
index 0000000..19b22e3
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-native.inc
@@ -0,0 +1,45 @@
+SECTION = "devel"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = \
+ "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+BASE_URL = "http://docs.projects.genivi.org/yamaica-update-site/CommonAPI"
+BASE_VER = "${@'.'.join(d.getVar('PV', True).split('.')[0:2])}"
+
+def get_launcher_name(d):
+ BS = d.getVar('BUILD_SYS', True)
+ if BS == "x86_64-linux":
+ launcherName = "${LAUNCHER_BASE}-linux-x86_64"
+ elif BS == "i686-linux":
+ launcherName = "${LAUNCHER_BASE}-linux-x86"
+ else:
+ bb.fatal("Build system '%s' is not supported by ${PN}_${PV} recipe" % BS)
+ return launcherName
+
+LAUNCHER = "${@get_launcher_name(d)}"
+
+inherit native
+SANITY_REQUIRED_UTILITIES += "java"
+
+S = "${WORKDIR}"
+DD = "${D}${datadir}/${PN}-${PV}"
+
+do_install() {
+ install -d ${DD}
+ install -m 0644 ${S}/artifacts.xml ${DD}
+ install -m 0755 ${S}/${LAUNCHER_BASE}-linux-x86 ${DD}
+ install -m 0644 ${S}/${LAUNCHER_BASE}-linux-x86.ini ${DD}
+ install -m 0755 ${S}/${LAUNCHER_BASE}-linux-x86_64 ${DD}
+ install -m 0644 ${S}/${LAUNCHER_BASE}-linux-x86_64.ini ${DD}
+ for dir in ./configuration ./features ./plugins; do
+ for item in $(find ${dir} -name '*' -print); do
+ if [ -d ${item} ]; then
+ install -d ${DD}/${item}
+ else
+ install -m 0644 ${S}/${item} ${DD}/$(dirname ${item})
+ fi
+ done
+ done
+ install -d "${D}${bindir}"
+ ln -sf -T "${DD}/${LAUNCHER}" ${D}${bindir}/${LAUNCHER_LINK}
+}