aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-dev.bb10
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb11
-rw-r--r--recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch50
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb11
4 files changed, 71 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-intel-dev.bb b/recipes-kernel/linux/linux-intel-dev.bb
index 4da6e3b9..12dda6cb 100644
--- a/recipes-kernel/linux/linux-intel-dev.bb
+++ b/recipes-kernel/linux/linux-intel-dev.bb
@@ -6,7 +6,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
SRC_URI = " \
git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
- file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
+ file://0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
"
SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
@@ -15,13 +15,13 @@ KCONF_BSP_AUDIT_LEVEL = "2"
KMETA_BRANCH = "master"
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.5-rc3"
-SRCREV_machine ?= "0c5d381c6f1ebd88b4da2c3392f86d1611daba84"
-SRCREV_meta ?= "1b65db46af4e00e257a6be18cb06736cb83d54dd"
+LINUX_VERSION ?= "5.19.0"
+SRCREV_machine ?= "270ddbd02fe9e1761ebccf792acadbb3cd52b69f"
+SRCREV_meta ?= "423df1333e1e2a0c2bff9b29d40d16d74b775a79"
LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index 38a536c0..15c8febf 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -17,8 +17,13 @@ KMETA_BRANCH = "yocto-5.4"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.4.138"
-SRCREV_machine ?= "45e3b0f5357fc86bf0e766a5249fc7faa33c1be8"
-SRCREV_meta ?= "b8c82ba37370e4698ff0c42f3e54b8b4f2fb4ac0"
+LINUX_VERSION ?= "5.4.209"
+SRCREV_machine ?= "70a06857dca28633fad857b852c6c86189438afb"
+SRCREV_meta ?= "c917f683a6394ae00f81139ae57ae0112d4b7528"
LINUX_KERNEL_TYPE = "preempt-rt"
+
+# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
+# linux-intel 5.4 specifically. This causes a warning during kernel config audit. Suppress the
+# harmless warning for now.
+KCONF_BSP_AUDIT_LEVEL = "0"
diff --git a/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
new file mode 100644
index 00000000..0ebbb008
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
@@ -0,0 +1,50 @@
+From ecb938c19d20543382c9bbc42588c29b5ebfd3ed Mon Sep 17 00:00:00 2001
+From: Bruce Ashfield <bruce.ashfield@windriver.com>
+Date: Fri, 12 Aug 2022 13:12:18 +0800
+Subject: [PATCH] menuconfig,mconf-cfg: Allow specification of ncurses location
+
+In some cross build environments such as the Yocto Project build
+environment it provides an ncurses library that is compiled
+differently than the host's version. This causes display corruption
+problems when the host's curses includes are used instead of the
+includes from the provided compiler are overridden. There is a second
+case where there is no curses libraries at all on the host system and
+menuconfig will just fail entirely.
+
+The solution is simply to allow an override variable in
+check-lxdialog.sh for environments such as the Yocto Project. Adding
+a CROSS_CURSES_LIB and CROSS_CURSES_INC solves the issue and allowing
+compiling and linking against the right headers and libraries.
+
+Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
+cc: Michal Marek <mmarek@suse.cz>
+cc: linux-kbuild@vger.kernel.org
+Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
+---
+ scripts/kconfig/mconf-cfg.sh | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/scripts/kconfig/mconf-cfg.sh b/scripts/kconfig/mconf-cfg.sh
+index 025b565e0b7c..6514d19790e6 100755
+--- a/scripts/kconfig/mconf-cfg.sh
++++ b/scripts/kconfig/mconf-cfg.sh
+@@ -4,6 +4,15 @@
+ PKG="ncursesw"
+ PKG2="ncurses"
+
++if [ "$CROSS_CURSES_LIB" != "" ]; then
++ echo libs=\'$CROSS_CURSES_LIB\'
++ if [ x"$CROSS_CURSES_INC" != x ]; then
++ echo cflags=\'$CROSS_CURSES_INC\'
++ fi
++ exit 0
++fi
++
++
+ if [ -n "$(command -v ${HOSTPKG_CONFIG})" ]; then
+ if ${HOSTPKG_CONFIG} --exists $PKG; then
+ echo cflags=\"$(${HOSTPKG_CONFIG} --cflags $PKG)\"
+--
+2.25.1
+
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index 3c6371bf..df56b370 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -9,9 +9,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.4.138"
-SRCREV_machine ?= "cfef018a5efc728040e938c270bbc68fc8124d33"
-SRCREV_meta ?= "b8c82ba37370e4698ff0c42f3e54b8b4f2fb4ac0"
+LINUX_VERSION ?= "5.4.209"
+SRCREV_machine ?= "ea2d8185fa954bc9c9a0c703cc4ff9c4b5cb8df5"
+SRCREV_meta ?= "c917f683a6394ae00f81139ae57ae0112d4b7528"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
@@ -19,3 +19,8 @@ KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
# Functionality flags
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
+
+# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
+# linux-intel 5.4 specifically. This causes a warning during kernel config audit. Suppress the
+# harmless warning for now.
+KCONF_BSP_AUDIT_LEVEL = "0"