aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch27
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch32
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch23
3 files changed, 27 insertions, 55 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
new file mode 100644
index 00000000..49a59496
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
@@ -0,0 +1,27 @@
+From b1d7f46442e50458311573443a5c78637874f62b Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anuj.mittal@intel.com>
+Date: Thu, 12 Apr 2018 11:46:15 +0800
+Subject: [PATCH] Makefile: check for CONFIG_IXGBEVF instead
+
+Check for the correct config, otherwise it won't build with kbuild.
+
+Upstream-Status: Pending
+
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 968ef5e..e3cb81b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),)
+ # Makefile for the Intel(R) 10GbE PCI Express Virtual Function Driver
+ #
+
+-obj-$(CONFIG_IXGBE) += ixgbevf.o
++obj-$(CONFIG_IXGBEVF) += ixgbevf.o
+
+ define ixgbevf-y
+ ixgbevf_main.o
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
deleted file mode 100644
index 8234f589..00000000
--- a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 511ee0d8d40a3e76b3e9875a96228ff370dbdfc6 Mon Sep 17 00:00:00 2001
-From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
-Date: Wed, 22 Jun 2016 11:25:41 +0800
-Subject: [PATCH] ixgbevf_patch
-
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 8df134a..8d5660e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -100,7 +100,7 @@ clean:
- @-rm -rf *.${MANSECTION}.gz *.ko
-
- # Install the modules and manpage
--install: default manfile
-+modules_install: default manfile
- @echo "Copying manpages..."
- @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
- @echo "Installing modules..."
-@@ -145,6 +145,6 @@ help:
- @echo ' Other variables may be available for tuning make process, see'
- @echo ' Kernel Kbuild documentation for more information'
-
--.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
-+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
-
- endif # ifneq($(KERNELRELEASE),)
---
-2.8.3
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch b/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
deleted file mode 100644
index d442e24d..00000000
--- a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From f74fbcd821a394dec58263fd2c2ea62eae298b2f Mon Sep 17 00:00:00 2001
-From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
-Date: Sun, 26 Jun 2016 12:01:36 +0800
-Subject: [PATCH] ixgbevf patch
-
----
- common.mk | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/common.mk b/common.mk
-index b9b01c7..228a926 100644
---- a/common.mk
-+++ b/common.mk
-@@ -289,6 +289,7 @@ export INSTALL_MOD_DIR ?= updates/drivers/net/ethernet/intel/${DRIVER}
- kernelbuild = ${MAKE} $(if ${GCC_I_SYS},CC="${GCC_I_SYS}") \
- ${CCFLAGS_VAR}="${EXTRA_CFLAGS}" \
- -C "${KSRC}" \
-+ CONFIG_IXGBE=m \
- CONFIG_${DRIVER_UPPERCASE}=m \
- M="${CURDIR}" \
- ${2} ${1};
---
-2.8.3