aboutsummaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18')
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/cross-compile.patch58
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch63
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/native-matypes.patch20
3 files changed, 141 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/cross-compile.patch b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/cross-compile.patch
new file mode 100644
index 00000000..a2315968
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/cross-compile.patch
@@ -0,0 +1,58 @@
+Index: mesa/configs/linux-dri
+===================================================================
+--- mesa.orig/configs/linux-dri
++++ mesa/configs/linux-dri
+@@ -3,11 +3,9 @@
+
+ include $(TOP)/configs/default
+
+-CONFIG_NAME = linux-dri
++$(warning ENVIRONMENT = $(shell printenv))
+
+-# Compiler and flags
+-CC = gcc
+-CXX = g++
++CONFIG_NAME = linux-dri
+
+ #MKDEP = /usr/X11R6/bin/makedepend
+ #MKDEP = gcc -M
+@@ -25,8 +23,6 @@ DEFINES = -D_POSIX_SOURCE -D_POSIX_C_SOU
+ -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING \
+ -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN
+
+-X11_INCLUDES = -I/usr/X11R6/include
+-
+ CFLAGS = -Wall -Wmissing-prototypes -std=c99 -ffast-math \
+ $(OPT_FLAGS) $(PIC_FLAGS) $(ARCH_FLAGS) $(DEFINES) $(ASM_FLAGS)
+
+@@ -40,9 +36,6 @@ CXXFLAGS += -fno-strict-aliasing
+
+ ASM_SOURCES =
+
+-# Library/program dependencies
+-EXTRA_LIB_PATH=-L/usr/X11R6/lib
+-
+ LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo`
+ LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo`
+ DRI_LIB_DEPS = $(EXTRA_LIB_PATH) -lm -lpthread -lexpat -ldl $(LIBDRM_LIB)
+Index: mesa/configs/default
+===================================================================
+--- mesa.orig/configs/default
++++ mesa/configs/default
+@@ -17,8 +17,6 @@ MESA_VERSION = $(MESA_MAJOR).$(MESA_MINO
+ DRM_SOURCE_PATH=$(TOP)/../drm
+
+ # Compiler and flags
+-CC = cc
+-CXX = CC
+ CFLAGS = -O
+ CXXFLAGS = -O
+ LDFLAGS =
+@@ -67,7 +65,6 @@ ASM_SOURCES =
+ # GLw widget sources (Append "GLwMDrawA.c" here and add -lXm to GLW_LIB_DEPS in
+ # order to build the Motif widget too)
+ GLW_SOURCES = GLwDrawA.c
+-MOTIF_CFLAGS = -I/usr/include/Motif1.2
+
+
+ # Directories to build
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch
new file mode 100644
index 00000000..96b94ef2
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch
@@ -0,0 +1,63 @@
+Index: mesa/configure.ac
+===================================================================
+--- mesa.orig/configure.ac 2010-05-13 13:20:26.000000000 +0100
++++ mesa/configure.ac 2010-07-25 17:02:58.000000000 +0100
+@@ -524,10 +524,10 @@
+ fi
+
+ # Check for libdrm
+- PKG_CHECK_MODULES([LIBDRM], [libdrm-poulsbo >= $LIBDRM_REQUIRED])
++ PKG_CHECK_MODULES([LIBDRM], [libdrm_poulsbo >= $LIBDRM_REQUIRED])
+ PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= $DRI2PROTO_REQUIRED])
+- GL_PC_REQ_PRIV="libdrm-poulsbo >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED"
+- DRI_PC_REQ_PRIV="libdrm-poulsbo >= $LIBDRM_REQUIRED"
++ GL_PC_REQ_PRIV="libdrm_poulsbo >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED"
++ DRI_PC_REQ_PRIV="libdrm_poulsbo >= $LIBDRM_REQUIRED"
+
+ # find the DRI deps for libGL
+ if test "$x11_pkgconfig" = yes; then
+Index: mesa/configs/linux-dri
+===================================================================
+--- mesa.orig/configs/linux-dri 2010-07-25 17:08:01.000000000 +0100
++++ mesa/configs/linux-dri 2010-07-25 17:08:17.000000000 +0100
+@@ -36,8 +36,8 @@
+
+ ASM_SOURCES =
+
+-LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo`
+-LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo`
++LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo`
++LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo`
+ DRI_LIB_DEPS = $(EXTRA_LIB_PATH) -lm -lpthread -lexpat -ldl $(LIBDRM_LIB)
+ GL_LIB_DEPS = $(EXTRA_LIB_PATH) -lX11 -lXext -lXxf86vm -lXdamage -lXfixes \
+ -lm -lpthread -ldl $(LIBDRM_LIB)
+Index: mesa/configs/linux-dri-xcb
+===================================================================
+--- mesa.orig/configs/linux-dri-xcb 2010-07-25 17:08:25.000000000 +0100
++++ mesa/configs/linux-dri-xcb 2010-07-25 17:08:44.000000000 +0100
+@@ -41,8 +41,8 @@
+ # Library/program dependencies
+ EXTRA_LIB_PATH=`pkg-config --libs-only-L x11`
+
+-LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo`
+-LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo`
++LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo`
++LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo`
+ DRI_LIB_DEPS = $(EXTRA_LIB_PATH) -lm -lpthread -lexpat -ldl $(LIBDRM_LIB)
+ GL_LIB_DEPS = $(EXTRA_LIB_PATH) -lX11 -lXext -lXxf86vm -lXdamage -lXfixes \
+ -lm -lpthread -ldl $(LIBDRM_LIB) `pkg-config --libs xcb` \
+Index: mesa/configs/linux-solo
+===================================================================
+--- mesa.orig/configs/linux-solo 2010-07-25 17:09:03.000000000 +0100
++++ mesa/configs/linux-solo 2010-07-25 17:09:13.000000000 +0100
+@@ -16,8 +16,8 @@
+ ARCH_FLAGS ?=
+
+ # DRM and pciaccess
+-LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo`
+-LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo`
++LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo`
++LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo`
+ PCIACCESS_CFLAGS = `pkg-config --cflags pciaccess`
+ PCIACCESS_LIB = `pkg-config --libs pciaccess`
+
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/native-matypes.patch b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/native-matypes.patch
new file mode 100644
index 00000000..26b1f52a
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/native-matypes.patch
@@ -0,0 +1,20 @@
+Index: mesa/src/mesa/x86/Makefile
+===================================================================
+--- mesa.orig/src/mesa/x86/Makefile 2010-10-11 16:34:12.664960996 +0100
++++ mesa/src/mesa/x86/Makefile 2010-10-11 16:34:43.854960861 +0100
+@@ -20,11 +20,12 @@
+ -rm -f matypes.h gen_matypes
+
+
+-gen_matypes: gen_matypes.c
+- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
++#gen_matypes: gen_matypes.c
++# $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
+
+ # need some special rules here, unfortunately
+-matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes
++matypes.h: ../main/mtypes.h ../tnl/t_context.h
++# gen_matypes
+ ./gen_matypes > matypes.h
+
+ common_x86_asm.o: matypes.h