summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch38
-rw-r--r--recipes-support/gnupg/gnupg_1.4.7.bb10
2 files changed, 44 insertions, 4 deletions
diff --git a/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch b/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch
new file mode 100644
index 0000000..eb4cc9f
--- /dev/null
+++ b/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch
@@ -0,0 +1,38 @@
+Remove the code for ustar format detection because it is not applicable
+for cross-complie platform.
+
+Upstream Status: Inappropriate [embedded specific]
+
+Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com>
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ m4/tar-ustar.m4 | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/m4/tar-ustar.m4 b/m4/tar-ustar.m4
+index 4ae9e63..f6e57c2 100644
+--- a/m4/tar-ustar.m4
++++ b/m4/tar-ustar.m4
+@@ -26,10 +26,15 @@ AC_DEFUN([GNUPG_CHECK_USTAR],
+
+ if test x$_mytar != x ; then
+ AC_MSG_CHECKING([whether $_mytar speaks USTAR])
+- echo hithere > conftest.txt
+- $_mytar -cf - conftest.txt | (dd skip=257 bs=1 count=5 2>/dev/null || cat) | grep ustar > /dev/null
+- _tar_bad=$?
+- rm conftest.txt
++
++ # Here, we ignore the check code, because it isn't indeed applicable for
++ # cross-compile platform.
++ # Now our tar support ustar, so we say directly yes, but once the tar is changed,
++ # you should check whether it suppport ustar, and please reference the follow command:
++ # echo hithere > conftest.txt
++ # tar -cf - conftest.txt | (dd skip=257 bs=1 count=5 2>/dev/null || cat) | grep ustar > /dev/null
++
++ _tar_bad=0
+
+ if test x$_tar_bad = x0 ; then
+ AC_MSG_RESULT([yes])
+--
+1.9.1
+
diff --git a/recipes-support/gnupg/gnupg_1.4.7.bb b/recipes-support/gnupg/gnupg_1.4.7.bb
index 6ccffd5..85636ab 100644
--- a/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -18,6 +18,7 @@ SRC_URI = "${GNUPG_MIRROR}/gnupg/gnupg-${PV}.tar.bz2 \
file://CVE-2013-4351.patch \
file://CVE-2013-4576.patch \
file://CVE-2013-4242.patch \
+ file://fix-ustar-check-issue.patch \
"
SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c"
@@ -74,12 +75,13 @@ inherit autotools gettext texinfo
# --disable-regex do not handle regular expressions in trust sigs
EXTRA_OECONF = "--disable-ldap \
- --with-zlib=${STAGING_LIBDIR}/.. \
- --with-bzip2=${STAGING_LIBDIR}/.. \
- --disable-selinux-support \
+ --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-bzip2=${STAGING_LIBDIR}/.. \
+ --disable-selinux-support \
--with-readline=${STAGING_LIBDIR}/.. \
ac_cv_sys_symbol_underscore=no \
- "
+ ac_cv_path_TAR=${base_bindir}/tar \
+ "
# Force gcc's traditional handling of inline to avoid issues with gcc 5
CFLAGS += "-fgnu89-inline"