aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mqxboot/mqxboot_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mqxboot/mqxboot_1.0.bb')
-rw-r--r--recipes-bsp/mqxboot/mqxboot_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/mqxboot/mqxboot_1.0.bb b/recipes-bsp/mqxboot/mqxboot_1.0.bb
new file mode 100644
index 00000000..7f11a984
--- /dev/null
+++ b/recipes-bsp/mqxboot/mqxboot_1.0.bb
@@ -0,0 +1,23 @@
+# Copyright (C) 2013 Timesys Corporation
+SUMMARY = "MQX Image loader - starts an MQX image on the M4"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d"
+
+DEPENDS = "virtual/kernel-module-mcc"
+
+SRC_URI = "http://repository.timesys.com/buildsources/m/mqxboot/mqxboot-${PV}/mqxboot-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "3de3c8b5f8cd6664870587d29c04c421"
+SRC_URI[sha256sum] = "c2f66ae962fe2529578d5c007e3f91a36085b714a0ea276f47bc3aea90e69699"
+
+S = "${WORKDIR}/mqxboot-${PV}"
+
+CFLAGS += "-I${STAGING_KERNEL_DIR}/include"
+
+RDEPENDS_${PN} = "virtual/kernel-module-mcc"
+
+COMPATIBLE_MACHINE = "(vf60)"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}