aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb')
-rw-r--r--recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb
new file mode 100644
index 00000000..50787fd6
--- /dev/null
+++ b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 NXP
+SUMMARY = "NXP i.MX Sentinel firmware"
+DESCRIPTION = "Firmware for i.MX Sentinel Security Controller"
+SECTION = "base"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
+
+inherit fsl-eula-unpack use-imx-security-controller-firmware deploy nopackages
+
+SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
+SRC_URI[md5sum] = "be47a5e59c1192ee36246af97d5d1532"
+SRC_URI[sha256sum] = "1003d4c6773c153ea341911a74e25c249423644f70f3d8f8d085599e00770b3f"
+
+do_compile[noexec] = "1"
+do_install[noexec] = "1"
+
+do_deploy () {
+ # Deploy the related firmware to be package by imx-boot
+ install -m 0644 ${S}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}
+}
+addtask deploy after do_install before do_build
+
+COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp|mx9-nxp-bsp)"