aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux')
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb17
-rw-r--r--common/recipes-kernel/linux/linux-intel.inc43
-rw-r--r--common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg14
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb13
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend26
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend13
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend13
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend33
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend13
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend19
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend19
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend33
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend31
-rw-r--r--common/recipes-kernel/linux/linux-yocto_%.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.10.bbappend21
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.12.bbappend21
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend43
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.9.bbappend21
18 files changed, 0 insertions, 397 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
deleted file mode 100644
index 3fbe8fda..00000000
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-
-require linux-intel.inc
-
-# Skip processing of this recipe if it is not explicitly specified as the
-# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
-# to build multiple virtual/kernel providers, e.g. as dependency of
-# core-image-rt-sdk, core-image-rt.
-python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
- raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
-}
-
-KBRANCH = "base-rt"
-SRCREV_machine ?= "fc08e0615edccfb4d297c07531451cb7905fb4f4"
-SRCREV_meta ?= "3ddaed3671efc2936efbebf4c5216e11b9dfd55d"
-
-LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/common/recipes-kernel/linux/linux-intel.inc b/common/recipes-kernel/linux/linux-intel.inc
deleted file mode 100644
index 46f28efe..00000000
--- a/common/recipes-kernel/linux/linux-intel.inc
+++ /dev/null
@@ -1,43 +0,0 @@
-require recipes-kernel/linux/linux-yocto.inc
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
-
-KERNEL_CONFIG_URI ?= " \
- git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA} \
- "
-SRC_URI = " \
- git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
- ${KERNEL_CONFIG_URI} \
- "
-
-SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
-
-
-LINUX_VERSION ?= "4.9.47"
-LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
-
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-KMETA = "kernel-meta"
-KCONF_BSP_AUDIT_LEVEL = "2"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = "features/qat/qat.scc"
-
-# Functionality flags
-KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
-KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
-
-KERNEL_MODULE_PROBECONF_corei7-64-intel-common += "snd-soc-skl"
-module_conf_snd-soc-skl_corei7-64-intel-common = "blacklist snd-soc-skl"
diff --git a/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg b/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg
deleted file mode 100644
index f7d7322e..00000000
--- a/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg
+++ /dev/null
@@ -1,14 +0,0 @@
-# CONFIG_SND_SOC_INTEL_SKYLAKE is not set
-# CONFIG_SND_SOC_INTEL_BXT_DA7219_MAX98357A_MACH is not set
-# CONFIG_SND_SOC_INTEL_BXT_FLORIDA_MACH is not set
-# CONFIG_SND_SOC_INTEL_BXT_RT298_MACH is not set
-# CONFIG_SND_SOC_INTEL_BXT_TDF8532_MACH is not set
-# CONFIG_SND_SOC_INTEL_KBL_RT5663_MAX98927_MACH is not set
-# CONFIG_SND_SOC_INTEL_SKL_RT286_MACH is not set
-# CONFIG_SND_SOC_INTEL_CNL_WM8281_MACH is not set
-# CONFIG_SND_SOC_INTEL_CNL_RT274_MACH is not set
-# CONFIG_SND_SOC_INTEL_SKL_NAU88L25_SSM4567_MACH is not set
-# CONFIG_SND_SOC_INTEL_SKL_NAU88L25_MAX98357A_MACH is not set
-# CONFIG_SND_SOC_INTEL_CNL_CS42L42_MACH is not set
-# CONFIG_SND_SOC_INTEL_CNL_RT700_MACH is not set
-# CONFIG_SND_SOC_INTEL_CNL_SVFPGA_MACH is not set
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
deleted file mode 100644
index 4823c98d..00000000
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-
-require linux-intel.inc
-
-KBRANCH = "base"
-SRCREV_machine ?= "2d533948da0a7c53a0a662d3764be166ba996d93"
-SRCREV_meta ?= "3ddaed3671efc2936efbebf4c5216e11b9dfd55d"
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# Functionality flags
-KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
deleted file mode 100644
index ee33ecc3..00000000
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-# Quark / X1000 BSP Info
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
-# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
-# and setting them here breaks the default mechanism to use AUTOREV if the
-# default SRCREV is set and linux-yocto-dev is the preferred provider.
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# For FRI2, NUC
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
deleted file mode 100644
index 17569a1c..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
deleted file mode 100644
index 17569a1c..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
deleted file mode 100644
index c18f4a11..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-LINUX_VERSION_INTEL_COMMON = "4.4.87"
-SRCREV_META_INTEL_COMMON ?= "804d2b3164ec25ed519fd695de9aa0908460c92e"
-SRCREV_MACHINE_INTEL_COMMON ?= "d1ce34c9e66fe55382cc196fe7facbe7865c4eed"
-
-KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
-SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
-SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
-SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend
deleted file mode 100644
index 9d2e3c0b..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON = ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
deleted file mode 100644
index b8d3d81c..00000000
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
+++ /dev/null
@@ -1,19 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-
-KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
-KBRANCH_core2-32-intel-common = "standard/tiny/base"
-KBRANCH_corei7-64-intel-common = "standard/tiny/base"
-
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend
deleted file mode 100644
index b8d3d81c..00000000
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend
+++ /dev/null
@@ -1,19 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-
-KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
-KBRANCH_core2-32-intel-common = "standard/tiny/base"
-KBRANCH_corei7-64-intel-common = "standard/tiny/base"
-
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
deleted file mode 100644
index 54430e21..00000000
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-LINUX_VERSION_i586-nlp-32-intel-common = "4.4.87"
-LINUX_VERSION_core2-32-intel-common = "4.4.87"
-LINUX_VERSION_corei7-64-intel-common = "4.4.87"
-
-SRCREV_meta_i586-nlp-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
-SRCREV_meta_core2-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
-SRCREV_meta_corei7-64-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
-
-SRCREV_machine_i586-nlp-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
-SRCREV_machine_core2-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
-SRCREV_machine_corei7-64-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-
-KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base"
-KBRANCH_core2-32-intel-common = "standard/tiny/intel/base"
-KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base"
-
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
deleted file mode 100644
index 9ecdb95a..00000000
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
-
-LINUX_VERSION_i586-nlp-32-intel-common = "4.9.13"
-LINUX_VERSION_core2-32-intel-common = "4.9.13"
-LINUX_VERSION_corei7-64-intel-common = "4.9.13"
-
-SRCREV_meta_i586-nlp-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
-SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
-SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
-
-SRCREV_machine_i586-nlp-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
-SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
-SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-
-KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
-KBRANCH_core2-32-intel-common = "standard/tiny/base"
-KBRANCH_corei7-64-intel-common = "standard/tiny/base"
-
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto_%.bbappend b/common/recipes-kernel/linux/linux-yocto_%.bbappend
deleted file mode 100644
index 7c29be14..00000000
--- a/common/recipes-kernel/linux/linux-yocto_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-# The kernel build is 64-bit regardless, so include both common overrides.
-# Without this, the kernel will be missing vars that make it buildable for the
-# intel-corei7-64 machine.
-MACHINEOVERRIDES_prepend_corei7-64-x32-intel-common = "corei7-64-intel-common:"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto_4.10.bbappend
deleted file mode 100644
index 20504637..00000000
--- a/common/recipes-kernel/linux/linux-yocto_4.10.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# For FRI2, NUC
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.12.bbappend b/common/recipes-kernel/linux/linux-yocto_4.12.bbappend
deleted file mode 100644
index 20504637..00000000
--- a/common/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# For FRI2, NUC
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
deleted file mode 100644
index 3b02a932..00000000
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ /dev/null
@@ -1,43 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
-
-LINUX_VERSION_INTEL_COMMON = "4.4.87"
-SRCREV_META_INTEL_COMMON = "804d2b3164ec25ed519fd695de9aa0908460c92e"
-SRCREV_MACHINE_INTEL_COMMON = "57746baa7ae35660fe807c65b6809e6b16d4a448"
-
-KBRANCH_INTEL_COMMON = "standard/intel/base"
-
-KERNEL_FEATURES_INTEL_COMMON ?= ""
-
-LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
-SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'a249f6388ace2a4035220c2333649b42c300faa9', '${SRCREV_MACHINE_INTEL_COMMON}', d)}"
-KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-# Quark / X1000 BSP Info
-LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
-SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
-SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# For FRI2, NUC
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.9.bbappend b/common/recipes-kernel/linux/linux-yocto_4.9.bbappend
deleted file mode 100644
index a09fe1a4..00000000
--- a/common/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-KERNEL_FEATURES_INTEL_COMMON = ""
-
-COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
-KMACHINE_core2-32-intel-common = "intel-core2-32"
-KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-
-COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
-KMACHINE_i586-nlp-32-intel-common = "intel-quark"
-KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
-# For Crystalforest and Romley
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
-
-# For FRI2, NUC
-KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
-KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"