aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend')
-rw-r--r--common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
new file mode 100644
index 00000000..c59ddb2f
--- /dev/null
+++ b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
+
+python() {
+ # When we add more kernels for linux-intel, we may have to add a Version check
+ if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"):
+ src_uri = d.getVar("SRC_URI")
+ d.setVar("SRC_URI", src_uri +
+ " file://0001-zc-Force-4.10-get_user_pages_remote-API.patch")
+}