aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb8
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb b/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
index a3a7ec07..fef8d5fb 100644
--- a/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
@@ -17,3 +17,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit setuptools
DEPENDS += "python-vcversioner"
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-vcversioner-native \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index 2fe96ab8..bcff6f35 100644
--- a/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -14,3 +14,11 @@ SRC_URI[sha256sum] = "acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit setuptools
+
+
+DEPENDS_class-native += " \
+ python \
+ python-setuptools \
+ "
+
+BBCLASSEXTEND = "native"