aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000')
-rw-r--r--meta-v1000/conf/local.conf.append.v100027
-rw-r--r--meta-v1000/conf/machine/v1000.conf6
-rw-r--r--meta-v1000/recipes-graphics/amdvlk/amdvlk_1.0.bb2
-rw-r--r--meta-v1000/recipes-graphics/amdvlk/files/amd_icd64.json3
-rw-r--r--meta-v1000/recipes-graphics/amdvlk/files/amdvlk64.sobin20050584 -> 40750352 bytes
-rw-r--r--meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend6
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_asd.binbin33280 -> 49664 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_ce.binbin9344 -> 9344 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_me.binbin17536 -> 17536 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec.binbin268048 -> 268048 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec2.binbin268048 -> 268048 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_pfp.binbin21632 -> 21632 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_rlc.binbin26948 -> 39036 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_sdma.binbin17408 -> 17408 bytes
-rw-r--r--meta-v1000/recipes-kernel/linux/linux-yocto-4.14.71/v1000-extra-config.cfg2
-rw-r--r--meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend1
-rw-r--r--meta-v1000/recipes-support/opencv/opencv_%.bbappend2
17 files changed, 31 insertions, 18 deletions
diff --git a/meta-v1000/conf/local.conf.append.v1000 b/meta-v1000/conf/local.conf.append.v1000
index 4c5658ec..34518aa6 100644
--- a/meta-v1000/conf/local.conf.append.v1000
+++ b/meta-v1000/conf/local.conf.append.v1000
@@ -40,10 +40,25 @@ COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "commercial_gstreamer1.0-plugins-ugly \
LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
CORE_IMAGE_EXTRA_INSTALL_append = "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-# MEL has support for Vulkan/LunarG SDK components.
-# These components are required to run the Vulkan based applications.
-# In order to include these components in your final
-# image or generating an ADE that can be used to develop for/against these
-# please change the below define to "yes" before building the
-# image or generating ADE.
+# MEL supports various components that can be enabled by setting the corresponding
+# INCLUDE_<component> to "yes".
+# Following is a list of <components> that can be enabled if you want them to be
+# installed/available on your image.
+# Please change the required INCLUDE_<component> to "yes" before building an image, or
+# generating an ADE that can be used to develop apps for these components (if applicable):
+#
+# - VULKAN - Vulkan driver and Loader Layer.
+# It is required to run Vulkan based applications. Vulkan is a new generation graphics
+# and compute API that provides high-efficiency, cross-platform access to modern GPUs.
+#
+# - OPENCL - The Open Computing Language.
+# Framework for writing programs that execute across heterogeneous platforms consisting
+# of CPUs, GPUs, DSPs, FPGAs and other processors or hardware accelerators.
+#
+# - OPENCV - The Open Computer Vision Library.
+# Library of programming functions mainly aimed at real-time computer vision. Used for
+# image-processing on input from image/video files and camera etc.
+#
INCLUDE_VULKAN ??= "no"
+INCLUDE_OPENCL ??= "no"
+INCLUDE_OPENCV ??= "no"
diff --git a/meta-v1000/conf/machine/v1000.conf b/meta-v1000/conf/machine/v1000.conf
index d0fb4c5d..27215d63 100644
--- a/meta-v1000/conf/machine/v1000.conf
+++ b/meta-v1000/conf/machine/v1000.conf
@@ -9,13 +9,15 @@ PATCH_VERSION = "0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.14%"
-PREFERRED_PROVIDER_llvm ?= "llvm6.0"
require conf/machine/include/tune-v1000.inc
# Add machine specific AMD features and feature pkgs here
VULKAN_PKGS_v1000 = "amdvlk glslang spirv-tools vulkan-loader-layers rgp"
-AMD_PLATFORM_SPECIFIC_PKGS_v1000 += "opencl"
+AMD_PLATFORM_SPECIFIC_PKGS_v1000 += " \
+ ${@bb.utils.contains('INCLUDE_OPENCL', 'yes', 'opencl', '', d)} \
+ ${@bb.utils.contains('INCLUDE_OPENCV', 'yes', 'opencv', '', d)} \
+ "
include conf/machine/include/amd-common-configurations.inc
include conf/machine/include/amd-customer-configurations.inc
diff --git a/meta-v1000/recipes-graphics/amdvlk/amdvlk_1.0.bb b/meta-v1000/recipes-graphics/amdvlk/amdvlk_1.0.bb
index 4344a5b2..2635552e 100644
--- a/meta-v1000/recipes-graphics/amdvlk/amdvlk_1.0.bb
+++ b/meta-v1000/recipes-graphics/amdvlk/amdvlk_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "AMD Vulkan ICD Library"
LICENSE = "BSD"
RDEPENDS_${PN} = "libdrm vulkan-loader-layers"
-LIC_FILES_CHKSUM = "file://amd_icd64.json;md5=169a0ec488fc9361f17883a5abdc5265"
+LIC_FILES_CHKSUM = "file://amd_icd64.json;md5=10cb7871f46c13ca7d2c9547969347b6"
SRC_URI = "file://amdvlk64.so \
file://amd_icd64.json \
diff --git a/meta-v1000/recipes-graphics/amdvlk/files/amd_icd64.json b/meta-v1000/recipes-graphics/amdvlk/files/amd_icd64.json
index 828099e6..15c0c973 100644
--- a/meta-v1000/recipes-graphics/amdvlk/files/amd_icd64.json
+++ b/meta-v1000/recipes-graphics/amdvlk/files/amd_icd64.json
@@ -2,6 +2,7 @@
"file_format_version": "1.0.0",
"ICD": {
"library_path": "/usr/lib64/amdvlk64.so",
- "api_version": "1.1.70"
+ "api_version": "1.1.96"
}
}
+
diff --git a/meta-v1000/recipes-graphics/amdvlk/files/amdvlk64.so b/meta-v1000/recipes-graphics/amdvlk/files/amdvlk64.so
index 9c4b0989..b0b96918 100644
--- a/meta-v1000/recipes-graphics/amdvlk/files/amdvlk64.so
+++ b/meta-v1000/recipes-graphics/amdvlk/files/amdvlk64.so
Binary files differ
diff --git a/meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend b/meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
deleted file mode 100644
index 7c661e41..00000000
--- a/meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Force X to be run on vt7
-do_install_append_v1000() {
- if [ -f ${D}${sysconfdir}/default/xserver-nodm ]; then
- echo "INPUT_EXTRA_ARGS=vt7" >> ${D}${sysconfdir}/default/xserver-nodm
- fi
-}
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_asd.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_asd.bin
index 80f2be51..7c4e7c09 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_asd.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_asd.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_ce.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_ce.bin
index 8a02261b..23636279 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_ce.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_ce.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_me.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_me.bin
index a55d8e94..da8c4bf9 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_me.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_me.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec.bin
index 93c8d94d..c45de0a1 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec2.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec2.bin
index 93c8d94d..c45de0a1 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec2.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_mec2.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_pfp.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_pfp.bin
index d3ab7d7a..963a0111 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_pfp.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_pfp.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_rlc.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_rlc.bin
index 12957af3..9f0e8810 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_rlc.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_rlc.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_sdma.bin b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_sdma.bin
index d4579acd..f0aa630a 100644
--- a/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_sdma.bin
+++ b/meta-v1000/recipes-kernel/linux-firmware/amdgpu-firmware/raven_sdma.bin
Binary files differ
diff --git a/meta-v1000/recipes-kernel/linux/linux-yocto-4.14.71/v1000-extra-config.cfg b/meta-v1000/recipes-kernel/linux/linux-yocto-4.14.71/v1000-extra-config.cfg
index 5dacfd28..4964cada 100644
--- a/meta-v1000/recipes-kernel/linux/linux-yocto-4.14.71/v1000-extra-config.cfg
+++ b/meta-v1000/recipes-kernel/linux/linux-yocto-4.14.71/v1000-extra-config.cfg
@@ -212,7 +212,7 @@ CONFIG_BCMA_DRIVER_PCI=y
# CONFIG_DRM_I2C_ADV7511 is not set
# CONFIG_DRM_AMD_POWERPLAY is not set
# CONFIG_DRM_VGEM is not set
-CONFIG_HSA_AMD=m
+CONFIG_HSA_AMD=y
CONFIG_FB_CMDLINE=y
CONFIG_HDMI=y
CONFIG_DUMMY_CONSOLE_COLUMNS=80
diff --git a/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
deleted file mode 100644
index 53f3483c..00000000
--- a/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG_append_v1000 = " vaapi"
diff --git a/meta-v1000/recipes-support/opencv/opencv_%.bbappend b/meta-v1000/recipes-support/opencv/opencv_%.bbappend
new file mode 100644
index 00000000..926175c4
--- /dev/null
+++ b/meta-v1000/recipes-support/opencv/opencv_%.bbappend
@@ -0,0 +1,2 @@
+# We do not support Video4Linux
+PACKAGECONFIG_remove_v1000 = " v4l libv4l"