aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/conf/machine/include/amd-common-configurations.inc1
-rw-r--r--common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch35
-rw-r--r--common/recipes-core/llvm/llvm_git.bbappend14
-rw-r--r--common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch35
-rw-r--r--common/recipes-graphics/drm/libdrm_git.bb5
-rw-r--r--common/recipes-graphics/libva/libva_2.1.0.bbappend1
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch33
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb18
-rw-r--r--common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend6
-rw-r--r--common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend2
10 files changed, 103 insertions, 47 deletions
diff --git a/common/conf/machine/include/amd-common-configurations.inc b/common/conf/machine/include/amd-common-configurations.inc
index b6d52110..3755b02e 100644
--- a/common/conf/machine/include/amd-common-configurations.inc
+++ b/common/conf/machine/include/amd-common-configurations.inc
@@ -6,6 +6,7 @@ PREFERRED_PROVIDER_jpeg ?= "jpeg"
PREFERRED_PROVIDER_jpeg-native ?= "jpeg-native"
PREFERRED_VERSION_linux-yocto ?= "4.4%"
PREFERRED_VERSION_libav ?= "9.18"
+PREFERRED_PROVIDER_llvm ?= "llvm7"
MULTILIBS ?= ""
require conf/multilib.conf
diff --git a/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch b/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
new file mode 100644
index 00000000..7b490a81
--- /dev/null
+++ b/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
@@ -0,0 +1,35 @@
+From ac39269933a9011567722e69c02734beaa1191b3 Mon Sep 17 00:00:00 2001
+From: Martin Kelly <mkelly@xevo.com>
+Date: Fri, 19 May 2017 00:22:57 -0700
+Subject: [PATCH] llvm: allow env override of exe path
+
+When using a native llvm-config from inside a sysroot, we need llvm-config to
+return the libraries, include directories, etc. from inside the sysroot rather
+than from the native sysroot. Thus provide an env override for calling
+llvm-config from a target sysroot.
+
+Signed-off-by: Martin Kelly <mkelly@xevo.com>
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ tools/llvm-config/llvm-config.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
+index 892adc3b9dd..73b6989fa9e 100644
+--- a/tools/llvm-config/llvm-config.cpp
++++ b/tools/llvm-config/llvm-config.cpp
+@@ -226,6 +226,13 @@ Typical components:\n\
+
+ /// Compute the path to the main executable.
+ std::string GetExecutablePath(const char *Argv0) {
++ // Hack for Yocto: we need to override the root path when we are using
++ // llvm-config from within a target sysroot.
++ const char *Sysroot = std::getenv("YOCTO_ALTERNATE_EXE_PATH");
++ if (Sysroot != nullptr) {
++ return Sysroot;
++ }
++
+ // This just needs to be some symbol in the binary; C++ doesn't
+ // allow taking the address of ::main however.
+ void *P = (void *)(intptr_t)GetExecutablePath;
diff --git a/common/recipes-core/llvm/llvm_git.bbappend b/common/recipes-core/llvm/llvm_git.bbappend
index 373df6cb..bd77ed77 100644
--- a/common/recipes-core/llvm/llvm_git.bbappend
+++ b/common/recipes-core/llvm/llvm_git.bbappend
@@ -1,2 +1,16 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c520ed40e11887bb1d24d86f7f5b1f05"
+
+SRCREV = "4a059213dd6f034147e9083c21133dc1b57b3a8a"
+PV = "7"
+BRANCH = "release_70"
+PATCH_VERSION = "0"
+
SRC_URI += "file://0001-llvm-config-allow-overriding-libdir-through-cmdline.patch"
+SRC_URI_remove = "file://0001-Disable-generating-a-native-llvm-config.patch"
+
+INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE}.${PATCH_VERSION}.0 += "dev-so"
+
+PACKAGES =+ "${PN}-testplugin"
+FILES_${PN}-testplugin = "${libdir}/${LLVM_DIR}/TestPlugin.so"
+FILES_${PN}-dbg += "${libdir}/${LLVM_DIR}/.debug/TestPlugin.so"
diff --git a/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch b/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch
deleted file mode 100644
index 2e6ba6ac..00000000
--- a/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 48ec0e7b1203e9fbe4aa8b59642ed0abeb739ab5 Mon Sep 17 00:00:00 2001
-From: Rex Zhu <Rex.Zhu@amd.com>
-Date: Wed, 31 Jan 2018 12:56:44 +0800
-Subject: [PATCH] headers: sync up amdgpu_drm.h with drm-next
-
-Add sensor_info type
-AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_MCLK
-AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_SCLK
-
-Change-Id: I83c763aee5cd0be21f2ab5734f0d19ffb59a2628
-Acked-by: Junwei Zhang <Jerry.Zhang@amd.com>
-Reviewed-by: Evan Quan <evan.quan@amd.com>
-Signed-off-by: Rex Zhu <Rex.Zhu@amd.com>
----
- include/drm/amdgpu_drm.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/include/drm/amdgpu_drm.h b/include/drm/amdgpu_drm.h
-index a023b47..f784f24 100644
---- a/include/drm/amdgpu_drm.h
-+++ b/include/drm/amdgpu_drm.h
-@@ -656,6 +656,10 @@ struct drm_amdgpu_cs_chunk_data {
- #define AMDGPU_INFO_SENSOR_VDDNB 0x6
- /* Subquery id: Query graphics voltage */
- #define AMDGPU_INFO_SENSOR_VDDGFX 0x7
-+ /* Subquery id: Query GPU stable pstate shader clock */
-+ #define AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_SCLK 0x8
-+ /* Subquery id: Query GPU stable pstate memory clock */
-+ #define AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_MCLK 0x9
- /* Number of VRAM page faults on CPU access. */
- #define AMDGPU_INFO_NUM_VRAM_CPU_PAGE_FAULTS 0x1E
- #define AMDGPU_INFO_VRAM_LOST_COUNTER 0x1F
---
-2.7.4
-
diff --git a/common/recipes-graphics/drm/libdrm_git.bb b/common/recipes-graphics/drm/libdrm_git.bb
index cbca6b72..d516c526 100644
--- a/common/recipes-graphics/drm/libdrm_git.bb
+++ b/common/recipes-graphics/drm/libdrm_git.bb
@@ -9,16 +9,15 @@ SECTION = "x11/base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
PROVIDES = "drm"
-DRM_VERSION = "2.4.91"
+DRM_VERSION = "2.4.96"
PV = "${DRM_VERSION}+git${SRCPV}"
inherit autotools pkgconfig
-SRCREV = "85ae22af0f209e73c954d8867d9189ab2cfeb3e1"
+SRCREV = "5a3bdc7add2f30f7673052376514c91dbcd1b64a"
DEPENDS = "libpthread-stubs udev libpciaccess freetype libxext cairo fontconfig libxrender libpng pixman"
SRC_URI = "git://anongit.freedesktop.org/mesa/drm;branch=master \
- file://0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch \
file://amdgpu.ids \
"
diff --git a/common/recipes-graphics/libva/libva_2.1.0.bbappend b/common/recipes-graphics/libva/libva_2.1.0.bbappend
index b28610f4..f8ffae4a 100644
--- a/common/recipes-graphics/libva/libva_2.1.0.bbappend
+++ b/common/recipes-graphics/libva/libva_2.1.0.bbappend
@@ -5,3 +5,4 @@ EXTRA_OECONF_append_amd = " --disable-glx"
PACKAGES_remove_amd = "libva-x11 libva-glx"
# This package (without x11) is no more dependent on mesa
DEPENDS_remove_amd = "virtual/mesa"
+RRECOMMENDS_${PN}_append_amd = " libva-utils"
diff --git a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
new file mode 100644
index 00000000..d40aaa98
--- /dev/null
+++ b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
@@ -0,0 +1,33 @@
+From ad0ef93a61be1ccd00e3b48bf6913bc2bffb3143 Mon Sep 17 00:00:00 2001
+From: Samuel Pitoiset <samuel.pitoiset@gmail.com>
+Date: Fri, 7 Dec 2018 10:08:38 +0100
+Subject: [PATCH] gallium: add missing PIPE_CAP_SURFACE_SAMPLE_COUNT default
+ value
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes: 2710c40e3c8 ("gallium: Add new PIPE_CAP_SURFACE_SAMPLE_COUNT")
+Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
+Tested-by: Michel Dänzer <michel.daenzer@amd.com>
+---
+ src/gallium/auxiliary/util/u_screen.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/gallium/auxiliary/util/u_screen.c b/src/gallium/auxiliary/util/u_screen.c
+index 95d2a7d5701..6ca3992ecd1 100644
+--- a/src/gallium/auxiliary/util/u_screen.c
++++ b/src/gallium/auxiliary/util/u_screen.c
+@@ -328,6 +328,9 @@ u_pipe_screen_get_param_defaults(struct pipe_screen *pscreen,
+ case PIPE_CAP_MAX_VERTEX_ELEMENT_SRC_OFFSET:
+ return 2047;
+
++ case PIPE_CAP_SURFACE_SAMPLE_COUNT:
++ return 0;
++
+ default:
+ unreachable("bad PIPE_CAP_*");
+ }
+--
+2.11.1
+
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
index 4e38fd06..596b8105 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_git.bb
@@ -5,9 +5,9 @@ S = "${WORKDIR}/git"
DEPENDS_append = " python-mako-native"
inherit pythonnative
-SRCREV_amd = "1f3536b80baf248761ccffcfc59d9fad23933945"
+SRCREV_amd = "0144bbdb98f515cce31688fce57d769e7fd82d52"
LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_amd = "18.1.1+git${SRCPV}"
+PV_amd = "19.0.0+git${SRCPV}"
DEPENDS_append_amd = " libvdpau libomxil"
@@ -24,19 +24,20 @@ LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' libva-x11',
LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-wayland', '', d)}"
RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-MESA_LLVM_RELEASE_amd = "6.0"
+MESA_LLVM_RELEASE_amd = "7"
-SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=18.1 \
+SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
- file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch"
+ file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
+ file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
EXTRA_OECONF_append_amd = " \
--enable-vdpau \
--enable-osmesa \
--enable-glx \
--enable-omx-bellagio \
- --with-omx-bellagio-libdir=${libdir}/bellagio \
- --enable-texture-float"
+ --with-omx-bellagio-libdir=${libdir}/bellagio"
+EXTRA_OECONF_remove_amd = "--enable-texture-float"
# Package all the libXvMC gallium extensions together
# they provide the shared lib libXvMCGallium and splitting
@@ -56,9 +57,10 @@ FILES_${PN}-dbg += "${libdir}/vdpau/.debug"
# libomx files are non-versioned so we put *.so directly in the
# main package as opposed to the -dev package.
#
-PACKAGES =+ "libomx-${PN} libomx-${PN}-dev"
+PACKAGES =+ "libomx-${PN} libomx-${PN}-dev ${PN}-driconfigs"
FILES_libomx-${PN} = "${libdir}/bellagio/libomx_*.so"
FILES_libomx-${PN}-dev = "${libdir}/bellagio/libomx_*.la"
+FILES_${PN}-driconfigs = "${datadir}/drirc.d/*"
FILES_${PN}-dbg += "${libdir}/bellagio/.debug"
# Set DRIDRIVERS with anonymous python so we can effectively
diff --git a/common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend b/common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
new file mode 100644
index 00000000..3bb9fae6
--- /dev/null
+++ b/common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
@@ -0,0 +1,6 @@
+# Force X to be run on vt7
+do_install_append_amdgpu() {
+ if [ -f ${D}${sysconfdir}/default/xserver-nodm ]; then
+ echo "INPUT_EXTRA_ARGS=vt7" >> ${D}${sysconfdir}/default/xserver-nodm
+ fi
+}
diff --git a/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
index 17f101db..be3d0a0c 100644
--- a/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ b/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
@@ -1,3 +1,3 @@
PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
-PACKAGECONFIG_append_amdgpu = " vdpau"
+PACKAGECONFIG_append_amdgpu = " vdpau vaapi"
PACKAGECONFIG_append_radeon = " vdpau"