aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/crun/crun_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/crun/crun_git.bb')
-rw-r--r--recipes-containers/crun/crun_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index 18d0c722..107e08b7 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -3,8 +3,8 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
PRIORITY = "optional"
-SRCREV_crun = "858ff2f605983ed420b09fd716c9c8e0cee5c174"
-SRCREV_libocispec = "ece5f6aede6488396f9c84bc985df09f95204e1d"
+SRCREV_crun = "f302dd8c02c6fddd2c50d1685d82b7a19aae8afe"
+SRCREV_libocispec = "c9b8b9524814550a489aa6d38b2dec95633ffa15"
SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693"
SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476"
@@ -22,12 +22,16 @@ inherit autotools-brokensep pkgconfig
PACKAGECONFIG ??= ""
-DEPENDS = "yajl libcap go-md2man-native"
+DEPENDS = "yajl libcap go-md2man-native m4-native"
# TODO: is there a packageconfig to turn this off ?
DEPENDS += "libseccomp"
DEPENDS += "systemd"
DEPENDS += "oci-image-spec oci-runtime-spec"
+do_configure_prepend () {
+ ./autogen.sh
+}
+
do_install() {
oe_runmake 'DESTDIR=${D}' install
}