summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch30
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb18
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus_3.1.3.bb22
3 files changed, 22 insertions, 48 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
deleted file mode 100644
index 49abf35..0000000
--- a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
-issues with automake 1.15.
-
-https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
-https://bugzilla.redhat.com/show_bug.cgi?id=1179182
-
-Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
-Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=353]
-
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac
-+++ git/configure.ac
-@@ -4,12 +4,14 @@ AC_INIT([GENIVI IPC Common API DBus C++]
- [],
- [CommonAPI-DBus])
-
-+AC_CONFIG_AUX_DIR([build-aux])
-+AC_CONFIG_HEADERS([build-aux/config.h])
-+
- AC_USE_SYSTEM_EXTENSIONS
-
- AC_CONFIG_MACRO_DIR([m4])
- m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
--AC_CONFIG_AUX_DIR([build-aux])
--AC_CONFIG_HEADERS([build-aux/config.h])
-+
- AC_CONFIG_FILES([
- Makefile
- CommonAPI-DBus.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
deleted file mode 100644
index 34b3071..0000000
--- a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "CommonAPI-DBus"
-SECTION = "libs"
-LICENSE = "MPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
-
-BRANCH ?= "maintain/2.1.6"
-TAG ?= "${PV}"
-SRC_URI = " \
- git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;branch=${BRANCH};tag=${TAG} \
- file://fix-with-automake-1-15.patch \
- "
-S = "${WORKDIR}/git"
-
-DEPENDS = "common-api2 dbus"
-
-CXXFLAGS := "${@oe_filter_out('-fvisibility-inlines-hidden', '${CXXFLAGS}', d)}"
-
-inherit autotools lib_package pkgconfig
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_3.1.3.bb b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_3.1.3.bb
new file mode 100644
index 0000000..c1cfa71
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_3.1.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "CommonAPI-DBus"
+SECTION = "libs"
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+PR = "r1"
+DEPENDS = "commonapi3 dbus"
+REQUIRES = "commonapi3 dbus"
+
+SRC_URI = "git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;branch=master;tag=${PV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE += "-DCMAKE_INSTALL_PREFIX=/usr "
+CXXFLAGS := "${@oe_filter_out('-fvisibility-inlines-hidden', '${CXXFLAGS}', d)}"
+
+do_configure_prepend() {
+ sed -i '/ set(${var} /c set(ABSOLUTE_${var} "${CMAKE_INSTALL_PREFIX}/${${var}}") ' ${S}/CMakeLists.txt
+ sed -i '/file(RELATIVE_PATH /c file(RELATIVE_PATH REL_INCLUDE_DIR "${ABSOLUTE_INSTALL_CMAKE_DIR}" "${ABSOLUTE_INSTALL_INCLUDE_DIR}") ' ${S}/CMakeLists.txt
+}
+
+inherit cmake lib_package pkgconfig
+FILES_${PN}-dev += "${libdir}/cmake"