aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb9
-rw-r--r--recipes-kernel/linux/linux-intel.inc5
-rw-r--r--recipes-kernel/linux/linux-intel_4.9.bb9
3 files changed, 14 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
index 8fb184b7..7a14c053 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -10,8 +10,11 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
-KBRANCH = "base-rt"
-SRCREV_machine ?= "3074f3308abdc15cbd2be92e5e5a7c0f31cfad84"
-SRCREV_meta ?= "f4e37e151102d89c4d0e110c88eb3b3c36bdeaa4"
+KBRANCH = "4.9/yocto/base-rt"
+KMETA_BRANCH = "yocto-4.9"
+
+LINUX_VERSION ?= "4.9.61"
+SRCREV_machine ?= "8eb1a43e7232c412673aaaeb968b02122e42de4d"
+SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 057779a1..f03ef463 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -3,17 +3,16 @@ require recipes-kernel/linux/linux-yocto.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
KERNEL_CONFIG_URI ?= " \
- git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
"
SRC_URI = " \
- git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
+ git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
${KERNEL_CONFIG_URI} \
"
SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
-LINUX_VERSION ?= "4.9.61"
LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb
index dfaf34d9..85cb9bbe 100644
--- a/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/recipes-kernel/linux/linux-intel_4.9.bb
@@ -1,9 +1,12 @@
require linux-intel.inc
-KBRANCH = "base"
-SRCREV_machine ?= "c2e99163add32c914514460fb67140409e287476"
-SRCREV_meta ?= "f4e37e151102d89c4d0e110c88eb3b3c36bdeaa4"
+KBRANCH = "4.9/yocto/base"
+KMETA_BRANCH = "yocto-4.9"
+
+LINUX_VERSION ?= "4.9.61"
+SRCREV_machine ?= "03469c2e703e40ed42ed72f415fd27c7d7f7f8cf"
+SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"