aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/files/make_install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/dtc/files/make_install.patch')
-rw-r--r--recipes-kernel/dtc/files/make_install.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/dtc/files/make_install.patch b/recipes-kernel/dtc/files/make_install.patch
new file mode 100644
index 00000000..ccf17b38
--- /dev/null
+++ b/recipes-kernel/dtc/files/make_install.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS)
+ install-lib: all
+ @$(VECHO) INSTALL-LIB
+ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+- $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+- ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++ $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
+ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
+ $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
+