aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb')
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
new file mode 100644
index 00000000..13cdf02d
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Mesa environment variables for etnaviv on xserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "file://mesa-etnaviv.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # MESA global envirronment variables
+
+ # systemd
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -D -m 644 ${WORKDIR}/mesa-etnaviv.conf \
+ ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf
+ fi
+
+ # sysvinit - TODO
+}
+
+ALLOW_EMPTY_${PN} = "1"