aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qoriq-arm.inc3
-rw-r--r--conf/machine/include/qoriq-base.inc3
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-linux_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-module_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-tests_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc (renamed from recipes-kernel/cryptodev/cryptodev_1.7.inc)0
6 files changed, 21 insertions, 3 deletions
diff --git a/conf/machine/include/qoriq-arm.inc b/conf/machine/include/qoriq-arm.inc
index 20a75945..ba6345cf 100644
--- a/conf/machine/include/qoriq-arm.inc
+++ b/conf/machine/include/qoriq-arm.inc
@@ -4,6 +4,9 @@ require conf/machine/include/soc-family.inc
PREFERRED_PROVIDER_u-boot_ls102xa ?= "u-boot-ls1"
PREFERRED_PROVIDER_virtual/bootloader_ls102xa ?= "u-boot-ls1"
PREFERRED_PROVIDER_virtual/kernel_ls102xa ?= "linux-ls1"
+PREFERRED_PROVIDER_cryptodev_ls102xa = "cryptodev-qoriq"
+PREFERRED_PROVIDER_cryptodev-module_ls102xa = "cryptodev-qoriq-module"
+PREFERRED_PROVIDER_cryptodev-tests_ls102xa = "cryptodev-qoriq-tests"
# Define the default image type
IMAGE_CLASSES ?= "image_types_uboot"
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index 25d22978..e5949fa4 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -4,6 +4,9 @@ require conf/machine/include/soc-family.inc
# providers
PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq"
PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq"
+PREFERRED_PROVIDER_cryptodev = "cryptodev-qoriq"
+PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module"
+PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests"
# versions
PREFERRED_VERSION_qemu = "2.2.0+fsl"
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
index 92ccd717..a388b4c8 100644
--- a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
@@ -1,7 +1,9 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A /dev/crypto device driver header file"
+PROVIDES = "cryptodev-linux"
+
do_compile[noexec] = "1"
# Just install cryptodev.h which is the only header file needed to be exported
@@ -10,3 +12,5 @@ do_install() {
}
ALLOW_EMPTY_${PN} = "1"
+
+COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
index e6b1f27c..df2e5464 100644
--- a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
@@ -1,10 +1,14 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A /dev/crypto device driver kernel module"
+PROVIDES = "cryptodev-module"
+
inherit module qoriq_build_64bit_kernel
# Header file provided by a separate package
DEPENDS += "cryptodev-linux"
EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
+
+COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
index 128ccc99..dd0afecd 100644
--- a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -1,8 +1,10 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A test suite for /dev/crypto device driver"
DEPENDS = "openssl"
+PROVIDES = "cryptodev-tests"
+
EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
do_compile() {
@@ -15,3 +17,5 @@ do_install() {
FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
FILES_${PN} = "${bindir}/tests_cryptodev/*"
+
+COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev_1.7.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
index 6b65f729..6b65f729 100644
--- a/recipes-kernel/cryptodev/cryptodev_1.7.inc
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc