aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
index fc965fa4..55f0c15f 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -1,4 +1,4 @@
-From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001
+From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Fri, 2 Sep 2016 15:48:52 +0800
Subject: [PATCH] dpdk: fix for parellel make issue
@@ -8,28 +8,29 @@ libraries will be build before, And available at the time of
linking example apps.
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
examples/Makefile | 1 +
examples/ethtool/ethtool-app/Makefile | 1 +
2 files changed, 2 insertions(+)
diff --git a/examples/Makefile b/examples/Makefile
-index 18b41b9..c7c2beb 100644
+index 17ecf7f64cda..2a8e805b85a7 100644
--- a/examples/Makefile
+++ b/examples/Makefile
-@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
+@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
DIRS-y += cmdline
DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
+DEPDIRS-y += examples/ethtool/lib
DIRS-y += ethtool
DIRS-y += exception_path
- DIRS-y += helloworld
+ DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
-index 09c66ad..ec068e6 100644
+index 4cd9efdd574b..d3c709ab2fef 100644
--- a/examples/ethtool/ethtool-app/Makefile
+++ b/examples/ethtool/ethtool-app/Makefile
-@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c
+@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
CFLAGS += $(WERROR_FLAGS)
@@ -37,6 +38,3 @@ index 09c66ad..ec068e6 100644
LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
LDLIBS += -lrte_ethtool
---
-1.9.1
-