aboutsummaryrefslogtreecommitdiffstats
path: root/meta-qat/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-qat/conf/layer.conf')
-rw-r--r--meta-qat/conf/layer.conf20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-qat/conf/layer.conf b/meta-qat/conf/layer.conf
new file mode 100644
index 00000000..2e3aa847
--- /dev/null
+++ b/meta-qat/conf/layer.conf
@@ -0,0 +1,20 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "intel-qat"
+BBFILE_PATTERN_intel-qat := "^${LAYERDIR}/"
+BBFILE_PRIORITY_intel-qat = "5"
+
+LAYERDEPENDS_intel-qat = "core intel"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_intel-qat = "1"
+LAYERSERIES_COMPAT_intel-qat = "rocko"
+
+
+require ${LAYERDIR}/conf/include/maintainers.inc