aboutsummaryrefslogtreecommitdiffstats
path: root/meta-dpdk/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-dpdk/conf/layer.conf')
-rw-r--r--meta-dpdk/conf/layer.conf19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-dpdk/conf/layer.conf b/meta-dpdk/conf/layer.conf
new file mode 100644
index 00000000..61331edc
--- /dev/null
+++ b/meta-dpdk/conf/layer.conf
@@ -0,0 +1,19 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "dpdk"
+BBFILE_PATTERN_dpdk := "^${LAYERDIR}/"
+BBFILE_PRIORITY_dpdk = "5"
+
+LAYERDEPENDS_dpdk = "core"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_dpdk = "1"
+LAYERSERIES_COMPAT_dpdk = "rocko"
+
+require ${LAYERDIR}/conf/include/maintainers.inc