aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support
AgeCommit message (Collapse)AuthorFilesLines
2018-06-22Ruby-shadow upgrade to 2.5.0Pablo Saavedra1-2/+2
Ruby was upgraded to 2.5.0 in sumo. A upgrade in the ruby-shadow is needed to build Upstream changes: * Updates code source reference * Fixes for rubinius and tests * Add friendlier method names * Start to add some smoke tests * Provide info on implementation Finally, this version of the package is alrady added in Debian Buster as well. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2018-05-29nss-pam-ldapd: fix SRC_URI and DEPENDSLei Maohui1-2/+2
- Fix SRC_URI, modified ${PN} to ${BPN} - Added krb5 into DEPENDS Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2018-03-12Revert "spice: Fix compile errors from gcc 7 with spice 0.12.4"Bruce Ashfield2-89/+0
This reverts commit 7f8de36343df74ba7aacc2ccb61e3b78d9b90ac0.
2018-03-08spice: Fix compile errors from gcc 7 with spice 0.12.4Jason Wessel2-0/+89
../../git/server/red_parse_qxl.c:367:18: error: 'BITMAP_FMT_IS_RGB' defined but not used [-Werror=unused-const-variable=] static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1}; ^~~~~~~~~~~~~~~~~ ../../git/server/inputs_channel.c: In function 'inputs_channel_handle_parsed': ../../git/server/inputs_channel.c:317:38: error: this statement may fall through [-Werror=implicit-fallthrough=] case SPICE_MSGC_INPUTS_KEY_DOWN: { ^ ../../git/server/inputs_channel.c:324:5: note: here case SPICE_MSGC_INPUTS_KEY_UP: { ^~~~ ../../git/server/reds.c: In function 'vdi_port_read_one_msg_from_device': ../../git/server/reds.c:797:31: error: this statement may fall through [-Werror=implicit-fallthrough=] state->read_state = VDI_PORT_READ_STATE_GET_BUFF; ~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../../git/server/reds.c:798:9: note: here case VDI_PORT_READ_STATE_GET_BUFF: { ^~~~ ../../git/server/reds.c:807:31: error: this statement may fall through [-Werror=implicit-fallthrough=] state->read_state = VDI_PORT_READ_STATE_READ_DATA; ~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../../git/server/reds.c:809:9: note: here case VDI_PORT_READ_STATE_READ_DATA: ^~~~ This patch just adds the fallthrough comments which are already checked in upstream along with the removal of the static variable which is not used. The newer versions of spice already have this fixed, so there is no need to further upstream this patch. It gets dropped in the future. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2018-02-20Puppet upstream upgrade to 5.4.0Pablo Saavedra9-118/+114
* Upstream to 5.4.0 [1][2][3][4][5] * Puppet 5 recipe is the official Puppet agent version with support for Ruby 2.4 [6] * Updated reference versions in the README file * Hiera isn’t separate from Puppet anymore [7]. * Do not install extlookup2hiera, it has been removed upstream * Hiera began as an independent Ruby library that worked with Puppet. Over time, it became a requirement and was even included in the puppet-agent package, but it was limited by its original design. * Removed puppet_3.7.3.bb recipe * Drop the superseded patches * Added init script * Added systemd script Facter 2.5 upstream release * Puppet 5 relays on Facter 3.10. Facter 3.10 reworks Facter 2.X code [8] in native code instead of Ruby gem. Facter 2.5 is still compatible with 5 series to help with Puppet 5 testing. * facter before 2.4.0 uses a deprecated Puppet settings API making `facter --puppet` no longer work with Puppet 4 or higher [9]. * Community, partner, and some of Puppet's internal testing workflows continue to use (ruby) Facter 2.4 [10], instead of native Facter 3, which is not (yet) available as a gem. * To help with Puppet 5 testing, we need to do a maintenance release in the Facter 2 series. [1] https://docs.puppet.com/puppet/5.0/release_notes.html [2] https://docs.puppet.com/puppet/5.1/release_notes.html [3] https://docs.puppet.com/puppet/5.2/release_notes.html [4] https://docs.puppet.com/puppet/5.3/release_notes.html [5] https://docs.puppet.com/puppet/5.4/release_notes.html [6] https://puppet.com/docs/puppet/4.10/hiera_intro.html [7] https://tickets.puppetlabs.com/browse/PA-1107 [8] https://github.com/puppetlabs/facter/tree/3.10.x [9] http://metadata.ftp-master.debian.org/changelogs/main/p/puppet/puppet_5.1.0-1_changelog [10] https://tickets.puppetlabs.com/browse/FACT-1630 Signed-off-by: Pablo Saavedra <psaavedra@igalia.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-09-29spice: fix CVE-2017-7506Yi Zhao4-0/+175
CVE-2017-7506: spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak. Reference: https://nvd.nist.gov/vuln/detail/CVE-2017-7506 Patches from: https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=f1e7ec03e26ab6b8ca9b7ec060846a5b706a963d https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=ec6229c79abe05d731953df5f7e9a05ec9f6df79 https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=a957a90baf2c62d31f3547e56bba7d0e812d2331 Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-08-24spice: fix builds with gcc 7.xMark Asselstine2-0/+60
There is an upstream fix for this issue but it doesn't apply cleanly and is rather simple so rather than backport it and turn it into something unrecognizeable I simply created my own version of it. This fixes builds which fail with: | ../../git/server/reds.c: In function 'vdi_port_read_one_msg_from_device': | ../../git/server/reds.c:797:31: error: this statement may fall through [-Werror=implicit-fallthrough=] | state->read_state = VDI_PORT_READ_STATE_GET_BUFF; | ~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ../../git/server/reds.c:798:9: note: here | case VDI_PORT_READ_STATE_GET_BUFF: { | ^~~~ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-08-17nss-pam-ldapd: upgrade to 0.9.8Huang Qiyu1-2/+2
Upgrade nss-pam-ldapd from 0.9.7 to 0.9.8. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-07-25spice: set COMPATIBLE_HOSTChen Qi1-0/+2
Set COMPATIBLE_HOST to restrict building only for x86 archs. The configure script clearly requires x86 archs. Message is as below. Only x86 and x86-64 are supported Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-07-25spice: Fix build failuresHe Zhe2-0/+73
Backport 3cb746329ea4846bd9c65e0198e69423379b6f62 "Use PRI macros in printf to keep compatibility between 32/64bit system" from upstream to fix the following errors: server/jpeg_encoder.c:639:17: error: format '%lu' expects argument of type 'long unsigned int', but argument 12 has type 'uint64_t {aka long long unsigned int}' [-Werror=format=] server/mjpeg_encoder.c:639:17: error: format '%lu' expects argument of type 'long unsigned int', but argument 13 has type 'uint64_t {aka long long unsigned int}' [-Werror=format=] server/mjpeg_encoder.c:706:21: error: format '%lu' expects argument of type 'long unsigned int', but argument 6 has type 'uint64_t {aka long long unsigned int}' [-Werror=format=] server/mjpeg_encoder.c:706:21: error: format '%lu' expects argument of type 'long unsigned int', but argument 7 has type 'uint64_t {aka long long unsigned int}' [-Werror=format=] server/mjpeg_encoder.c:936:75: error: integer overflow in expression [-Werror=overflow] Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2017-06-29spice: Fix compilation errorHe Zhe2-0/+30
| ../../git/server/red_parse_qxl.c:367:18: error: 'BITMAP_FMT_IS_RGB' defined but not used [-Werror=unused-const-variable=] | static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1}; Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-09-19nss-pam-ldapd: 0.9.6 -> 0.9.7Wang Xin1-2/+2
Upgrade nss-pam-ldapd from 0.9.6 to 0.9.7. Signed-off-by: Wang Xin <wangxin2015.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-08-31spice: Add missing license to LICENSEMark Asselstine1-1/+1
There is a new QA check warning which has been added which flags situation where a subpackage includes a license which is not included in the recipe's LICENSE string. In this case we are seeing: WARNING: .../meta-cloud-services/recipes-support/spice/spice_git.bb: LICENSE_lib32-spice-protocol includes licenses (BSD) that are not listed in LICENSE Adding the missing license to the LICENSE string. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-05-31spice: add PACKAGECONFIG for xineramaJackie Huang1-0/+1
spice auto detect Xinerama library to enable the feature, but it causes error when using sstate between different builds, e.g. previous build have xinerama but the later one doesn't, then it fails on the later one with: "Package 'xinerama', required by 'spice-server', not found" Add PACKAGECONFIG for xinerama to ensure we have deterministic builds. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-04-28nss-pam-ldapd: add systemd supportLiang Li2-2/+18
Just add systemd style service file. Signed-off-by: Liang Li <liang.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-04-28nss-pam-ldapd: move from meta-openstack to base layerLiang Li2-0/+137
To prepare enable nss-pam-ldapd reuseable by other layer/addons. Signed-off-by: Liang Li <liang.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-01-19ruby-shadow: Work around cross compile gem problemJason Wessel1-1/+1
Prior to this commit it is not possible to cross build a ruby gem. In fact even on the x86 system the object files for the native gem are generated with the wrong compiler (the host compiler instead of the cross compiler). A better way to fix this in the future would be to use only gems that supported cross compile tool called rake. For now the bbclass can modify the extconf.rb just before creating the gem and insert some code into the Makefile so as to honor the cross compile environment. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-01-11puppet: add new recipe for puppet-vswitch moduleMark Asselstine2-0/+67
There are several puppet modules that provide functionality to interact with vSwitches, such as OpenVSwitch. This one is one of the more popular and is an officially sanctioned puppet module so using this one for the time being. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2016-01-11puppet: add puppetlabs stdlib moduleMark Asselstine2-0/+64
This module is used by many puppet modules so will be useful to have to extend our puppet capabilities. Additionally it offers some useful functionality such as the ability to append to a file. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2015-09-16celt051: use https protocol in git fetcherJosep Puigdemont1-1/+1
Only the https protocol is available when cloning from git.xiph.org currently. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2015-09-10spice: add SRCREV_FORMAT to recipeJoe Slater1-0/+2
Create a composite source revision. Failure to do so can cause parsing errors. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2015-08-20puppet: back-port some patches to fix issues with Ruby >= 2.0.0Mark Asselstine4-0/+105
We should uprev puppet at some point but for the sake of stabilizing first the following set of patches will allow puppet to work with the newer version of Ruby that we are using. The first two are upstream commits and the third is a commit which borrows a fix found in various puppet forks (repos which people host to stabalize older versions of puppet). With these patches puppet can now execute commands like 'help' and 'apply' without falling over. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2015-08-20puppet: fixup QA warningMark Asselstine1-0/+1
Currently we get the following warning when building puppet: WARNING: QA Issue: /usr/lib/ruby/gems/2.2.0/gems/puppet-3.7.3/ lib/puppet/vendor/safe@underscore@yaml/run@underscore@specs@ underscore@all@underscore@ruby@underscore@versions.sh_puppet contained in package puppet requires /bin/bash, but no providers found in its RDEPENDS [file-rdeps] Adding 'bash' as an RDEPENDS fixes this. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2015-08-20puppet: move to base layerMark Asselstine9-0/+255
Puppet can be used by many 'cloud services', it is not openstack specific, so moving puppet and puppet related recipes to the meta-cloud-services base layer. This allows either internal sub-layers found in meta-cloud-services or external layers to include meta-cloud-services without being burdened by bbappends and configs found in meta-openstack. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2014-07-30keystone: package openLDAP 2.4.39Amy Fong24-0/+1341
The patches are taken from Debian. Signed-off-by: Amy Fong <amy.fong@windriver.com>
2014-05-21autotools: B != S build fixesBruce Ashfield1-1/+1
Since oe-core introduced the autotools separated build and source directory changes, some package builds broke. With this change, we can build against the latest oe-core master. It should be noted that this masks the build issues, and the bbappends should be removed as dependency layers update or "real" fixes are generated. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2014-05-13spice: allow separated src and build dirsMark Asselstine2-1/+64
Some minor fixes around generated .c and .h files were required to allow separated src and build dirs. Without these builds will fail and you would have to build in the src dir. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2014-03-26spice: updates to work with latest autotoolsMark Asselstine2-4/+37
We were getting several errors during configure related to autoreconf. We need to create an empty m4 directory as well as enable the subdir-objects option to allow configure to complete successfully. There were indications that this second issue was fixed upstream but even using the latest git trees I am seeing this failure. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2014-03-25cloud-services: add celt051Bruce Ashfield1-0/+30
spice requires celt051. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
2014-03-25meta-cloud-services: introduce spiceBruce Ashfield2-0/+163
A common requirement for many cloud systems is remote console access. Adding spice to the common layer allows a rich console environment to be provided. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>