aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.db_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-troveclient_git.bb5
4 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
index 7b7cb91d..557a557f 100644
--- a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-keystoneauth1 \
python-oslo.config \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
index 53df1068..d693570c 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${PN} += " \
python-six \
python-alembic \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
index fd323261..2db5aae8 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
python-pbr \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
# RDEPENDS_default:
RDEPENDS_${PN} += " \
python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-troveclient_git.bb b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
index 251d9e0e..95ec5aee 100644
--- a/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
@@ -72,6 +72,11 @@ RDEPENDS_${SRCNAME} += " \
${SRCNAME}-bin \
"
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
RDEPENDS_${SRCNAME}-bin += " \
${PN} \
"