aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend11
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc11
-rw-r--r--meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend14
-rw-r--r--meta-openstack/recipes-core/base-files/base-files_openstack.inc13
-rw-r--r--meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend11
-rw-r--r--meta-openstack/recipes-core/initscripts/initscripts_openstack.inc10
-rw-r--r--meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend4
-rw-r--r--meta-openstack/recipes-extended/iptables/iptables_openstack.inc3
-rw-r--r--meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend22
-rw-r--r--meta-openstack/recipes-extended/libpam/libpam_openstack.inc21
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend14
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc13
-rw-r--r--meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend4
-rw-r--r--meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc3
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend7
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc6
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend10
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend10
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc9
-rw-r--r--meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend1
-rw-r--r--meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend5
-rw-r--r--meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc4
-rw-r--r--meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend8
-rw-r--r--meta-openstack/recipes-support/ebtables/ebtables_openstack.inc7
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend5
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_openstack.inc4
-rw-r--r--meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend74
-rw-r--r--meta-openstack/recipes-support/openldap/openldap_openstack.inc73
-rw-r--r--meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend1
29 files changed, 191 insertions, 187 deletions
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend b/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
index 5c0d724f..7233019a 100644
--- a/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
@@ -1,11 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
-SRC_URI += "file://mcs-sshd"
-SRC_URI += "file://mcs-sshd_config"
-
-do_install_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
- install -D -m 644 ${WORKDIR}/mcs-sshd ${D}/etc/pam.d/sshd
- install -D -m 644 ${WORKDIR}/mcs-sshd_config ${D}/etc/ssh/sshd_config
- fi
-}
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc b/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc
new file mode 100644
index 00000000..5c0d724f
--- /dev/null
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://mcs-sshd"
+SRC_URI += "file://mcs-sshd_config"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
+ install -D -m 644 ${WORKDIR}/mcs-sshd ${D}/etc/pam.d/sshd
+ install -D -m 644 ${WORKDIR}/mcs-sshd_config ${D}/etc/ssh/sshd_config
+ fi
+}
diff --git a/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend b/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
index 0a1b1604..025ee4ee 100644
--- a/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -1,13 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://nsswitch.conf"
-
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
-PACKAGECONFIG[OpenLDAP] = ",,,nss-pam-ldapd"
-
-do_install_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
- install -m 755 -d ${D}/etc/
- install -m 644 ${WORKDIR}/nsswitch.conf ${D}/etc/
- fi
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-core/base-files/base-files_openstack.inc b/meta-openstack/recipes-core/base-files/base-files_openstack.inc
new file mode 100644
index 00000000..0a1b1604
--- /dev/null
+++ b/meta-openstack/recipes-core/base-files/base-files_openstack.inc
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://nsswitch.conf"
+
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
+PACKAGECONFIG[OpenLDAP] = ",,,nss-pam-ldapd"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
+ install -m 755 -d ${D}/etc/
+ install -m 644 ${WORKDIR}/nsswitch.conf ${D}/etc/
+ fi
+}
diff --git a/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
index 21749974..025ee4ee 100644
--- a/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
+++ b/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
@@ -1,10 +1 @@
-do_install_append() {
-
- echo >> ${D}${sysconfdir}/init.d/functions
- echo init_is_upstart \(\) \{ >> ${D}${sysconfdir}/init.d/functions
- echo \ \ \ \ false >> ${D}${sysconfdir}/init.d/functions
- echo \} >> ${D}${sysconfdir}/init.d/functions
- echo log_daemon_msg \(\) \{ >> ${D}${sysconfdir}/init.d/functions
- echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
- echo \} >> ${D}${sysconfdir}/init.d/functions
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc b/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc
new file mode 100644
index 00000000..21749974
--- /dev/null
+++ b/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc
@@ -0,0 +1,10 @@
+do_install_append() {
+
+ echo >> ${D}${sysconfdir}/init.d/functions
+ echo init_is_upstart \(\) \{ >> ${D}${sysconfdir}/init.d/functions
+ echo \ \ \ \ false >> ${D}${sysconfdir}/init.d/functions
+ echo \} >> ${D}${sysconfdir}/init.d/functions
+ echo log_daemon_msg \(\) \{ >> ${D}${sysconfdir}/init.d/functions
+ echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
+ echo \} >> ${D}${sysconfdir}/init.d/functions
+}
diff --git a/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend b/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
index 2a53557a..025ee4ee 100644
--- a/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
+++ b/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
@@ -1,3 +1 @@
-RRECOMMENDS_${PN} += "kernel-module-xt-conntrack \
- kernel-module-xt-redirect \
- "
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-extended/iptables/iptables_openstack.inc b/meta-openstack/recipes-extended/iptables/iptables_openstack.inc
new file mode 100644
index 00000000..2a53557a
--- /dev/null
+++ b/meta-openstack/recipes-extended/iptables/iptables_openstack.inc
@@ -0,0 +1,3 @@
+RRECOMMENDS_${PN} += "kernel-module-xt-conntrack \
+ kernel-module-xt-redirect \
+ "
diff --git a/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend b/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
index ec858a7f..025ee4ee 100644
--- a/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
+++ b/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
@@ -1,21 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://common-account"
-SRC_URI += "file://common-auth"
-SRC_URI += "file://common-password"
-SRC_URI += "file://common-session"
-SRC_URI += "file://common-session-noninteractive"
-
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
-PACKAGECONFIG[OpenLDAP] = ",,,pam-plugin-mkhomedir nss-pam-ldapd"
-
-do_install_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
- install -m 755 -d ${D}/etc/pam.d/
- install -m 644 ${WORKDIR}/common-account ${D}/etc/pam.d/
- install -m 644 ${WORKDIR}/common-auth ${D}/etc/pam.d/
- install -m 644 ${WORKDIR}/common-password ${D}/etc/pam.d/
- install -m 644 ${WORKDIR}/common-session ${D}/etc/pam.d/
- install -m 644 ${WORKDIR}/common-session-noninteractive ${D}/etc/pam.d/
- fi
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-extended/libpam/libpam_openstack.inc b/meta-openstack/recipes-extended/libpam/libpam_openstack.inc
new file mode 100644
index 00000000..ec858a7f
--- /dev/null
+++ b/meta-openstack/recipes-extended/libpam/libpam_openstack.inc
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://common-account"
+SRC_URI += "file://common-auth"
+SRC_URI += "file://common-password"
+SRC_URI += "file://common-session"
+SRC_URI += "file://common-session-noninteractive"
+
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
+PACKAGECONFIG[OpenLDAP] = ",,,pam-plugin-mkhomedir nss-pam-ldapd"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
+ install -m 755 -d ${D}/etc/pam.d/
+ install -m 644 ${WORKDIR}/common-account ${D}/etc/pam.d/
+ install -m 644 ${WORKDIR}/common-auth ${D}/etc/pam.d/
+ install -m 644 ${WORKDIR}/common-password ${D}/etc/pam.d/
+ install -m 644 ${WORKDIR}/common-session ${D}/etc/pam.d/
+ install -m 644 ${WORKDIR}/common-session-noninteractive ${D}/etc/pam.d/
+ fi
+}
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend b/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
index 0b0f0114..025ee4ee 100644
--- a/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
@@ -1,13 +1 @@
-PACKAGECONFIG ?= "qemu lxc test remote macvtap libvirtd udev yajl \
- python ebtables \
- ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
- "
-
-inherit useradd
-USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN}_append = " ;--system libvirt"
-
-do_install_append() {
- sed -e "s:^#unix_sock_group =:unix_sock_group =:g" -i ${D}/etc/libvirt/libvirtd.conf
- sed -e "s:^#unix_sock_rw_perms =:unix_sock_rw_perms =:g" -i ${D}/etc/libvirt/libvirtd.conf
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc b/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc
new file mode 100644
index 00000000..0b0f0114
--- /dev/null
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc
@@ -0,0 +1,13 @@
+PACKAGECONFIG ?= "qemu lxc test remote macvtap libvirtd udev yajl \
+ python ebtables \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
+ "
+
+inherit useradd
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN}_append = " ;--system libvirt"
+
+do_install_append() {
+ sed -e "s:^#unix_sock_group =:unix_sock_group =:g" -i ${D}/etc/libvirt/libvirtd.conf
+ sed -e "s:^#unix_sock_rw_perms =:unix_sock_rw_perms =:g" -i ${D}/etc/libvirt/libvirtd.conf
+}
diff --git a/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend b/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
index 33b1f61c..025ee4ee 100644
--- a/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
+++ b/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
@@ -1,3 +1 @@
-do_install_append() {
- sed -i '2i port=`grep "^server.port" /etc/lighttpd.conf`; if [ -z $port ]; then echo "server port not configured, not running lighttpd..."; exit 0; fi' ${D}/etc/init.d/lighttpd
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc b/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc
new file mode 100644
index 00000000..33b1f61c
--- /dev/null
+++ b/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc
@@ -0,0 +1,3 @@
+do_install_append() {
+ sed -i '2i port=`grep "^server.port" /etc/lighttpd.conf`; if [ -z $port ]; then echo "server port not configured, not running lighttpd..."; exit 0; fi' ${D}/etc/init.d/lighttpd
+}
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend b/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
index 8da640f5..025ee4ee 100644
--- a/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
@@ -1,6 +1 @@
-#
-# Copyright (C) 2014 Wind River Systems, Inc.
-#
-
-require recipes-extended/syslog/syslog-user.inc
-
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc b/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc
new file mode 100644
index 00000000..8da640f5
--- /dev/null
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc
@@ -0,0 +1,6 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+#
+
+require recipes-extended/syslog/syslog-user.inc
+
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
index 843546c8..025ee4ee 100644
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
@@ -1,9 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://enable-veth.cfg \
- file://enable-iscsi-tcp.cfg \
- file://enable-nbd.cfg \
- file://enable-rtlink.cfg \
- file://nf.scc \
- file://nfs.scc \
- "
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
index 843546c8..025ee4ee 100644
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
@@ -1,9 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://enable-veth.cfg \
- file://enable-iscsi-tcp.cfg \
- file://enable-nbd.cfg \
- file://enable-rtlink.cfg \
- file://nf.scc \
- file://nfs.scc \
- "
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc b/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc
new file mode 100644
index 00000000..843546c8
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://enable-veth.cfg \
+ file://enable-iscsi-tcp.cfg \
+ file://enable-nbd.cfg \
+ file://enable-rtlink.cfg \
+ file://nf.scc \
+ file://nfs.scc \
+ "
diff --git a/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend b/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend
deleted file mode 100644
index 7447c56e..00000000
--- a/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-inherit autotools-brokensep
diff --git a/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend b/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
index 0c979fea..025ee4ee 100644
--- a/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
+++ b/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
@@ -1,4 +1 @@
-do_install_append() {
- # Remove /var/run as it is created on startup
- rm -rf ${D}${localstatedir}/run
-}
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc b/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc
new file mode 100644
index 00000000..0c979fea
--- /dev/null
+++ b/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc
@@ -0,0 +1,4 @@
+do_install_append() {
+ # Remove /var/run as it is created on startup
+ rm -rf ${D}${localstatedir}/run
+}
diff --git a/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend b/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
index 9f6f2e63..025ee4ee 100644
--- a/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
+++ b/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
@@ -1,7 +1 @@
-RRECOMMENDS_${PN} += " \
- kernel-module-ebtables \
- kernel-module-ebtable-nat \
- kernel-module-ebt-arp \
- kernel-module-ebt-ip \
- "
-
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc b/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc
new file mode 100644
index 00000000..9f6f2e63
--- /dev/null
+++ b/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc
@@ -0,0 +1,7 @@
+RRECOMMENDS_${PN} += " \
+ kernel-module-ebtables \
+ kernel-module-ebtable-nat \
+ kernel-module-ebt-arp \
+ kernel-module-ebt-ip \
+ "
+
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend b/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
index 2fde00dc..025ee4ee 100644
--- a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
+++ b/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
@@ -1,4 +1 @@
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
-
-RRECOMMENDS_${PN} += "kernel-module-veth \
- "
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc b/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc
new file mode 100644
index 00000000..2fde00dc
--- /dev/null
+++ b/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
+
+RRECOMMENDS_${PN} += "kernel-module-veth \
+ "
diff --git a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
index 63f6064f..025ee4ee 100644
--- a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
+++ b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
@@ -1,73 +1 @@
-DEPEND_${PN} += "cyrus-sasl"
-RDEPEND_${PN} += "libsasl2-modules"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://initscript"
-SRC_URI += "file://ops-base.ldif"
-
-LDAP_DN ?= "dc=my-domain,dc=com"
-LDAP_DATADIR ?= "/etc/openldap-data/"
-
-OPENLDAP_LIBEXECDIR = "${libexecdir}"
-
-EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}"
-
-do_install_append() {
- install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap
- sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap
- sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap
- # Base openldat bb installs slapd under ${sbin}
- sed -i -e 's#%LIBEXEC%#${sbindir}#g' ${D}${sysconfdir}/init.d/openldap
-
- # This is duplicated in /etc/openldap and is for slapd
- rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
- rm -rf "${D}${localstatedir}/run"
- rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
-
- # remove symlinks for backends, recreating in postinstall
- rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so
-
- sed -i -e '/^include\s*/a \
-include /etc/openldap/schema/cosine.schema \
-include /etc/openldap/schema/nis.schema \
-include /etc/openldap/schema/inetorgperson.schema \
-include /etc/openldap/schema/misc.schema' \
- ${D}/etc/openldap/slapd.conf
-
- sed -i -e '/^# Load dynamic backend modules:/a \
-modulepath ${OPENLDAP_LIBEXECDIR}/openldap \
-moduleload back_bdb.la' \
- ${D}/etc/openldap/slapd.conf
-
- sed -i -e 's#^pidfile\s*.*$#pidfile ${LDAP_DATADIR}/slapd.pid#' ${D}/etc/openldap/slapd.conf
- sed -i -e 's#^argsfile\s*.*$#argsfile ${LDAP_DATADIR}/slapd.args#' ${D}/etc/openldap/slapd.conf
- sed -i -e 's#^directory\s*.*$#directory ${LDAP_DATADIR}/#' ${D}/etc/openldap/slapd.conf
-
- sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/slapd.conf
-
- # modify access perms for ldap/authentication
- sed -i -e '$a\
-\
-access to attrs=userPassword \
- by self write \
- by anonymous auth \
- by * none \
-\
-access to * \
- by self write \
- by * read' \
- ${D}/etc/openldap/slapd.conf
-
- install -D -m 0644 ${WORKDIR}/ops-base.ldif ${D}/etc/openldap/ops-base.ldif
- sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/ops-base.ldif
-
- mkdir ${D}/${LDAP_DATADIR}
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "openldap"
-INITSCRIPT_PARAMS = "defaults"
-
-FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/* ${sysconfdir}/openldap/ops-base.ldif"
-FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug"
+require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
diff --git a/meta-openstack/recipes-support/openldap/openldap_openstack.inc b/meta-openstack/recipes-support/openldap/openldap_openstack.inc
new file mode 100644
index 00000000..63f6064f
--- /dev/null
+++ b/meta-openstack/recipes-support/openldap/openldap_openstack.inc
@@ -0,0 +1,73 @@
+DEPEND_${PN} += "cyrus-sasl"
+RDEPEND_${PN} += "libsasl2-modules"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI += "file://initscript"
+SRC_URI += "file://ops-base.ldif"
+
+LDAP_DN ?= "dc=my-domain,dc=com"
+LDAP_DATADIR ?= "/etc/openldap-data/"
+
+OPENLDAP_LIBEXECDIR = "${libexecdir}"
+
+EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}"
+
+do_install_append() {
+ install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap
+ sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap
+ sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap
+ # Base openldat bb installs slapd under ${sbin}
+ sed -i -e 's#%LIBEXEC%#${sbindir}#g' ${D}${sysconfdir}/init.d/openldap
+
+ # This is duplicated in /etc/openldap and is for slapd
+ rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
+ rm -rf "${D}${localstatedir}/run"
+ rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
+
+ # remove symlinks for backends, recreating in postinstall
+ rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so
+
+ sed -i -e '/^include\s*/a \
+include /etc/openldap/schema/cosine.schema \
+include /etc/openldap/schema/nis.schema \
+include /etc/openldap/schema/inetorgperson.schema \
+include /etc/openldap/schema/misc.schema' \
+ ${D}/etc/openldap/slapd.conf
+
+ sed -i -e '/^# Load dynamic backend modules:/a \
+modulepath ${OPENLDAP_LIBEXECDIR}/openldap \
+moduleload back_bdb.la' \
+ ${D}/etc/openldap/slapd.conf
+
+ sed -i -e 's#^pidfile\s*.*$#pidfile ${LDAP_DATADIR}/slapd.pid#' ${D}/etc/openldap/slapd.conf
+ sed -i -e 's#^argsfile\s*.*$#argsfile ${LDAP_DATADIR}/slapd.args#' ${D}/etc/openldap/slapd.conf
+ sed -i -e 's#^directory\s*.*$#directory ${LDAP_DATADIR}/#' ${D}/etc/openldap/slapd.conf
+
+ sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/slapd.conf
+
+ # modify access perms for ldap/authentication
+ sed -i -e '$a\
+\
+access to attrs=userPassword \
+ by self write \
+ by anonymous auth \
+ by * none \
+\
+access to * \
+ by self write \
+ by * read' \
+ ${D}/etc/openldap/slapd.conf
+
+ install -D -m 0644 ${WORKDIR}/ops-base.ldif ${D}/etc/openldap/ops-base.ldif
+ sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/ops-base.ldif
+
+ mkdir ${D}/${LDAP_DATADIR}
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "openldap"
+INITSCRIPT_PARAMS = "defaults"
+
+FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/* ${sysconfdir}/openldap/ops-base.ldif"
+FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug"
diff --git a/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend b/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend
deleted file mode 100644
index 7447c56e..00000000
--- a/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-inherit autotools-brokensep