aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/Documentation/README.ceph-openstack4
-rw-r--r--meta-openstack/Documentation/README.heat2
-rw-r--r--meta-openstack/Documentation/README.swift6
-rw-r--r--meta-openstack/README.setup2
-rw-r--r--meta-openstack/recipes-extended/guest-images/cirros_0.3.2.bb (renamed from meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb)7
5 files changed, 11 insertions, 10 deletions
diff --git a/meta-openstack/Documentation/README.ceph-openstack b/meta-openstack/Documentation/README.ceph-openstack
index d7e8c082..11348375 100644
--- a/meta-openstack/Documentation/README.ceph-openstack
+++ b/meta-openstack/Documentation/README.ceph-openstack
@@ -256,7 +256,7 @@ root 3808 0.0 0.0 3289468 34428 ? Ssl 02:50 0:36 /usr/bin/ceph-o
| 15157fda-0940-4eba-853d-52338ace3362 | mynetwork | |
+--------------------------------------+-----------+---------+
- $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-0.3.0-x86_64-disk.img
+ $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-*-x86_64-disk.img
$ nova boot --image myfirstimage --flavor 1 myinstance
$ nova list
@@ -293,7 +293,7 @@ root 3808 0.0 0.0 3289468 34428 ? Ssl 02:50 0:36 /usr/bin/ceph-o
| d38811d4-741a-4a68-afe3-fb5892160d7c | nfs | {u'volume_backend_name': u'Generic_NFS'} |
+--------------------------------------+-----------+------------------------------------------+
- $ glance image-create --name mysecondimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-0.3.0-x86_64-disk.img
+ $ glance image-create --name mysecondimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-*-x86_64-disk.img
$ glance image-list
+--------------------------------------+---------------+-------------+------------------+---------+--------+
diff --git a/meta-openstack/Documentation/README.heat b/meta-openstack/Documentation/README.heat
index 95d2e08b..35782915 100644
--- a/meta-openstack/Documentation/README.heat
+++ b/meta-openstack/Documentation/README.heat
@@ -28,7 +28,7 @@ node, unless otherwise explicitly indicated.
$ Start Controller and Compute node
$ . /etc/nova/openrc
- $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-0.3.0-x86_64-disk.img
+ $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-*-x86_64-disk.img
$ glance image-list
+--------------------------------------+--------------+-------------+------------------+---------+--------+
| ID | Name | Disk Format | Container Format | Size | Status |
diff --git a/meta-openstack/Documentation/README.swift b/meta-openstack/Documentation/README.swift
index 88ca0958..0945ed30 100644
--- a/meta-openstack/Documentation/README.swift
+++ b/meta-openstack/Documentation/README.swift
@@ -260,7 +260,7 @@ b1a1b6b34a6852cdd51cd487a01192cc 100M_c2.org
(The md5sums of each pair "zzz.save" and "zzz.org" files must be the same)
$ neutron net-create mynetwork
- $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-0.3.0-x86_64-disk.img
+ $ glance image-create --name myfirstimage --is-public true --container-format bare --disk-format qcow2 --file /root/images/cirros-*-x86_64-disk.img
$ glance image-list
+--------------------------------------+--------------+-------------+------------------+---------+--------+
@@ -277,10 +277,10 @@ b1a1b6b34a6852cdd51cd487a01192cc 100M_c2.org
(The object name in the "glance" container must be the same as glance image id just created)
$ swift download glance 79f52103-5b22-4aa5-8159-2d146b82b0b2
- $ md5sum 79f52103-5b22-4aa5-8159-2d146b82b0b2 /root/images/cirros-0.3.0-x86_64-disk.img
+ $ md5sum 79f52103-5b22-4aa5-8159-2d146b82b0b2 /root/images/cirros-*-x86_64-disk.img
50bdc35edb03a38d91b1b071afb20a3c 79f52103-5b22-4aa5-8159-2d146b82b0b2
-50bdc35edb03a38d91b1b071afb20a3c /root/images/cirros-0.3.0-x86_64-disk.img
+50bdc35edb03a38d91b1b071afb20a3c /root/images/cirros-*-x86_64-disk.img
(The md5sum of these 2 files must be the same)
diff --git a/meta-openstack/README.setup b/meta-openstack/README.setup
index 3949fe72..ebd73b4a 100644
--- a/meta-openstack/README.setup
+++ b/meta-openstack/README.setup
@@ -157,7 +157,7 @@ following steps will validate a simple compute node guest launch:
% . /etc/nova/openrc
% glance image-create --name myFirstImage --is-public true \
- --container-format bare --disk-format qcow2 --file /root/images/cirros-0.3.0-x86_64-disk.img
+ --container-format bare --disk-format qcow2 --file /root/images/cirros-*-x86_64-disk.img
% neutron net-create mynetwork
% nova boot --image myFirstImage --flavor 1 myinstance
diff --git a/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb b/meta-openstack/recipes-extended/guest-images/cirros_0.3.2.bb
index 459628a6..9ebd2b7e 100644
--- a/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb
+++ b/meta-openstack/recipes-extended/guest-images/cirros_0.3.2.bb
@@ -4,9 +4,10 @@ HOMEPAGE = "https://launchpad.net/cirros"
LICENSE="GPLv2"
-SRC_URI = "https://launchpad.net/cirros/trunk/${PV}/+download/${PN}-${PV}-x86_64-disk.img"
-SRC_URI[md5sum] = "50bdc35edb03a38d91b1b071afb20a3c"
-SRC_URI[sha256sum] = "648782e9287288630250d07531fed9944ecc3986764a6664f0bf6c050ec06afd"
+SRC_URI = "http://download.cirros-cloud.net/${PV}/${PN}-${PV}-x86_64-disk.img"
+
+SRC_URI[md5sum] = "64d7c1cd2b6f60c92c14662941cb7913"
+SRC_URI[sha256sum] = "a2ca56aeded5a5bcaa6104fb14ec07b1ceb65222e2890bef8a89b8d2da729ad5"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"