aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index af740ff..ac21829 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,20 +8,7 @@ LDADD = $(DEPS_LIBS)
gaku_SOURCES = \
main.c \
- audio-player.c audio-player.h \
- playlist-parser.c playlist-parser.h \
- tag-reader.c tag-reader.h \
- marshal.c marshal.h
-
-%.h: %.list
- $(GLIB_GENMARSHAL) --prefix=$* $< --header > $@
-
-%.c: %.list
- $(GLIB_GENMARSHAL) --prefix=$* $< --body > $@
-
-EXTRA_DIST = marshal.list
-BUILT_SOURCES = marshal.c marshal.h
-CLEANFILES = $(BUILT_SOURCES)
+ playlist-parser.c playlist-parser.h
desktopdir = $(datadir)/applications
dist_desktop_DATA = gaku.desktop