aboutsummaryrefslogtreecommitdiffstats
path: root/lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py
diff options
context:
space:
mode:
Diffstat (limited to 'lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py')
-rw-r--r--lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py174
1 files changed, 0 insertions, 174 deletions
diff --git a/lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py b/lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py
deleted file mode 100644
index 8c7e3491..00000000
--- a/lib/python2.7/site-packages/buildbot-0.8.8-py2.7.egg/buildbot/steps/package/rpm/mock.py
+++ /dev/null
@@ -1,174 +0,0 @@
-# This file is part of Buildbot. Buildbot is free software: you can
-# redistribute it and/or modify it under the terms of the GNU General Public
-# License as published by the Free Software Foundation, version 2.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
-# details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 51
-# Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-# Portions Copyright Buildbot Team Members
-# Portions Copyright Marius Rieder <marius.rieder@durchmesser.ch>
-"""
-Steps and objects related to mock building.
-"""
-
-import re
-
-from buildbot.steps.shell import ShellCommand
-from buildbot.process import buildstep
-from buildbot import config
-
-class MockStateObserver(buildstep.LogLineObserver):
- _line_re = re.compile(r'^.*State Changed: (.*)$')
-
- def outLineReceived(self, line):
- m = self._line_re.search(line.strip())
- if m:
- state = m.group(1)
- if not state == 'end':
- self.step.descriptionSuffix = ["[%s]"%m.group(1)]
- else:
- self.step.descriptionSuffix = None
- self.step.step_status.setText(self.step.describe(False))
-
-class Mock(ShellCommand):
- """Add the mock logfiles and clean them if they already exist. Add support
- for the root and resultdir parameter of mock."""
-
- name = "mock"
-
- haltOnFailure = 1
- flunkOnFailure = 1
-
- mock_logfiles = ['build.log', 'root.log', 'state.log']
-
- root = None
- resultdir = None
-
- def __init__(self,
- root=None,
- resultdir=None,
- **kwargs):
- """
- Creates the Mock object.
-
- @type root: str
- @param root: the name of the mock buildroot
- @type resultdir: str
- @param resultdir: the path of the result dir
- @type kwargs: dict
- @param kwargs: All further keyword arguments.
- """
- ShellCommand.__init__(self, **kwargs)
- if root:
- self.root = root
- if resultdir:
- self.resultdir = resultdir
-
- if not self.root:
- config.error("You must specify a mock root")
-
-
- self.command = ['mock', '--root', self.root]
- if self.resultdir:
- self.command += ['--resultdir', self.resultdir]
-
- def start(self):
- """
- Try to remove the old mock logs first.
- """
- if self.resultdir:
- for lname in self.mock_logfiles:
- self.logfiles[lname] = self.build.path_module.join(self.resultdir,
- lname)
- else:
- for lname in self.mock_logfiles:
- self.logfiles[lname] = lname
- self.addLogObserver('state.log', MockStateObserver())
-
- cmd = buildstep.RemoteCommand('rmdir', {'dir':
- map(lambda l: self.build.path_module.join('build', self.logfiles[l]),
- self.mock_logfiles)})
- d = self.runCommand(cmd)
- def removeDone(cmd):
- ShellCommand.start(self)
- d.addCallback(removeDone)
- d.addErrback(self.failed)
-
-class MockBuildSRPM(Mock):
- """Build a srpm within a mock. Requires a spec file and a sources dir."""
-
- name = "mockbuildsrpm"
-
- description = ["mock buildsrpm"]
- descriptionDone = ["mock buildsrpm"]
-
- spec = None
- sources = '.'
-
- def __init__(self,
- spec=None,
- sources=None,
- **kwargs):
- """
- Creates the MockBuildSRPM object.
-
- @type spec: str
- @param spec: the path of the specfiles.
- @type sources: str
- @param sources: the path of the sources dir.
- @type kwargs: dict
- @param kwargs: All further keyword arguments.
- """
- Mock.__init__(self, **kwargs)
- if spec:
- self.spec = spec
- if sources:
- self.sources = sources
-
- if not self.spec:
- config.error("You must specify a spec file")
- if not self.sources:
- config.error("You must specify a sources dir")
-
- self.command += ['--buildsrpm', '--spec', self.spec,
- '--sources', self.sources]
-
- def commandComplete(self, cmd):
- out = cmd.logs['build.log'].getText()
- m = re.search(r"Wrote: .*/([^/]*.src.rpm)", out)
- if m:
- self.setProperty("srpm", m.group(1), 'MockBuildSRPM')
-
-class MockRebuild(Mock):
- """Rebuild a srpm within a mock. Requires a srpm file."""
-
- name = "mock"
-
- description = ["mock rebuilding srpm"]
- descriptionDone = ["mock rebuild srpm"]
-
- srpm = None
-
- def __init__(self, srpm=None, **kwargs):
- """
- Creates the MockRebuildRPM object.
-
- @type srpm: str
- @param srpm: the path of the srpm file.
- @type kwargs: dict
- @param kwargs: All further keyword arguments.
- """
- Mock.__init__(self, **kwargs)
- if srpm:
- self.srpm = srpm
-
- if not self.srpm:
- config.error("You must specify a srpm")
-
- self.command += ['--rebuild', self.srpm]