summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
index 431dbb0926..b17cba4a78 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
@@ -5,11 +5,15 @@
SUMMARY = "Full-featured set of base utils"
DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
inherit packagegroup
VIRTUAL-RUNTIME_vim ?= "vim-tiny"
-RDEPENDS_${PN} = "\
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RDEPENDS:${PN} = "\
base-passwd \
bash \
bind-utils \
@@ -17,8 +21,8 @@ RDEPENDS_${PN} = "\
coreutils \
cpio \
${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "debianutils-run-parts", d)} \
- dhcp-client \
- ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dhcp-server", d)} \
+ dhcpcd \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "kea", d)} \
diffutils \
${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dpkg-start-stop", d)} \
e2fsprogs \
@@ -38,7 +42,6 @@ RDEPENDS_${PN} = "\
${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} \
kmod \
less \
- lzip \
ncurses-tools \
net-tools \
parted \