summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index db353d607b..e3d63df852 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -1,7 +1,6 @@
SUMMARY = "Runs postinstall scripts on first boot of the target device"
DESCRIPTION = "${SUMMARY}"
SECTION = "devel"
-PR = "r10"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -13,6 +12,8 @@ S = "${WORKDIR}"
inherit allarch systemd update-rc.d
+RDEPENDS:${PN} = "util-linux-fcntl-lock"
+
INITSCRIPT_NAME = "run-postinsts"
INITSCRIPT_PARAMS = "start 99 S ."
@@ -28,13 +29,13 @@ do_compile () {
do_install() {
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/run-postinsts ${D}${sbindir}/
+ install -m 0755 ${S}/run-postinsts ${D}${sbindir}/
install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts
+ install -m 0755 ${S}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts
install -d ${D}${systemd_system_unitdir}/
- install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${S}/run-postinsts.service ${D}${systemd_system_unitdir}/
sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
-e 's:#SBINDIR#:${sbindir}:g' \