summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cython_0.29.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_0.29.20.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cython_0.29.20.bb18
1 files changed, 0 insertions, 18 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.20.bb b/meta/recipes-devtools/python/python3-cython_0.29.20.bb
deleted file mode 100644
index 2ce6bdbd68..0000000000
--- a/meta/recipes-devtools/python/python3-cython_0.29.20.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-inherit setuptools3
-require python-cython.inc
-
-RDEPENDS_${PN} += "\
- python3-setuptools \
-"
-
-# running build_ext a second time during install fails, because Python
-# would then attempt to import cythonized modules built for the target
-# architecture.
-DISTUTILS_INSTALL_ARGS += "--skip-build"
-
-do_install_append() {
- # rename scripts that would conflict with the Python 2 build of Cython
- mv ${D}${bindir}/cython ${D}${bindir}/cython3
- mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
- mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
-}