summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb')
-rw-r--r--meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb b/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
index 053945ebbc..56a9321fb9 100644
--- a/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
+++ b/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
@@ -2,15 +2,15 @@ SUMMARY = "icecc environment setup script"
DESCRIPTION = "This is a version of the icecc-create-env script that has \
been modified in order to make it work with OE."
SECTION = "base"
-# source file has just a "GPL" word, but upstream is GPLv2+.
+# source file has just a "GPL" word, but upstream is GPL-2.0-or-later.
# most probably just GPL would be a mistake
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://icecc-create-env;beginline=2;endline=5;md5=ae1df3d6a058bfda40b66094c5f6065f"
-PR = "r2"
DEPENDS = ""
INHIBIT_DEFAULT_DEPS = "1"
+ICECC_DISABLED = "1"
# This is needed, because otherwise there is dependency loop from quilt-native
# Dependency loop #1 found:
@@ -30,7 +30,9 @@ S = "${WORKDIR}"
do_install() {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/icecc-create-env ${D}/${bindir}
+ install -m 0755 ${S}/icecc-create-env ${D}/${bindir}
}
BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS:${PN}:class-nativesdk = "patchelf"