summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-systemctl-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-systemctl-native.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-systemctl-native.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd-systemctl-native.bb b/meta/recipes-core/systemd/systemd-systemctl-native.bb
index fadc8433d8..ffa024caef 100644
--- a/meta/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,15 +3,15 @@ SUMMARY = "Wrapper for enabling systemd services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r6"
inherit native
SRC_URI = "file://systemctl"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/systemctl ${D}${bindir}
+ install -m 0755 ${S}/systemctl ${D}${bindir}
}