summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb')
-rw-r--r--meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
new file mode 100644
index 0000000000..db674d0efc
--- /dev/null
+++ b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Test recipe for testing rpm generated by oe-core"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+LICENSE = "MIT"
+
+SRC_URI = "file://testfile.txt"
+INHIBIT_DEFAULT_DEPS = "1"
+
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
+do_compile(){
+ echo "testdata" > ${B}/"file with [brackets].txt"
+ echo "testdata" > ${B}/"file with (parentheses).txt"
+}
+
+do_install(){
+ install ${B}/* ${D}/
+}
+
+FILES:${PN} = "*"