aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend b/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
new file mode 100644
index 00000000..fcc041fd
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
@@ -0,0 +1,16 @@
+COMPATIBLE_HOST:xilinx-standalone = "${HOST_SYS}"
+COMPATIBLE_HOST:xilinx-freertos = "${HOST_SYS}"
+
+COMPATIBLE_MACHINE:cortexa53-zynqmp = ".*"
+COMPATIBLE_MACHINE:cortexr5-zynqmp = ".*"
+COMPATIBLE_MACHINE:microblaze-pmu = ".*"
+COMPATIBLE_MACHINE:microblaze-plm = ".*"
+COMPATIBLE_MACHINE:cortexa72-versal = ".*"
+COMPATIBLE_MACHINE:cortexr5-versal = ".*"
+COMPATIBLE_MACHINE:cortexa9-zynq = ".*"
+
+# Enable @ flag on dtc which is required by libxil
+DTC_FLAGS:append:xilinx-standalone = " -@"
+DT_INCLUDE:append:xilinx-standalone = " ${WORKDIR}/git/device_tree/data/kernel_dtsi/${XILINX_RELEASE_VERSION}/include/"
+DTC_FLAGS:append:xilinx-freertos = " -@"
+DT_INCLUDE:append:xilinx-freertos = " ${WORKDIR}/git/device_tree/data/kernel_dtsi/${XILINX_RELEASE_VERSION}/include/"