aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental/conf/layer.conf')
-rw-r--r--meta-xilinx-standalone-experimental/conf/layer.conf28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/conf/layer.conf b/meta-xilinx-standalone-experimental/conf/layer.conf
new file mode 100644
index 00000000..6cfd01c3
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/conf/layer.conf
@@ -0,0 +1,28 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend \
+ ${LAYERDIR}/recipes-*/*.bb \
+ ${LAYERDIR}/recipes-*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "xilinx-standalone-exp"
+BBFILE_PATTERN_xilinx-standalone-exp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_xilinx-standalone-exp = "7"
+
+# Allow other layers to find the root of this layer if necessary
+META_XILINX_STANDALONE_EXP_PATH = "${LAYERDIR}"
+
+LAYERDEPENDS_xilinx-standalone-exp = "core \
+ xilinx \
+ xilinx-standalone \
+ xilinx-microblaze \
+ virtualization-layer \
+ "
+
+LAYERSERIES_COMPAT_xilinx-standalone-exp = "scarthgap"
+
+# Aid debugging, show where the device trees are we are using
+BUILDCFG_VARS:append = " SYSTEM_DTFILE CONFIG_DTFILE"