aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-xrt/xrt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-xrt/xrt')
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_202320.2.16.0.bb29
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc6
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc7
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0.inc7
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch117
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0.inc13
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0/xrt-cstdint.patch117
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb51
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb51
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb56
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202320.2.16.0.bb57
11 files changed, 511 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_202320.2.16.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_202320.2.16.0.bb
new file mode 100644
index 00000000..6cf10817
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_202320.2.16.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Xilinx Runtime(XRT) - minimal native build for xclbinutil"
+DESCRIPTION = "Native build of xclbinutil using XRT codebase"
+
+require xrt-202320.2.16.0.inc
+
+FILESEXTRAPATHS:append := ":${THISDIR}/xrt"
+
+LICENSE = "GPL-2.0-or-later & Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = " \
+ file://../LICENSE;md5=de2c993ac479f02575bcbfb14ef9b485 \
+ file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
+ file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/common/elf/LICENSE.txt;md5=b996e8b74af169e7e72e22d9e7d05b06 \
+"
+
+S = "${WORKDIR}/git/src"
+
+inherit cmake pkgconfig native
+
+DEPENDS = "libdrm-native ocl-icd-native boost-native rapidjson-native protobuf-native python3-pybind11-native systemtap-native"
+
+EXTRA_OECMAKE += " -DCMAKE_BUILD_TYPE=Release -DCMAKE_EXPORT_COMPILE_COMANDS=ON"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -Dm 0755 ${WORKDIR}/build/runtime_src/tools/xclbinutil/xclbinutil ${D}${bindir}
+}
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc
new file mode 100644
index 00000000..38fbd162
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc
@@ -0,0 +1,6 @@
+REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
+BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
+SRC_URI = "${REPO};${BRANCHARG}"
+
+BRANCH= "2022.1"
+SRCREV= "5e92a513c6950e79638b1a879ddb882da34fc683"
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc
new file mode 100644
index 00000000..e4bb423c
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc
@@ -0,0 +1,7 @@
+REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
+BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
+SRC_URI = "${REPO};${BRANCHARG}"
+
+BRANCH= "2022.2"
+SRCREV= "43926231f7183688add2dccfd391b36a1f000bea"
+
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0.inc
new file mode 100644
index 00000000..2f6a5c6a
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0.inc
@@ -0,0 +1,7 @@
+REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
+BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
+SRC_URI = "${REPO};${BRANCHARG}"
+
+BRANCH= "2023.1"
+SRCREV= "64c933573e7e50a8aba939a74209590c2b739e8b"
+
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch
new file mode 100644
index 00000000..67ca68c6
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch
@@ -0,0 +1,117 @@
+Add cstdint as necessary
+
+In GCC 13.1 usage of uint64 and similar will result in an error without
+ #include <cstdint>
+
+Signed-off-by: Mark Hatle <mark.hatle@amd.com>
+
+diff --git a/src/runtime_src/core/common/time.h b/src/runtime_src/core/common/time.h
+index a4a96b11d..585d38756 100644
+--- a/src/runtime_src/core/common/time.h
++++ b/src/runtime_src/core/common/time.h
+@@ -19,6 +19,7 @@
+
+ #include "core/common/config.h"
+ #include <string>
++#include <cstdint>
+
+ namespace xrt_core {
+
+diff --git a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
+index 196304765..36ce35e80
+--- a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
++++ b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
+@@ -18,6 +18,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ namespace adf
+ {
+diff --git a/src/runtime_src/core/edge/user/zynq_dev.h b/src/runtime_src/core/edge/user/zynq_dev.h
+index 6fe36c615..2abd7473b 100644
+--- a/src/runtime_src/core/edge/user/zynq_dev.h
++++ b/src/runtime_src/core/edge/user/zynq_dev.h
+@@ -19,6 +19,7 @@
+ #include <fstream>
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ class zynq_device {
+ public:
+diff --git a/src/runtime_src/tools/xclbinutil/CBOR.h b/src/runtime_src/tools/xclbinutil/CBOR.h
+index 368459f59..acbf6ebae 100644
+--- a/src/runtime_src/tools/xclbinutil/CBOR.h
++++ b/src/runtime_src/tools/xclbinutil/CBOR.h
+@@ -22,6 +22,7 @@
+ // #includes here - please keep these to a bare minimum!
+ #include <string>
+ #include <sstream>
++#include <cstdint>
+
+ // ------------ F O R W A R D - D E C L A R A T I O N S ----------------------
+ // Forward declarations - use these instead whenever possible...
+diff --git a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
+index 361015962..1c3bca18d 100644
+--- a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
++++ b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
+@@ -19,6 +19,7 @@
+
+ // ----------------------- I N C L U D E S -----------------------------------
+ #include <sstream>
++#include <cstdint>
+ #include <string>
+
+ // ----------- C L A S S : D T C S t r i n g s B l o c k -------------------
+diff --git a/src/runtime_src/tools/xclbinutil/XclBinSignature.h b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
+index b19ab56a4..f1b72d4d2 100644
+--- a/src/runtime_src/tools/xclbinutil/XclBinSignature.h
++++ b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
+@@ -18,6 +18,7 @@
+ #define __XclBinSignature_h_
+
+ #include <string>
++#include <cstdint>
+
+ // ----------------------- I N C L U D E S -----------------------------------
+
+diff --git a/src/runtime_src/xdp/profile/database/events/vtf_event.h b/src/runtime_src/xdp/profile/database/events/vtf_event.h
+index f8d0121db..b5f36554c 100644
+--- a/src/runtime_src/xdp/profile/database/events/vtf_event.h
++++ b/src/runtime_src/xdp/profile/database/events/vtf_event.h
+@@ -19,6 +19,7 @@
+ #define VTF_EVENT_DOT_H
+
+ #include <fstream>
++#include <cstdint>
+
+ #include "xdp/config.h"
+
+diff --git a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
+index 98c57de2e..6077bd247 100644
+--- a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
++++ b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
+@@ -17,7 +17,8 @@
+ #ifndef XDP_PROFILE_AIE_TRACE_LOGGER_H
+ #define XDP_PROFILE_AIE_TRACE_LOGGER_H
+
+-#include<iostream>
++#include <iostream>
++#include <cstdint>
+
+ namespace xdp {
+
+diff --git a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
+index a88597464..f392ec0e6 100644
+--- a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
++++ b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
+@@ -19,6 +19,7 @@
+
+ #include <fstream>
+ #include <string>
++#include <cstdint>
+
+ #include "xdp/config.h"
+
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0.inc
new file mode 100644
index 00000000..0ef2b1e5
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0.inc
@@ -0,0 +1,13 @@
+REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
+BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
+SRC_URI = "${REPO};${BRANCHARG};name=xrt"
+
+BRANCH= "2023.2"
+SRCREV_xrt = "2865a62b6a417dea523d2d5646154aa94a2cbc28"
+
+SRC_URI += "git://github.com/Xilinx/dma_ip_drivers.git;branch=master;name=dma_ip_drivers;destsuffix=git/src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma;protocol=https"
+SRCREV_dma_ip_drivers = "9f02769a2eddde008158c96efa39d7edb6512578"
+
+SRC_URI += "git://github.com/serge1/ELFIO.git;branch=main;name=ELFIO;destsuffix=git/src/runtime_src/core/common/elf;protocol=https"
+SRCREV_ELFIO = "a04810f12625207cce72665d783babb80f0175a8"
+SRCREV_FORMAT = "xrt"
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0/xrt-cstdint.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0/xrt-cstdint.patch
new file mode 100644
index 00000000..67ca68c6
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202320.2.16.0/xrt-cstdint.patch
@@ -0,0 +1,117 @@
+Add cstdint as necessary
+
+In GCC 13.1 usage of uint64 and similar will result in an error without
+ #include <cstdint>
+
+Signed-off-by: Mark Hatle <mark.hatle@amd.com>
+
+diff --git a/src/runtime_src/core/common/time.h b/src/runtime_src/core/common/time.h
+index a4a96b11d..585d38756 100644
+--- a/src/runtime_src/core/common/time.h
++++ b/src/runtime_src/core/common/time.h
+@@ -19,6 +19,7 @@
+
+ #include "core/common/config.h"
+ #include <string>
++#include <cstdint>
+
+ namespace xrt_core {
+
+diff --git a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
+index 196304765..36ce35e80
+--- a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
++++ b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
+@@ -18,6 +18,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ namespace adf
+ {
+diff --git a/src/runtime_src/core/edge/user/zynq_dev.h b/src/runtime_src/core/edge/user/zynq_dev.h
+index 6fe36c615..2abd7473b 100644
+--- a/src/runtime_src/core/edge/user/zynq_dev.h
++++ b/src/runtime_src/core/edge/user/zynq_dev.h
+@@ -19,6 +19,7 @@
+ #include <fstream>
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ class zynq_device {
+ public:
+diff --git a/src/runtime_src/tools/xclbinutil/CBOR.h b/src/runtime_src/tools/xclbinutil/CBOR.h
+index 368459f59..acbf6ebae 100644
+--- a/src/runtime_src/tools/xclbinutil/CBOR.h
++++ b/src/runtime_src/tools/xclbinutil/CBOR.h
+@@ -22,6 +22,7 @@
+ // #includes here - please keep these to a bare minimum!
+ #include <string>
+ #include <sstream>
++#include <cstdint>
+
+ // ------------ F O R W A R D - D E C L A R A T I O N S ----------------------
+ // Forward declarations - use these instead whenever possible...
+diff --git a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
+index 361015962..1c3bca18d 100644
+--- a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
++++ b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
+@@ -19,6 +19,7 @@
+
+ // ----------------------- I N C L U D E S -----------------------------------
+ #include <sstream>
++#include <cstdint>
+ #include <string>
+
+ // ----------- C L A S S : D T C S t r i n g s B l o c k -------------------
+diff --git a/src/runtime_src/tools/xclbinutil/XclBinSignature.h b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
+index b19ab56a4..f1b72d4d2 100644
+--- a/src/runtime_src/tools/xclbinutil/XclBinSignature.h
++++ b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
+@@ -18,6 +18,7 @@
+ #define __XclBinSignature_h_
+
+ #include <string>
++#include <cstdint>
+
+ // ----------------------- I N C L U D E S -----------------------------------
+
+diff --git a/src/runtime_src/xdp/profile/database/events/vtf_event.h b/src/runtime_src/xdp/profile/database/events/vtf_event.h
+index f8d0121db..b5f36554c 100644
+--- a/src/runtime_src/xdp/profile/database/events/vtf_event.h
++++ b/src/runtime_src/xdp/profile/database/events/vtf_event.h
+@@ -19,6 +19,7 @@
+ #define VTF_EVENT_DOT_H
+
+ #include <fstream>
++#include <cstdint>
+
+ #include "xdp/config.h"
+
+diff --git a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
+index 98c57de2e..6077bd247 100644
+--- a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
++++ b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
+@@ -17,7 +17,8 @@
+ #ifndef XDP_PROFILE_AIE_TRACE_LOGGER_H
+ #define XDP_PROFILE_AIE_TRACE_LOGGER_H
+
+-#include<iostream>
++#include <iostream>
++#include <cstdint>
+
+ namespace xdp {
+
+diff --git a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
+index a88597464..f392ec0e6 100644
+--- a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
++++ b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
+@@ -19,6 +19,7 @@
+
+ #include <fstream>
+ #include <string>
++#include <cstdint>
+
+ #include "xdp/config.h"
+
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb
new file mode 100644
index 00000000..64702022
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Xilinx Runtime(XRT) libraries"
+DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
+
+require xrt-${PV}.inc
+
+LICENSE = "GPL-2.0-or-later & Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
+ file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
+ file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
+ file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 "
+
+S = "${WORKDIR}/git/src"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+# util-linux is for libuuid-dev.
+DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson"
+RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
+
+EXTRA_OECMAKE += " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
+ "
+# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
+# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
+# Note: If meta-openamp is not available, AIE will not be enabled.
+
+EXTRA_OECMAKE:append:aarch64 = " -DXRT_LIBDFX=true"
+DEPENDS:append:aarch64 = " libdfx"
+
+FILES_SOLIBSDEV = ""
+FILES:${PN} += "\
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.so.* \
+ ${libdir}/ps_kernels_lib \
+ /lib/*.so* "
+INSANE_SKIP:${PN} += "dev-so"
+
+pkg_postinst_ontarget:${PN}() {
+ #!/bin/sh
+ if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
+ echo "INFO: Creating ICD entry for Xilinx Platform"
+ mkdir -p /etc/OpenCL/vendors
+ echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
+ chmod -R 755 /etc/OpenCL
+ fi
+}
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb
new file mode 100644
index 00000000..5f6e0034
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Xilinx Runtime(XRT) libraries"
+DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
+
+require xrt-${PV}.inc
+
+LICENSE = "GPL-2.0-or-later & Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
+ file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
+ file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 "
+
+S = "${WORKDIR}/git/src"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+# util-linux is for libuuid-dev.
+DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson"
+RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
+
+EXTRA_OECMAKE += " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
+ "
+# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
+# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
+# Note: If meta-openamp is not available, AIE will not be enabled.
+
+EXTRA_OECMAKE:append:aarch64 = " -DXRT_LIBDFX=true"
+DEPENDS:append:aarch64 = " libdfx"
+
+FILES_SOLIBSDEV = ""
+FILES:${PN} += "\
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.so.* \
+ ${libdir}/ps_kernels_lib \
+ /lib/*.so* \
+ ${datadir}"
+INSANE_SKIP:${PN} += "dev-so"
+
+pkg_postinst_ontarget:${PN}() {
+ #!/bin/sh
+ if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
+ echo "INFO: Creating ICD entry for Xilinx Platform"
+ mkdir -p /etc/OpenCL/vendors
+ echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
+ chmod -R 755 /etc/OpenCL
+ fi
+}
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb
new file mode 100644
index 00000000..cad8ccee
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb
@@ -0,0 +1,56 @@
+SUMMARY = "Xilinx Runtime(XRT) libraries"
+DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
+
+require xrt-${PV}.inc
+
+SRC_URI += "file://xrt-cstdint.patch;striplevel=2"
+
+LICENSE = "GPL-2.0-or-later & Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
+ file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
+ file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 "
+
+COMPATIBLE_MACHINE ?= "^$"
+COMPATIBLE_MACHINE:zynqmp = ".*"
+COMPATIBLE_MACHINE:versal = ".*"
+
+S = "${WORKDIR}/git/src"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+# util-linux is for libuuid-dev.
+DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson libdfx"
+RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
+
+EXTRA_OECMAKE += " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
+ -DXRT_LIBDFX=true \
+ "
+
+# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
+# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
+# Note: If meta-openamp is not available, AIE will not be enabled.
+
+FILES_SOLIBSDEV = ""
+FILES:${PN} += "\
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.so.* \
+ ${libdir}/ps_kernels_lib \
+ /lib/*.so* \
+ ${datadir}"
+INSANE_SKIP:${PN} += "dev-so"
+
+pkg_postinst_ontarget:${PN}() {
+ #!/bin/sh
+ if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
+ echo "INFO: Creating ICD entry for Xilinx Platform"
+ mkdir -p /etc/OpenCL/vendors
+ echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
+ chmod -R 755 /etc/OpenCL
+ fi
+}
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202320.2.16.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202320.2.16.0.bb
new file mode 100644
index 00000000..5824ae9c
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_202320.2.16.0.bb
@@ -0,0 +1,57 @@
+SUMMARY = "Xilinx Runtime(XRT) libraries"
+DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
+
+require xrt-${PV}.inc
+
+SRC_URI += "file://xrt-cstdint.patch;striplevel=2"
+
+LICENSE = "GPL-2.0-or-later & Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=de2c993ac479f02575bcbfb14ef9b485 \
+ file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
+ file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://runtime_src/core/common/elf/LICENSE.txt;md5=b996e8b74af169e7e72e22d9e7d05b06 "
+
+COMPATIBLE_MACHINE ?= "^$"
+COMPATIBLE_MACHINE:zynqmp = ".*"
+COMPATIBLE_MACHINE:versal = ".*"
+
+S = "${WORKDIR}/git/src"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+# util-linux is for libuuid-dev.
+DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson libdfx"
+RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
+
+EXTRA_OECMAKE += " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
+ -DXRT_LIBDFX=true \
+ "
+
+# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
+# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
+# Note: If meta-openamp is not available, AIE will not be enabled.
+
+FILES_SOLIBSDEV = ""
+FILES:${PN} += "\
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.so.* \
+ ${libdir}/ps_kernels_lib \
+ /lib/*.so* \
+ ${datadir}"
+INSANE_SKIP:${PN} += "dev-so"
+
+pkg_postinst_ontarget:${PN}() {
+ #!/bin/sh
+ if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
+ echo "INFO: Creating ICD entry for Xilinx Platform"
+ mkdir -p /etc/OpenCL/vendors
+ echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
+ chmod -R 755 /etc/OpenCL
+ fi
+}