aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb')
-rw-r--r--meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb b/meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb
new file mode 100644
index 00000000..8bd6e6bc
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/python/python3-anytree_2.8.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
+
+HOMEPAGE = "https://github.com/c0fec0de/anytree"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+DEPENDS += "python3-six"
+
+SRC_URI = "git://github.com/c0fec0de/anytree.git;branch=2.x.x;protocol=https"
+SRCREV = "75c0198636f8997967ba00df5077cd21350f68ce"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+do_install:append() {
+ rm -f ${D}/${datadir}/LICENSE ${D}/${prefix}/LICENSE
+ rmdir ${D}/${datadir} || :
+}
+
+BBCLASSEXTEND = "native nativesdk"