aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
new file mode 100644
index 00000000..c10564f4
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
@@ -0,0 +1,24 @@
+include u-boot-xlnx.inc
+include u-boot-spl-zynq-init.inc
+
+XILINX_RELEASE_VERSION = "v2017.3"
+SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded"
+PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
+
+SRC_URI_append = " \
+ file://arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch \
+ "
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
+
+# u-boot-xlnx has support for these
+HAS_PLATFORM_INIT ?= " \
+ zynq_microzed_config \
+ zynq_zed_config \
+ zynq_zc702_config \
+ zynq_zc706_config \
+ zynq_zybo_config \
+ xilinx_zynqmp_zcu102_rev1_0_config \
+ "
+